Jump to content
acad_2k

AutoCad 12 & 13 DOS Issue

Recommended Posts

acad_2k

During the recent cold snap, I decided to go thru my collection of computers, parts and software.  I still have my first two PC's, a Compaq 486 and a HP Pentium 1. I also have my first two AutoCad purchases, R12 DOS and R13 which I used in DOS mode but later in Windows 95. I formatted both hard drives and did a clean install of DOS on both machines and then installed R12 in the 486 and R13 in the 166. 

 

The problem I am having is that when I start Autocad, I cannot access the drawing editor. I get a AutoCad command prompt in the DOS screen. If I type 'open', it asks for a drawing name, so I loaded some R12 sample drawings but Acad cannot access them. Both computers have the exact same problem.

 

I seem to recall having the same problem when I first purchased them back way back and Autodesk walked me thru it.

 

Any suggestions would be helpful.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
acad_2k

I realize that this particular forum is off the beaten path, so if anyone has a suggestion of where to post my question regarding R12 & R13 DOS,  I would greatly appreciate it.

Share this post


Link to post
Share on other sites
eldon

I seem to remember that the search paths had to be loaded every time Autocad was used, with a batch file.

 

I presume that you have done this and have tried typing the full path to where the drawing is.

Share this post


Link to post
Share on other sites
David Bethel

These are cad environment settings I use

 

SET ACAD=\ACAD\12;\ACAD;\ACAD\LIB;\ACAD\FONTS;\ACAD\UT;\ACAD\LIB\BORDERS;\ACAD\FONTS\BIG;\ACAD\KCL;
SET ACADCFG=\ACAD\12
SET ACADDRV=\ACAD\12

In the batch file that starts ACAD for R12 installed in c:\acad\12\

 

 

Edited by David Bethel

Share this post


Link to post
Share on other sites
acad_2k

Thanks for the replies and suggestions. I will give it a shot and report back. It's been a long time since I worked in DOS mode.

Share this post


Link to post
Share on other sites
acad_2k
On 2/18/2019 at 4:43 AM, David Bethel said:

These are cad environment settings I use

 


SET ACAD=\ACAD\12;\ACAD;\ACAD\LIB;\ACAD\FONTS;\ACAD\UT;\ACAD\LIB\BORDERS;\ACAD\FONTS\BIG;\ACAD\KCL;
SET ACADCFG=\ACAD\12
SET ACADDRV=\ACAD\12

In the batch file that starts ACAD for R12 installed in c:\acad\12\

 

 

well, I have to say that I am completely lost. Where exactly do I add these lines? 

 

I gave up on R12 last winter and am now having the exact same problem with R13. I installed it in a Windows 98 machine and can access AutoCAD in Windows, but in DOS Mode, when I open Autocad, I get a Autocad "command" prompt in the DOS screen.

 

From the C:\ prompt, I can find my way to the autocad directory

IMG_1828.JPG

Share this post


Link to post
Share on other sites
acad_2k

I read some of the Autocad R13  "Installation For DOS Guide" and made an attempt to edit the Autocadr13.bat file (I really don't know what the hell I am doing), anyway, here is a screen shot...

 

 

IMG_1840.JPG

Share this post


Link to post
Share on other sites
RetroCAD

Seems like your AutoCAD folder is named "ACADR13" so make sure you are reflecting that correctly in your batch file. In your case it would be:

 

SET ACAD=C:\ACADR13\SUPPORT;C:\ACADR13\FONTS;C:\ACADR13\ADS

SET ACADCFG=C:\ACADR13

SET ACADDRV=C:\ACADR13\DRV

C:\ACADR13\ACAD %1 %2

 

Attached is my ACADR13.BAT for reference.

Photo Dec 19, 7 57 09 PM.jpg

  • Like 1

Share this post


Link to post
Share on other sites
acad_2k

Awesome, will edit it. Thank you

Edited by acad_2k

Share this post


Link to post
Share on other sites
RetroCAD
18 hours ago, acad_2k said:

Awesome, will edit it. Thank you

Glad to help. Let us know how it goes.

Share this post


Link to post
Share on other sites
acad_2k

I updated the file, but no luck. Whenever I start autocad, I get a "command" prompt (COMMAND:) but no drawing editor.

 

 

Share this post


Link to post
Share on other sites
eldon
On 12/20/2019 at 12:11 AM, acad_2k said:

..........From the C:\ prompt, I can find my way to the autocad directory

 

 

When you are there, what happens if you just type "ACAD"

Share this post


Link to post
Share on other sites
David Bethel

I know R12DOS required this. 

I think R13DOS did as well.

 


In  'c:/windows/system/' : verify this file exists

PHARLAP.386

 

 


In 'c:/windows/' : Edit/Add/Verify  'c:\windows\system.ini'


>
[386Enh]
device=pharlap.386
<
 

 

This is one of the main problems for ACAD when trying to setup virtual machine for DOS.

 

Win98SE should work fine.

 

 

-David

 

 

Share this post


Link to post
Share on other sites
RetroCAD
8 hours ago, acad_2k said:

I updated the file, but no luck. Whenever I start autocad, I get a "command" prompt (COMMAND:) but no drawing editor.

 

 

 

This sounds like a configuration problem.

 

At the Command: prompt, please type “config” and press enter. You will be presented with a screen that shows your current configuration. For reference I am attaching the screen I see when typing this command. Please take a photo of what you see and post it here.

903E19BD-64F2-47C9-8F17-EB474B462B9D.jpeg

Share this post


Link to post
Share on other sites
acad_2k

Thanks guys for the responses. I'm sure I've mucked up the OS settings so I just formatted the hard drive and am doing a fresh install of DOS 6.21 on my Compaq 486 machine.  Will upload some screen shots after AutoCAD R12 is installed.

Share this post


Link to post
Share on other sites
acad_2k

When I first start AutoCAD from the DOS prompt, C:\, the start-up page reads:

 

"BASE.dcl" : Can't open file

Error loading dialog control file

Press RETURN to continue 

 

RETURN

 

prototype drawing acad is not on file. Using defaults

Press RETURN to continue

 

RETURN

 

login was successful

"TXT.shx"

can't open file

 

RETURN

 

enter another font file name for style STANDARD (or RETURN for none)

 

RETURN

 

"ACAD.mnu"

can't open file

 

RETURN

 

enter another menu file name (or RETURN for none)

 

RETURN

 

Command:

 

So now I will try "config" at the command prompt.

 

video, digitizer, plotter configs that I chose during install (none) are what is displayed

 

RETURN

 

Configuration menu:

 

0: exit to drawing editor

1: show current config

2: allow detailed config

3: config video

4: config digitizer

5: config plotter

6: config system console

7: config operating parameters

 

Enter selection (0): 

 

I'll wait at this stage for instructions

 

Share this post


Link to post
Share on other sites
RetroCAD

What video did you configure for AutoCAD?

Share this post


Link to post
Share on other sites
RetroCAD

All of the “Can’t open file” messages indicate that you need to use a batch file like the one we were initially working on. Those SET strings are used to tell AutoCAD where to find those files.

Share this post


Link to post
Share on other sites
acad_2k
29 minutes ago, RetroCAD said:

What video did you configure for AutoCAD?

I used "null" display. The options given were unfamiliar.

Share this post


Link to post
Share on other sites
RetroCAD
20 minutes ago, acad_2k said:

I used "null" display. The options given were unfamiliar.


That is the problem. Select VGA instead.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...