Jump to content
Pukenzz

Publish problems

Recommended Posts

Pukenzz

We recently got a new plotter Cannon TX-3000

 

When plotting I can plot a single layout tab and choose multiple qtys – success

When publishing multiple tabs I can choose (1) qty and plot with success

When publishing multiple tabs it will let me choose multiple qty but it errors out and will not send successfully

 

It worked fine on our old plotter but not now with this new plotter 

 

IT has work arounds, Cannon rep has work arounds, but I’m looking for a solution 

 

Has anybody run into this and can you share your fix?

Share this post


Link to post
Share on other sites
ammobake

What is the error message you're getting? Is the error associated with the PC3 file for that printer?

 

Also, are you using 1 page setup for all your sheets or does the page setup vary by sheet/tab?

 

-ChrIS

 

Share this post


Link to post
Share on other sites
BIGAL

I went away from publish and do a plot range of layouts lisp, it could have how many added but would plot sets, one after the other.

 

Like ammobake it works for one size title block only. Happy to post a revamped version, need your title block in a dwg or limits x,y as it uses window for the selection area.

Share this post


Link to post
Share on other sites
Pukenzz
WARNING: Incompatible or missing plot style
ERROR: Error
Not sure how to identify if the error is associated with that PC 3 but when I publish qty (1) it works fine
Yes it will be the same page setup for all sheets
 
BIGAL...  Would you be willing to share your lisp?

Share this post


Link to post
Share on other sites
BIGAL
Posted (edited)

Not a problem will post soon will add some comments about what to change for your plotter.


; Plotter name, paper size and ctb need to be changed
; lower left co-ords and upper right need to be changed

; set to a A1 sheet title block 1:1 ie approx 840x594

(COMMAND "-PLOT" "Y" "" "\\\\yourserver\\your printer" "A1" "m"    "LANDSCAPE"   "N"   "W"  "-6,-6"    "807,560"    "1=1"  "C"
           "y"  "Designlaser.ctb" "Y" "N" "N" "N" "N" "N" "y" )

Plot-Range-plotter.LSP

Multi GETVALS.lsp

Edited by BIGAL

Share this post


Link to post
Share on other sites
Pukenzz

I tweaked your lisp as noted and attempted to run.  I'm getting the following error...

 

; error: no function definition: AH:GETVALSM

Share this post


Link to post
Share on other sites
BIGAL
Posted (edited)

Sorry you will need this its a library dcl routine can use in any lisp

Multi GETVALS.lsp

Edited by BIGAL

Share this post


Link to post
Share on other sites
Pukenzz

Works great.  But I'm a little confused...  Run it from a button or keyboard, what is the command?  It looks like AH or pltlays but neither runs the plot for me.

Share this post


Link to post
Share on other sites
maratovich

Pukenzz

Attach an example of your file.

Share this post


Link to post
Share on other sites
Pukenzz

It is the files above shared by BIGAL

Share this post


Link to post
Share on other sites
maratovich

Pukenzz

Attach an example of your .dwg file.

Share this post


Link to post
Share on other sites
maratovich

Pukenzz

This will automatically install all printer settings (example of your file):

https://youtu.be/8dwQoW8uh7w

Share this post


Link to post
Share on other sites
Pukenzz

Thanks maratovich.  Looks pretty powerful.  Unfortunately, I have guys that struggle to use and understand the batch plot, general layer usage, what plot styles do, etc.  This KDM software will be way too complex for them and my company will likely push back on spending $.  I was hoping to understand how to run the Plot-range-plotter.lsp  with a defun C entry so I can just attach it to the macro of a custom button and click button...  poof, it plots.

Share this post


Link to post
Share on other sites
BIGAL
Posted (edited)

I run it as a menu option,  [Plot - plotter]^c^c^p(load "Plot-range-plotter")  it will autorun as the last line calls the program. (AH:pltlays) same for a toolbar icon etc. 

 

Please note  as it uses a window you will need to change the window co-ords to match your title block, -6,-6 807,560 and it must have your plotter name and ctb etc.

 

I do have a move all titles to 0,0 if you need it.

 

Any probs just ask here.

 

image.png

Edited by BIGAL

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...