Jump to content
addesigns

Right Click Shortcut Menu

Recommended Posts

addesigns

Running Civil 3D 2018.  Having issues with Right click.  I want it to act like the enter command ONLY while I am in a command.  I am used to the following for example.

1. Type L and hit enter

2. Left click where I want my line to begin, move my cursor and then left click again to end the line, then Right click to end the command.

 

Problem I am running into is that the right click always brings up the shortcut menu and that is NOT what I want it to do.  I want it to cancel out of the command.  I have checked the User Preference settings and no matter what combination I do it will NOT let me allow that to happen.  It wants to bring up the shortcut menu no matter what. 

 

Is there a system variable or two or three that I need to change as well?  I have been an autocad user for 10 years now and can always figure out what the heck is going on. This one is really annoying me.

 

Any help is great.

 

 

Share this post


Link to post
Share on other sites
BIGAL

Hit the spacebar !

Share this post


Link to post
Share on other sites
addesigns

Again, I was hoping for an actual real answer.  thanks though.  I can solve this on my own.

Share this post


Link to post
Share on other sites
Romero

@Addesigns For the click to work as you wish, just change the value of the variable SHORTCUTMENU to 27 😀

Share this post


Link to post
Share on other sites
BIGAL

I was not kidding the space bar is a real big button easy to find and for stuff like ->  L spacebar pickpt pickpt spacebar it works ! It is as fast as finding the right button may even be faster.

 

I do post funny stuff at times but this was a legitimate answer.

Share this post


Link to post
Share on other sites
addesigns

Yeah I hear ya.  Didn't mean to make it sound like it did.  Was a frustrating day.  I def have been using the spacebar in place of the right click.  I just was so used to the right click that I didn't want to change my ways (go figure).  Anyway, the shortcutmenu variable to 27 seems to be doing the job as well.  At least now I have a few solutions.

 

Many thanks folks.  This IT ticket can be considered closed.

Share this post


Link to post
Share on other sites
BIGAL

No worries just me I use space bar.

Share this post


Link to post
Share on other sites
RobDraw

Have you looked in the right click settings? These are my settings which gives you the behavior that you are seeking. If you want to change the grayed out options, uncheck the "Turn on time-sensitive right click". Check it again after changing the settings if you use it.

 

 

22524495_RightClick.jpg.f42675fcaf034b715a380ac4edde51f9.jpg

 

Share this post


Link to post
Share on other sites
addesigns

RobDraw

I have tried those settings as it made sense that it should behave how I want it to.  For some reason thought it would still behave differently.  That is when I though maybe there was a system variable that needed to change as well.  It wasn't until Romero suggested that I change the SHORTCUTMENU variable to 27 that it started working properly.  I don't know.  It seems to be working now just fine if I change the variable but unfortunately I am mostly using MicroStation now since I am in the Civil world.  

 

I don't hate MicroStation, just wish I was using AutoCAD more often than just the few clients that require it. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...