Jump to content
sketch11

Paste as Block greyed out

Recommended Posts

sketch11

If I copy objects, then delete, "Paste as Block" is greyed out from the right click menu.

If I don't delete objects then it work.

 

If I start a brand new drawing, the issue goes away.

 

Why does this happen?

Share this post


Link to post
Share on other sites
Cad64

I can't replicate this issue on my end. Maybe there's a problem with the drawing that you're working in. Try running an Audit and see if it fixes any errors, then try to copy/paste again.

Share this post


Link to post
Share on other sites
sketch11

Yes it does actually work. Thanks.

Share this post


Link to post
Share on other sites
sketch11

After trialing, it does work sometimes but at other times it doesn't. Sometimes I have to close the drawing at least once and Audit at least twice.

Was there another command?

Share this post


Link to post
Share on other sites
Cad64
5 hours ago, sketch11 said:

Was there another command?

 

No, but if you're copying from one drawing and pasting into another, you could be reintroducing the same errors again and again, which would explain why you have to keep running Audit. Make sure all your drawings are clean and free of errors.

Share this post


Link to post
Share on other sites
tombu

Why not Paste as Block before deleting rather than take a chance on losing those objects?

Messy way of creating blocks with unintelligible names. If you explain what you're trying to accomplish you may get some useful suggestions.

 

I added a "Paste as Group" to the 5 Paste options installed with AutoCAD and use RCDATA_16_NEWGROUP as the image for it.  This is the macro for it: 

^C^C_pasteblock;\(setq LstBlk(vla-get-Name (vlax-ename->vla-object (entlast))));_explode;_last;_-group;_create;*;;_previous;;(command "-purge" "B" LstBlk "N")(setq LstBlk nil)

 

Share this post


Link to post
Share on other sites
sketch11
Quote

Why not Paste as Block before deleting rather than take a chance on losing those objects?

Because this is painful when you have a lot of objects selected.

 

"tombu" Thanks for the option of the macro. I tried this and it works.

 

Thanks to both for your input.

  • Like 1

Share this post


Link to post
Share on other sites
tombu

Glad it worked out for you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...