Jump to content
Silvercloak

Creating a Plan View Pipe Mask for Fittings

Recommended Posts

Silvercloak

Hi,

 

    One problem I've having is getting my fittings to appear when the drawing is plotted.  I can't get convertlineworktomaskblock to mask any plan view pipes.  Nor does wipeout seem to help me.  I've created a Valve style and tried to use part mask to mask the pipe out.  Right now I'm getting this;

 

image.png.b7da9fe37306730677800456cc045ec7.png

 

When what I actually want is more like this;

image.png.32844fa226d379f7abef55cadcfa7728.png

 

I really do NOT want to go back to just using polylines and blocks.  Please tell me there's a solution to this.

 

Silvercloak

Share this post


Link to post
Share on other sites
BIGAL

Draw order can be quite critical when using wipeout I had underlying, then mask, then new over top in mask area. From memory do backwards draworder top 1st.

Share this post


Link to post
Share on other sites
Silvercloak

That's the first thing I tried.  It hasn't made a difference.  I'm absolutely baffled as to why this isn't working.  I know it CAN work because I had Null structures that were breaking the pipe previously that I used to turn off when I didn't need to see them.  Now even they aren't breaking the pipe with part mask.  I'm completely baffled as to what changed to make this pipe seemingly indestructible. :P

 

Silvercloak

Share this post


Link to post
Share on other sites
steven-g

Cany you post an example file, so we can see what is going on.

Share this post


Link to post
Share on other sites
SLW210

This seems to be a Civil 3D issue.

Share this post


Link to post
Share on other sites
Silvercloak
4 hours ago, SLW210 said:

This seems to be a Civil 3D issue.

Thanks for moving the thread.  I'll try to keep my questions here in the future.

Share this post


Link to post
Share on other sites
Silvercloak
10 hours ago, steven-g said:

Cany you post an example file, so we can see what is going on.

Here's an example file.  I've tried to limit what I show and stripped the file down so I don't post anything proprietary from my company.  However this should suffice to show what I'm dealing with right now.

 

Thanks Steven,

 

Silvercloak

Pipe Example.dwg

Share this post


Link to post
Share on other sites
BIGAL

Worked for me just did draworder. kept wipeout outline so can see. Make sure your wipe out is on a plot on layer.

image.png.0feb66a639e0aa89a5c1b463c7acaf34.png

Edited by BIGAL

Share this post


Link to post
Share on other sites
Silvercloak

Is that structure masking or just a wipeout separate from the structure?

Share this post


Link to post
Share on other sites
BIGAL

Separate wipeout, the valve is a Aecc object I haven't used so if a block maybe check wipeout draw order.

 

I bedited PWBEGV and added a wipeout, then draw order to back, save new block, seems to have worked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...