Jump to content
daveCAAAAAD

Wrong Units??

Recommended Posts

daveCAAAAAD

Hi There,

 

Im new to Autocad and have drawn in model space some floor plans for a build, I have completed my drawing but I think I have made a mistake as I changed dimensions to milimeters and set the decimal to 0.000. and as I have gone on to draw for example a measurement that should read 90mm I have entered as 0.090. is there an easy way to change my whole drawing so that it is reading correctly as when I went to move it to layout it came through as a very minuscule drawing in the bottom corner?

 

Any help with this would be greatly appreciated.

Share this post


Link to post
Share on other sites
ReMark

Which AutoCAD template file did you start with?  The two obvious choices are acad.dwt and acadiso.dwt?  The first, and default, is used for Imperial based drawings.  The second is used for Metric drawings.

  • Like 1

Share this post


Link to post
Share on other sites
daveCAAAAAD

Hi Remark,

 

As being new as self taught I'm unsure, I did click on the start drawing button to get started though.

 

Share this post


Link to post
Share on other sites
Berzerker

If you didn't draw it at 90mm (1:1) and just want the dimension to reflect that number try the DIMEDIT command. just type the command in the command line and when it asks you what you want select "new", a text box will appear and then type the numbers you want it to be and then select the dimension you want to be changed to that.

 

I'm old and have never used the metric system for drawing but have had to use it here lately for 3D print reasons.

Always set you units before you start a drawing, always draw at 1:1 scale.

No you don't have to but it saves a lot of fixing later on.

Also when your in the layout tab double click inside the layout window and now you should be able to zoom into any part of the drawing you want and place it where you want in that window.

Edited by Berzerker

Share this post


Link to post
Share on other sites
CyberAngel

By "layout" I assume you mean paper space. You should set the scale of the viewport to fit the size of your output, taking into account any title block you need (if any).

 

Also check the dimension style to make sure the scale factor is 1 (open the dimension style in the Dimension Style manager and look under the Primary Units tab). That could explain why the dimension value is off.

 

The more information you can give us, the better we can help you.

Share this post


Link to post
Share on other sites
Dana W

If this is an employment situation, overriding or editing dimensions including the dimension scale factor, could have a detrimental effect on your employment status.

 

There is a command, -DWINGUNITS, which can be used to reset or re-scale your entire drawing to the correct units.  However, it is important to have some understanding of what the command is going to ask you and what you want it to do for you before you use it.  Notice there is a leading hyphen.  it is required. 

 

Perhaps before running that command, you need to undo whatever you have done to your dimension style, and/or using the command UNITS.   Please understand that the command UNITS does not change your drawing units, it only changes the label YOU have given the unit.

 

Perhaps it you upload a copy of your drawing along with telling us what units you want to use, one of us can remedy your predicament for you while explaining how to determine your units and viewport scale up front.

  • Funny 1

Share this post


Link to post
Share on other sites
Dana W
1 hour ago, Berzerker said:

"double click inside the layout window" 

That word "window".  I see you are catching on.  Hole in the paper, hole in the wall, no difference. 👍😆

Edited by Dana W

Share this post


Link to post
Share on other sites
Dana W
5 minutes ago, Dana W said:

If this is an employment situation, overriding or editing dimensions including the dimension scale factor, could have a detrimental effect on your employment status.

That is because there are estimators and tradesmen who will actually measure a drawing for their own purposes, and if it is not to a standard scale and labeled as such, they are hanging in the wind.  Never mind that an industry wide rule of thumb says "NEVER measure a drawing, use the printed dimensions." 

Share this post


Link to post
Share on other sites
Berzerker

Here's what He said that made me think it may have been him that edited the dimension.

4 hours ago, daveCAAAAAD said:

for example a measurement that should read 90mm I have entered as 0.090.

You don't enter a dimension, you place a dimension.  I don't know if He typed (drew the object at .090mm) when he was drawing it or edited it afterwards. If it was drawn at 90mm it should measure 90mm or dimension at 90mm should I say. There should be no .090mm numbers.

The window thing is just how I see it or explain it. I get the hole in the paper thing now but it just don't fit how I look at it.

I just went and changed to the metric system drew a 90mm line and I get this.

90mm.PNG

 

I guess what I'm saying is I don't know if was actually drawn at 90mm to begin with. If it says .090mm then it was drawn at .090mm.

Edited by Berzerker

Share this post


Link to post
Share on other sites
Dana W

Yup, the dimension thing works real well when one starts out with the correct drawing units.  I agree completely.

  • Like 1

Share this post


Link to post
Share on other sites
Berzerker
9 hours ago, daveCAAAAAD said:

As being new as self taught I'm unsure, I did click on the start drawing button to get started though.

I also taught myself AutoCad. Did I learn somethings the wrong way....Yes I did. The people here are great. Just remember there's no such thing as a stupid question and we all do things  a little different. One might tell you this or that way but they all are here to help.

 

7 hours ago, CyberAngel said:

By "layout" I assume you mean paper space.

 I know you all call it that but for years all I've seen at the bottom of my screen is "Layout1 and Layout2" so it's kinda like burnt in.

Edited by Berzerker

Share this post


Link to post
Share on other sites
Dadgad

As Dana suggested, and to reinforce what ReMark said.

 

Should you find yourself working on a drawing, from or by anyone, about which you are curious, the   " -DWGUNITS " command is the way to go.

Ideally, one should set one's default template to reflect the measuring system and units, in which one typically works.

 

In addition to the issue of Imperial or Metric systems of measure, is the question of what UNITS to work in.

Does a value  of 1 represent one lightyear, one mile, one kilometer, one yard, foot, inch, one meter, one centimeter, one millimeter...you get the picture.

The answer to that question will be supplied by your UNITS value,as you follow the prompts through -DWGUNITS.

 

Save a copy of your drawing, upon which to experiment with -DWGUNITS.

Expanding your commandline history window to display about 10 lines will help a lot to understand what is going on in the command.

Read the commandline prompts carefully and move slowly through the dialog.

 

image.thumb.png.f08015d350f6defacc2dbf05b8633eaa.png

 

If you run the MEASUREMENT command, the commandline response of <0> means you are working in Imperial, a response of <1> indicates Metric.

Once you have a completed drawing reflecting all of the values and preferences with which you typically work, use the SAVEAS command, and in the dropdown menu select .DWT, which means you are saving that as a Template, for later use.  See  the last screen shot.

 

image.thumb.png.550ce3d46b385f02439fa3a1b5b41868.png

 

In this dialog you can choose which .DWT to use as your DEFAULT template, every time you start a new drawing, this template will be opened, UNLESS

you actively override it and choose a different .DWT.

image.thumb.png.cd274822c1644f9952098f5f4b477ba5.png

 

 

 

Edited by Dadgad
typo.
  • Thanks 1

Share this post


Link to post
Share on other sites
Dana W

Now that I am retired, (or is it untired?) I work exclusively in whiskers.

  • Like 1

Share this post


Link to post
Share on other sites
Berzerker
23 hours ago, Dana W said:

If this is an employment situation, overriding or editing dimensions including the dimension scale factor, could have a detrimental effect on your employment status.

@Dana W 

I wanted to also say that I would never tell someone to do anything to hurt their job or career. 

Dave did post this:

On 10/12/2020 at 6:59 AM, daveCAAAAAD said:

As being new as self taught I'm unsure, I did click on the start drawing button to get started though.

As I said I also taught myself AutoCad. I consider myself pretty good at 2D drawing and have just started to learn 3D. But even I wouldn't think I have the skills to draw a house or building or room. There are just too many things you need to know besides how to draw something in AutoCad or any other drafting program to do this professionally.

Dave's post above just made me think this is a personal project he was doing for himself.

So Dave if this is for a job....Don't edit dimensions. I would fix the length by stretching it or redrawing it altogether.

  • Like 1

Share this post


Link to post
Share on other sites
Dana W


Yeah, I was replying to Dave, more or less, so the neophytes in the room would pick up on it.   When you override a dimension you have to math the others connected to it and the chances of error are high.  Besides, overridden dimensions are camouflaged unless you check the object properties, making them impossible to manage for another person modifying the drawing.

 

I've been doing this since 1971 on the board, 1982 on the computer, 2004 in AutoCAD, and I still feel like a beginner in AutoCad.

  • Like 1

Share this post


Link to post
Share on other sites
daveCAAAAAD

Hi Guys, 

I have fixed the problem with the -dwgunits command and checking all dimensions, though I have decided to redraw the whole drawing with some of the pointers as mentioned above, setting the right settings to begin with is a lot easier, thanks everyone for your help its greatly appreciated. might here from some of you when I run into my next problem.

Thanks,

Dave.

Share this post


Link to post
Share on other sites
Dadgad

Glad we could help get you back on the tracks.

It sounds like you manually checked all of your dimension.

Much easier to do that in your QuickProperties, as shown.

 

You can see that in the lower screenshot I have selected one set of dimensions

and entered <> into the Dimension TEXT Override field, which undoes any measurements which you fudged, and makes them display their

true values.  :thumbsup:

 

image.thumb.png.99b13a90e47df005763f31fa9757234f.png

 

image.thumb.png.fd2557fd2d171da073cae327f059a764.png

 

 

 

 

 

 

Edited by Dadgad
minor correction

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...