Jump to content
itacad

Problem with XREF aspect

Recommended Posts

itacad

Hello, I have a problem with an XREF file.
From various operators I receive "source files" concerning the various architectural and plant parts.
I don't want to modify these files, I want to leave them as I receive them (colors, freezing layers ...).
I use these files to create a "base file" that I conceptually call "XREF TOTAL", this file is created through the insertion of "source files" loaded as single XREFs.
In this "XREF TOTAL" file I apply all the settings I need (color, layer freezing etc etc...).
The problem is: when I load the "XREF TOTAL" file (real name XREF05 PRIMO.dwg) in the "working files", it loads with the "source files" settings, even changing the value of the visretain variable...why?

 

thank you in advance for help and suggestions

 

image.png.ffc9aa1243f0ae33cd171579ae9d72f9.pngProblem with XREF aspect.dwg

 

 

Problem_with_XREF_aspect_EXAMPLE.zip

Share this post


Link to post
Share on other sites
ammobake

I came across this link

https://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/AutoCAD-Core/files/GUID-5070C6C7-EAEF-45F0-ABB8-F894E585C54D-htm.html

 

I will paste the relevant part here:

 

The XREFOVERRIDE system variable affects display and plotting, and works in conjunction with the VISRETAIN system variable. Consider these scenarios:
  • If you want the xref layers to retain their layer settings, it is recommended to set VISRETAIN and XREFOVERRIDE system variables to 0.
  • If you want the xref layers to retain the overrides you made in the current (host) drawing, it is recommended to set VISRETAIN to 1.
This assumes that the visual properties on the external reference objects are set to ByLayer.
  • When XREFOVERRIDE is set to 1, objects on xref layers are treated as if their properties are set to ByLayer.
  • When XREFOVERRIDE is set to 0, objects on xref layers honor their object property assignments.

The VISRETAINMODE system variable provides you with more options on how you want to control and manage the xref layer property overrides in your current (host) drawing when you have set VISRETAIN to 1. By default, the VISRETAINMODE, a bitcoded system variable, is set to 0. To specify more than one layer properties that you want to automatically sync, enter the sum of their values. You can choose any combination for the xref layer properties that you want to reload from the referenced layer settings even when you have set VISRETAIN to 1. But, if you do not want to synchronize xref layer properties, you should keep the default value for VISRETAINMODE.

Legacy Drawings and Xref Layer Property Overrides Settings

If you have a legacy drawing, which you opened in AutoCAD 2018.1 or later versions, any changes to the referenced layer property will not get updated automatically in the current drawing regardless of what value you have set for your VISRETAINMODE sysvar (changed the default value). This behavior ensures that anytime you open a drawing that is authored in an earlier version of AutoCAD 2018.1, it maintains the visual fidelity between AutoCAD 2018.1 and previous AutoCAD releases and there is no change in behavior.

To make VISRETAINMODE take effect for legacy drawings, you need to save the current drawing in AutoCAD 2018.1 and reload the xref drawing to see the changes.

 

 

 

 

 

 

Edited by ammobake
  • Like 1

Share this post


Link to post
Share on other sites
tombu

Once the "XREF TOTAL" layers were set I'd save an "XREF TOTAL" Layer State. Then any drawing I copied those xrefs into with Design Center I'd simply import that Layer State making sure VISRETAIN was set to 1 (default) in all my drawings.

Share this post


Link to post
Share on other sites
itacad

Oh thanks! I was trying to solve the problem only by setting the variables and I didn't think about the Layer State!

Thanks you solved the problem!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...