Jump to content
slimjramirez

Draw Order not working correctly

Recommended Posts

It seems as though my draw order is 'locked'. The command is recognized; but it doesn't seem to work properly.

 

I essentially have two lines, drawn right on top of eachother; I go to get the one underneath and bring to front/send to front, or send the top line to the back, etc. and nothing changes at all.

 

I've found a way to get what I need done completed so I don't need a solution, but is there some variable I'm not aware of that affects the use of draw order?

Share this post


Link to post
Share on other sites

have you done a purge and regen - just coz AutoCAD is strange like that sometimes

Share this post


Link to post
Share on other sites

Purging and the SORTENTS didn't help.

 

However using DRAWORDER, then referencing the object I needed to get this one line under worked. The Draw Order toolbar doesn't seem to help but the written command does

Share this post


Link to post
Share on other sites
it isn't a PICKFIRST problem is it?

 

what's your PICKFIRST set to?

 

Rah! this is a handy thing to know about, but it didn't help when alternating between 0 and 1.

 

I think this may have just been a freak event; I just finished the drawing, went to open another,

 

"Command "Open" Unknown"

"Command "Close" Unkown"

"Command F***YouCAD" Unknown"

-qsave

-quit

:lol:

Share this post


Link to post
Share on other sites
Rah! this is a handy thing to know about, but it didn't help when alternating between 0 and 1.

 

I think this may have just been a freak event; I just finished the drawing, went to open another,

 

"Command "Open" Unknown"

"Command "Close" Unkown"

"Command F***YouCAD" Unknown"

-qsave

-quit

:lol:

 

I should set that command up to give a big "F***U2" on the screen. :lol:

Share this post


Link to post
Share on other sites

Try the variable:

treedepth

if it is set to 0, it will give you the problem you are describing.

set it to 3020.

 

Type: Integer

Saved in: Drawing

Initial value: 3020

Specifies the maximum depth, that is, the number of times the tree-structured spatial index can divide into branches.

 

0 Suppresses the spatial index entirely, eliminating the performance improvements it provides in working with large drawings. This setting assures that objects are always processed in database order, making it unnecessary ever to set SORTENTS.

>0 Turns on spatial indexing. An integer of up to five digits is valid. The first three digits refer to model space, and the remaining two digits refer to paper space.

Note You cannot use TREEDEPTH transparently.

Share this post


Link to post
Share on other sites

I had this problem today and found this answer and it worked for me. Great job, CADMANGOD.

 

Try the variable:

treedepth

if it is set to 0, it will give you the problem you are describing.

set it to 3020.

 

Type: Integer

Saved in: Drawing

Initial value: 3020

Specifies the maximum depth, that is, the number of times the tree-structured spatial index can divide into branches.

 

0 Suppresses the spatial index entirely, eliminating the performance improvements it provides in working with large drawings. This setting assures that objects are always processed in database order, making it unnecessary ever to set SORTENTS.

>0 Turns on spatial indexing. An integer of up to five digits is valid. The first three digits refer to model space, and the remaining two digits refer to paper space.

Note You cannot use TREEDEPTH transparently.

Share this post


Link to post
Share on other sites
I had this problem today and found this answer and it worked for me. Great job, CADMANGOD.

 

I completly agree, this finally solved my display problem with TEXTTOFRONT not working properly.

Now that is selt the TREEDEPTH variable to 32767 (max. value) everything is working fine.

 

Thanks a lot!

utor

Share this post


Link to post
Share on other sites

The visual style will also affect draw order. I believe Draw order only works in the traditional 2d visual style (or at least thats what i was told)

Share this post


Link to post
Share on other sites

The default for TREEDEPTH is 3020, so if you have something else it has been altered.

Share this post


Link to post
Share on other sites
Sometimes when I change the draw order of objects the results don't show until after a regen.
That is normal.

Share this post


Link to post
Share on other sites
have you done a purge and regen - just coz AutoCAD is strange like that sometimes

 

Yeay...it works after purge and regen. Thanks man

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×