Jump to content
dej-b&v

Unlocked Viewport - Zoom Extents

Recommended Posts

dej-b&v

Hopefully a simple question

 

This only happens on one drawing so I suspect there is a system variable set incorrectly.

 

When clicking into an unlocked viewport, to switch from paper to model space, the viewport automatically zooms to extents. Does anyone now how to disable this.

 

Thanks in advance.

 

dej-b&v

Share this post


Link to post
Share on other sites
Tiger

UCSFOLLOW I think it is...change it to 0 and see what happens

Share this post


Link to post
Share on other sites
dej-b&v

Thanks for the quick response.

 

UCSFOLLOW is the setting.

 

For others with similar problem. It seems UCSFOLLOW is set for each viewport. So by setting it to 0 subsequent viewports wotk normally, but previously drawn viewports need setting individually.

Share this post


Link to post
Share on other sites
Dipali
Hopefully a simple question

 

This only happens on one drawing so I suspect there is a system variable set incorrectly.

 

When clicking into an unlocked viewport, to switch from paper to model space, the viewport automatically zooms to extents. Does anyone now how to disable this.

 

Thanks in advance.

 

dej-b&v

 

:shock:

As far as I know, it should happen in all unlocked viewports.:?

Are u sure it the cas with only one drawing?:o

Share this post


Link to post
Share on other sites
dej-b&v

This is the first time I have come across a drawing in which USCFOLLOW has been set to 1. Checking other drawings I have/use it is always set to 0 problably why I have never had this problem before.

Share this post


Link to post
Share on other sites
Dipali
This is the first time I have come across a drawing in which USCFOLLOW has been set to 1. Checking other drawings I have/use it is always set to 0 problably why I have never had this problem before.

 

:shock: now this is even more surprising. Because I always want to keep 'ucsfollow' to '1' in most of my drawings, but it gets reset to '0' as soon a s I close the dawing & I have to resrt it to '1' every tme i open the drawing. and have not found the way to do that in any thread here:?

so how come you have it '1' in most of your drawings?:?

Share this post


Link to post
Share on other sites
Tiger

How come you have UCSFOLLOW set to 1 in your drawings Dip? What is advantage of that?

Share this post


Link to post
Share on other sites
Dipali
How come you have UCSFOLLOW set to 1 in your drawings Dip? What is advantage of that?

 

one of my current project has one building which is not at same angle as the other building so to work on that building I need to rotate ucs.

Also for elevations of all my project we draw it around plan on its respective sides (in pinwheel fashion) so to work on them we need to rotate ucs constantly.

we usually create named ucs in all the files where required but ucs follow have to be set to 1 to rotate the ucs everytime we reopen the draiwng.

Share this post


Link to post
Share on other sites
Tiger

hmm, not quite sure I follow you Dip... but if it works for you, then it's great :D

Share this post


Link to post
Share on other sites
Hedgehog
:shock: now this is even more surprising. Because I always want to keep 'ucsfollow' to '1' in most of my drawings, but it gets reset to '0' as soon a s I close the dawing & I have to resrt it to '1' every tme i open the drawing. and have not found the way to do that in any thread here:?

so how come you have it '1' in most of your drawings?:?

It shouldn't reset on open or close unless you have a line written into your start-up lisp (possibly inserted by some helpful person aware of this very problem).

I used to write macro's for switching ucs's & views which set ucsfollow on & off again on exit (I use the plan command now :wink: )

Share this post


Link to post
Share on other sites
Dipali
It shouldn't reset on open or close unless you have a line written into your start-up lisp (possibly inserted by some helpful person aware of this very problem).

I used to write macro's for switching ucs's & views which set ucsfollow on & off again on exit (I use the plan command now :wink: )

 

Hedge

:? now i really need to get to the bottom of this.:huh:

I run LT, so no customised lisps. There is no one in my office that knows about lisps........including me.

 

so can you think of anythting else hedge, which causes it to reset in all my files?

 

BY THE WAY

If any of the 'mod' feels to move this issue in its own thread, Please do so. I will be very happy, if I can find the soluton.........

Share this post


Link to post
Share on other sites
Hedgehog

I don't have a copy of LT to test it on... could be that it's been set as standard. Maybe someone else can help :)

Share this post


Link to post
Share on other sites
Peter K

One way to prevent that your viewport zoom extends is by not only using the UCSFOLLOW but more importantly by settings UCSVP to 0 as well as UCSFOLLOW TO 0 while being in the viewport in paperspace.

 

When checking the UCSFOLLOW variable on my version of 2008 LT it appears that the variable in question gets set to "0" in paperspace as well as modelspace but it does stay "1" in viewport modelspace.

 

Hope this helps

 

PS: setting the variable(s) even in LT is possible by making your own acad.lsp or acaddoc.lsp file if you're using LT-extender or Drcauto

or by creating a start.scr file if you just use plain LT 2008

Share this post


Link to post
Share on other sites
tonybolony

WOW - thanks for this one... been buggin me in some of my drawings!

tony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×