Jump to content
chavlji

RefEdit is not locking the objects ?!?

Recommended Posts

chavlji

Hello I use the following command in lisp to get into ref edit mode:

(command "-RefEdit" "ok" "all" "yes")

But entering editor this way it does not lock other objects (objects that are not inside block/xref).

If I use standard refedit with dialog under "settings" there is an option "lock objects not in working set". It is always checked. But how to trigger this option from lisp? I monitored sysvar changes (using reactor), but no sysvar is changed...

 

Intrestingly:

If I refedit with dialog once, from then on even my lisp code locks other options. So refedit dialog setts something that I should set from lisp... but what?

Share this post


Link to post
Share on other sites
borgunit

Normally Autocad stores settings in the registry. Look under the registry in the current Autocad profile you are using.

Share this post


Link to post
Share on other sites
wizman

followup to borgunit's reply:

 

 

in my acad 2008(unnamed profile):

 

(VL-REGISTRY-READ "HKEY_CURRENT_USER\\Software\\Autodesk\\AutoCAD\\R17.1\\ACAD-6001:409\\Profiles\\>\\Dialogs\\RefeditDialog" "LockObjects") => 0

 

to change:

(vl-registry-Write "HKEY...." "LockObjects" "1")

Share this post


Link to post
Share on other sites
chavlji

Thet's not it. It doesn't work.

 

Registry value only tells program what was last setting in dialogs between different Autocad runs. Changing this value does not affect behaveour of current run.

 

This must be some variable inside autocad, but I am unable to detrmine wich or how to set it manualy.

Share this post


Link to post
Share on other sites
wizman
Changing this value does not affect behaveour of current run.

i tested here and its dynamically changing in my current run and im using only one acad session.

 

 

try searching for RefeditDialog inside your registry to get the LockObjects directory then copy the key frame. i think i have put

R 17.1 in my previous post, it should be R17.1(without space). ill try also to look for some other sysvars, i'll post if ever i find something related.

Share this post


Link to post
Share on other sites
chavlji

Thenx.

 

It really doesn't work only changing the registry. In my case it is set to 1 but it still does not lock other objects.

 

It may be changing during session, but it probably only store value there. So it knows if it should check or uncheck "lock objects" radio button, when user runs "refedit" dialog for the first time in one session...

Because changing this reg value really does not change the behaveour of "-refedit" command.

Share this post


Link to post
Share on other sites
LINHOREKA

I think the lock option in refedit mode handle the BeginCommand event, and filter the entities which are not in the working selection set out. I use VBA to scale object, and RefEdit allow me to scale any object ! Then the lock option is not very powerfull as it should be ...

Share this post


Link to post
Share on other sites
Gipslove4u

I have recently upgraded to AutoCAD'2011 from AutoCAD'2008 and having same problem with "-refedit". In earlier version of Cad, their was no such problem but now the objects outside working set are not locked untill you use the right click option & select "edit block in place" :reallymad:

 

IS THIS BUG OR WHAT :rtfm:

 

Does Anyone know the solution :? :unsure: :? :unsure:

Share this post


Link to post
Share on other sites
CADbloke
IS THIS BUG OR WHAT :rtfm:

 

MATCHPROP seems to ignore the "lock objects not in working set" setting in v2013. I'd call that a bug.

Share this post


Link to post
Share on other sites
martinle

This problem still persists with Autocad 2022! Does anyone have an idea?

Share this post


Link to post
Share on other sites
Dadgad

Have you selected LOCK OBJECTS NOT IN WORKING SET?

It does not appear to be the default value, at least in 2016.

image.thumb.png.754b01a3979c85574e7298fd567cf6eb.png

Share this post


Link to post
Share on other sites
martinle

Hello Dadgad, yes is selected.
When I first select _refedit in the context menu in a new drawing and the button ok. press then the second time everything works as desired. But you always have to edit the block the first time using the _refedit dialog box.
That's funny.
lg. Martin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...