Jump to content

Laggy, Jerky Cursor! - HELP ME PLEASE!


Recommended Posts

Hi guys,


I'm using AutoCAD 2012 on ASUS WIN 7, i5, 4GB RAM, Intel HD Graphic Card.


For some reason my cursor becomes very laggy and jerky as I use the "Line" tool,

that being said, my cursor is completely fine when I use any other tool.





I know in the AutoDesk "Knowledge Base" there's a similar Q&A for my situation, but after doing carry out all the AutoCad commands the cursor is still laggy. I don't have a face scanner or virus program turned on. My drivers are updated as well.




So far, only "Line", "Polyline", and just about any function that involves drawing a line (eg: arc), my cursor becomes very laggy.


Any help is greatly appreciated! Thank you!


@ Grant -


No I turned off my Virus program, and have a only AutoCAD running.


Seeing my laggy problem is isolated to "Line" function, I'm thinking my problem is not a hardware/software issue, but more of a setting problem.

Thank you for your reply though Grant!

Edited by dulerong
Link to comment
Share on other sites

Have you got something else running in the background - auto antivirus check running


Goto windows task manager and click the processes tab and see what is taking the cpu time


See how much ram is being used under performance tab - if it is around 75% in memory or CPU I would say that something else is using your computer time and memory

Link to comment
Share on other sites

What antivirus program and/or firewall do you have installed? They are not all compatible with Autocad (shutting them down does not resolve the issue).

Link to comment
Share on other sites

Not that I mind posting a few hundred times to try to WAG your problem, but maybe you could help things along by listing out the steps you have taken so far.

Link to comment
Share on other sites

Is it only when you use the LINE tool? What about when you use PLINE? Same thing or no?


I've heard if you are using a wireless mouse, replace the batteries. Worth a try at least, unless you're mouse is wired.

Link to comment
Share on other sites

Your graphics card isn't exactly what I'd call "conducive to CAD". Try to see if you can turn on/off hardware acceleration - maybe the rubber-banding is causing hassles with your GPU.


Apart from that, I've found a jerky cursor happens every now and then on my WinXP (even outside of ACad) - which requires a reboot to fix. It might have been some mouse driver issue though and would affect EVERYTHING not just 1 command in ACad.


If all else fails try playing with the DragMode / DragP1 / DragP2 system variables. You might loose the rubber-band effect alltogether, but that's what you'll have to pay for using the cheap graphics card.

Link to comment
Share on other sites

  • 1 month later...

i have exactly the same problem and its very annoying.


Operating System

MS Windows 7 64-bit


Intel Xeon X3430 @ 2.40GHz 28 °C

Lynnfield 45nm Technology


7.93 GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)


Hewlett-Packard 0B40h (XU1 PROCESSOR) 7 °C


Acer AL2416W (1920x1200@59Hz)

NVIDIA Quadro 600

Hard Drives

488GB Hitachi Hitachi HDS721050CLA362 (RAID) 28 °C

488GB Hitachi Hitachi HDS721050CLA362 (RAID) 22 °C

Optical Drives



Realtek High Definition Audio


have tried a number of remedies and at the moment i have decided to use an older version until i can get it sorted.

Link to comment
Share on other sites

  • 2 years later...



If you find that nothing works, you could select all items in your drawing (Ctrl+A) and transfer (copy-paste) them in a new Autocad File. It worked for me.

Link to comment
Share on other sites

I find this happens when you have edited a block by double clicking on the block and using 'Edit Block Definition' on a slightly bigger drawing.


When you come out of the block editor it can sometimes go laggy!

The way I solve this is to:

1. don't use 'Edit Block Definition' - explode the block, do the mod, re-block

2. When it is laggy - save the drawing, close the drawing and then go back into the drawing.


Not good solutions though!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...