Jump to content
cbat

Right click short-cut menu settings

Recommended Posts

cbat

I use Autocad 2011, I'm a bit of a Cad newb, and I appear to have somehow messed up my right click short-cut menu settings. Before, I could right-click and get all of the edit options (delete, move, rotate, draw order, properties, select similar, etc.). I could get these options whether an object was selected or not. Now, my options are the "default" ones (Repeat, Pan, Zoom, Quick calc, etc, to name a few). This happened after I made an adjustment to the drawing in a viewport. Ie. I was in layout, clicked into model space to draw a line, then clicked back to paper space. I NEVER do this (I always switch back to model to edit), except for this one time. Also, if I select an object and hit "delete" on the keyboard, nothing happens. I've already tried adjusting the "shortcutmenu" command number, and nothing really changes in the shortcut menu itself. Also, when keying in a command, the keystrokes used to show up beside my cursor, but now they show only in the command line at the bottom. That's not really a big deal, but I did like the previous function.

 

Any advice anyone could give me would be much appreciate. Remember I'm a newb, so please provide step-by-step instructions, if possible. Thanks!

Share this post


Link to post
Share on other sites
nestly

If you can't delete using the Delete Key, then Noun/Verb Selection is almost certainly turned off. Tools > Options > Selection > Noun'/Verb Selection, or set the PICKFIRST variable to 1 at the Command line. If PICKFIRST is disabled (0) then that also explains why your context sensitive right-click menus don't work.

 

The Input at your cursor is called Dynamic Input. You can turn it back on by clicking the Dynamic Input button on your Status bar, or by setting DYNMODE to 3 at the Command line.

 

Switching from model to paper shouldn't have affected those settings. The typical culprit is escaping out of a LISP routine that doesn't have error correction.

 

Also, welcome to Cadtutor

Share this post


Link to post
Share on other sites
rkent
I use Autocad 2011, I'm a bit of a Cad newb, and I appear to have somehow messed up my right click short-cut menu settings. Before, I could right-click and get all of the edit options (delete, move, rotate, draw order, properties, select similar, etc.). I could get these options whether an object was selected or not. Now, my options are the "default" ones (Repeat, Pan, Zoom, Quick calc, etc, to name a few). This happened after I made an adjustment to the drawing in a viewport. Ie. I was in layout, clicked into model space to draw a line, then clicked back to paper space. I NEVER do this (I always switch back to model to edit), except for this one time. Also, if I select an object and hit "delete" on the keyboard, nothing happens. I've already tried adjusting the "shortcutmenu" command number, and nothing really changes in the shortcut menu itself. Also, when keying in a command, the keystrokes used to show up beside my cursor, but now they show only in the command line at the bottom. That's not really a big deal, but I did like the previous function.

 

Any advice anyone could give me would be much appreciate. Remember I'm a newb, so please provide step-by-step instructions, if possible. Thanks!

 

Soujds like you have three separate issues.

 

Pickfirst to 1 will let you use the delete key as you remember.

 

The shortcut menu will show the options you remember after you have selected one or more objects.

 

The commands at the cursor is the DYN dynamic input, see the DYN button at the bottom of the screen, toggle it on.

Share this post


Link to post
Share on other sites
cbat

Thanks for your advice. I've successfully solved the "delete" issue, and the commands at the cursor. My shortcut menu options are still not back to normal, however. Rkent, I'm not sure what you mean by "the shortcut menu will show the options you remember after you have selected one or more objects." Can you clarify? Nestly, how can I solve this "LISP routine" issue?

 

Thanks again for your help!

Share this post


Link to post
Share on other sites
rkent

With no command active pick on a line, now right click on mouse.

Share this post


Link to post
Share on other sites
nestly

These are the default settings for AutoCAD2011 (SHORTCUTMENU = 11)

 

right click.JPG

 

If you're the only one that uses your computer for CAD and you don't know what a Lisp is, then that's probably not the problem, but for future reference, a lisp is programming code that automates certain autocad tasks. These programs often have to temporarily turn off some AutoCAD features such as PICKFIRST, Dynamic Input, OSNAPS, etc, but if the user uses ESCAPE before the program completes, often those features don't get restored to their previous settings.

Share this post


Link to post
Share on other sites
cbat

I'd already experimented with those and it hadn't worked, but now it's back to normal! Thanks very much for both your help! I really appreciate it!

Share this post


Link to post
Share on other sites
SLW210

I used MVSETUP in a viewport and it reset PICKFIRST and all of my snaps. :ouch:

 

I expect better from freeware. :x

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...