Jump to content
tennis4you

Any Reasons AutoCAD is pausing?

Recommended Posts

tennis4you

Seems like the longer I am in AutoCAd the more things slow down. Any reason for that? I think rebooting helps a ton, time to try that out now.

Share this post


Link to post
Share on other sites
Cad64

How much free space do you have on your hard drive?

 

When was the last time you cleaned out your temp files? Emptied your Recycle Bin? Defragged your computer? Cleaned out your Registry? Checked for spyware/malware/viruses?

Share this post


Link to post
Share on other sites
Glen1980
I followed some "Speeding Up AutoCAD" instructions and turned off something int he control panel for Windows 7, that has sped things up a lot. Windows does not quite look the same, but for now AutoCAD seems happier.

 

Heh, reminds you of windows 95 doesn't it! I did everything I could on that list even had to call IT over to fiddle with the bits I didn't have admin rights for (i.e. virtual memory) now it runs a lot faster.

 

I have found that everytime we upgrade the latest version is far more memory intensive and although you have 4 gig you only mention having windoze 7 if it isn't the 64bit version I'm not sure if it utilizes more than 3 gigs. Something I read on here is that AutoCAD can only use one core of a processor so maybe that one core is getting clogged whilst the other cores are happily running windows and your other programmes, even so a single 3gig processor shouldn't slow down that much. Are there any more things you can try from that list?

 

My i7 win 7 64 at home that has 4 gig was feeling sluggish until I turned off every visual flourish and did everything on that list.

Share this post


Link to post
Share on other sites
tennis4you

It is 32 bit. The pc is only 6 weeks old and I have 380 gigs free and I empty the recycling bin multiple times per day. I have not run cc cleaner for deleting cookies for a few weeks though.

Share this post


Link to post
Share on other sites
ReMark

Just curious, but why did you stick with a 32-bit system?

Share this post


Link to post
Share on other sites
tennis4you

Well, at my last firm I did a 64 bit and not everything I needed functioned properly without going through extra steps so I went with the 32 bit.

Share this post


Link to post
Share on other sites
tennis4you

Right now I get an average of a 10 second delay when I open new files. Also a 10 second delay when moving from model space to layout. That's easily an hour a day wasted staring at the frozen screen on a brand new computer running LT. Crazy. I am already working 12-14 hours per day, this is killing me.

Share this post


Link to post
Share on other sites
ReMark
Well, at my last firm I did a 64 bit and not everything I needed functioned properly without going through extra steps so I went with the 32 bit.

That may not have been the best decision you ever made. Forward...always forward. Anticipate what is coming down the road. 64-bit is already the handwriting on the wall.

Share this post


Link to post
Share on other sites
ReMark
Right now I get an average of a 10 second delay when I open new files. Also a 10 second delay when moving from model space to layout. That's easily an hour a day wasted staring at the frozen screen on a brand new computer running LT. Crazy. I am already working 12-14 hours per day, this is killing me.

Are you on a network?

 

Do you have Windows "indexing" disabled?

Share this post


Link to post
Share on other sites
tennis4you

I am not on a network. What is indexing and where can I check that bad boy?

Share this post


Link to post
Share on other sites
ReMark

It is a file indexer for locating files faster. A sure sign, in the past, if indexing was enabled was a near constant flickering of the computer's hard drive activity light. This constant activity was called "churning" and it really slows things down...a lot.

 

The fix: http://windows7themes.net/disable-windows-7-indexing.html

Share this post


Link to post
Share on other sites
tennis4you

OK, I did that, I will see if it makes a difference. Thanks!

Share this post


Link to post
Share on other sites
irneb
How much free space do you have on your hard drive?

 

When was the last time you cleaned out your temp files? Emptied your Recycle Bin? Defragged your computer? Cleaned out your Registry? Checked for spyware/malware/viruses?

Cleaning the disc, removing temp files and running as few proggies as possible is good. You may want to set your AV to not check ACad all the time though (I'm not sure how to do this with M$SE, I'm using Avast!).

 

What I'd HIGHLY discourage is even looking at the word "Defrag". It is literally like a placebo which is also addictive and toxic. Basically what happens if you "defrag" is all the files on your hard-drive are rearranged to follow each other, with no gaps in between. That's fine if you never edit any file ... ever. The very first edit will create at least one fragmented file (i.e. a file split over 2 or more places on the disc). Thus after a defrag your PC runs a bit faster for no more than a week, then it's actually slower than before - thus you now need to defrag again. And the more you defrag the quicker your hdd will destroy itself through over-use.

 

Most "modern" operating systems try to avoid fragmentation. The most common method is what windows does if your drive is formatted in NTFS: Leave some growing space after each file so that if it grows it doesn't immediately become fragmented. The old FAT8/16/32 file systems didn't do this - thus you were stuck with having to Defrag. Apparently NTFS is supposed to move a file once it becomes fragmented, searching for a place large enough to hold the entire file in one section. Though I've seen NTFS become fragmented to about 5%, it's a LOT less than I've seen on FAT, but not as scarce as you get on Linux's EXT4 file system (which nearly guarantees less than 1% fragmentation). But every time I've defraged a NTFS disc, it's become fragmented up to 50% within a month - making that PC slow to a crawl. Only solution was to re-install windows after formatting.

 

That may not have been the best decision you ever made. Forward...always forward. Anticipate what is coming down the road. 64-bit is already the handwriting on the wall.
Yep, from my own personal experience, any full ACad after 2008 (perhaps 9 as well) is simply not a good idea on 32bit. Not if you want to use it for serious work. Haven't used any LT since 2000 so don't know about that. Actually on 32bit you can only use 2GB max, if you turn on the 4GB limit you're lucky if you get a usable 3GB - but then ACad doesn't want to work with graphics hardware acceleration, or crashes intermittently. And even then, no one program can have any more than 2GB of RAM used. That's the 1st big benefit of 64bit - i.e. able to break the 2/4GB limits.

 

As for one core being over-used, it doesn't actually work that way. Windows keeps swapping processing between cores, so generally ACad's working on many cores - just using one at any one time. It's like a round-robin swap, but due to acad not having separate threads each instruction needs to complete before the next can run. Thus windows cannot let it run on more than one core at once, that would definitely make acad crash. You could set affinity to force acad to only use one particular core, but you don't actually get any improvement in performance - so it's of no use.

 

Generally speaking, if your disc is not used more that 50% of its space - fragmentation shouldn't be a problem. Even with discs with only 20% free space, it shouldn't be too much of an issue. Unless you go and defrag them, then you've caused your own problem.

 

There's several things in the DWG which can cause slow-downs though. Unfortunately I'm not well versed in LT, so some of these might not be available to you.

 

  • Purge Regapps not only makes the DWG a lot smaller, but also uses less RAM and thus also less CPU.
  • Errors in the DWG will most probably cause slow-downs, if not crashes. So Audit, Recover, WBlock ... whatever it takes to get rid of them.
  • Annotative scales can grow to execessivle amounts simply by inserting blocks, copy-n-past between DWGs, using refedit, adding xrefs, etc. For this use the command-line version of -scalelistedit (note the dash/minus prefix) and then Reset. There's other fixes, but most require lisp so no go in LT. Perhaps the ScaleListCleanupUtility from ADesk works with LT - this can clean multiple DWGs at once.
  • You say your logo is drawn in cad, does it have solid hatching, lots of curves, splines, etc. Try to simplify it as much as possible, yet still having the "correct" appearance in a plot. You don't need to always draw it 100% as a plot is quite forgiving in this sense.
  • If you have any annotative stuff, keep especially annotative hatches to the absolute minimum. Regens could take ages if there's a lot of these (I've seen DWGs taking 10-30min to swap between MS & PS due to this.)
  • Remember that xrefs bring in their own problems. If there's an error in the source DWG it will cause the same thing to slow down in the target DWG. So clean the xrefs as well, then reload and clean the target.
  • Make sure all your support paths (and other paths like plotter settings) actually exist. Try to keep all these on a local disc (not network / external).
  • Also make sure there's not any windows shortcuts in any of these folders which may point to a non-existent folder/file.
  • If you do use images, don't scale them smaller in ACad. Rather scale them in an image editing app, then insert them. Otherwise ACad loads a high res image only to display & print at lower res. You may need to play around untill you find the lowest res which has not artefacts.
  • Some addons may perform things due to regens / certain commands. Though I guess it's unlikely in LT.

Share this post


Link to post
Share on other sites
tennis4you

OK, I appreciate everyone's help thus far but this is still an issue for me. I have modified Windows, AutoCAD, etc. to get this try to work but to no avail. In response to the post above:

- Purge made the drawings a little smaller but not much. I have purged everything I can.

- Audit finds nothing.

- No annotative anything, not even sure how to sue it.

- Logo is not as big as I thought it was. A friend with AutoCAD 2001 and an old pc is able to open my drawings and have no issues at all.

- All drawings are small, this is smaller scale residential projects.

- Support paths are fine.

- No windows short cuts

- No images used.

- No addons.

 

I have only had this AutoCAD for 6 weeks or so and I have done nothing to customize it other than where my toolbars are. This is happening in every project all the time. Happens more and more as I get into CDs, not much when I am in design. Just going to layout to model space lags 5-10 seconds. And then if I want to go right back to layout space after doing nothing in model space (not even zooming) then I get to wait another 5-10 seconds.

Share this post


Link to post
Share on other sites
ReMark

If the issue is not with the drawing file itself then it has to be LT 2012 as you have pretty much discounted the system based upon the specs right?

Edited by ReMark

Share this post


Link to post
Share on other sites
tennis4you

I feel the system is good. Shy of not having 64-bit, the computer is pretty solid.

Share this post


Link to post
Share on other sites
ReMark

Then it seems you have narrowed the issue to the software. Do you have a previous version of LT available like 2010 or 2009?

Share this post


Link to post
Share on other sites
Glen1980

I may have my wires crossed/bad memory but I had a faulty install of 2010LT way back when and I think it may have stemmed from having the Anti-virus switched on during the installation process.

 

Have you checked Autodesk for any service packs or hot fixes?

Share this post


Link to post
Share on other sites
tennis4you

That I have not done. I assume I can do that through AutoCAD?

Share this post


Link to post
Share on other sites
tennis4you

Two things I have on my AutoCAD that a friend thinks could be slowing it down some (I am doubtful though). Anytime I change a file that is being x-ref'd then go to the file that is showing the x-ref I get a notification on the bottom right of the screen telling me so. Also, I have the layer and x-ref bars docked on the right. They are pretty big, I like em though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...