Jump to content

Alignment Geometry Editor Disabled


CyberAngel
 Share

Recommended Posts

This is not so much an issue as an addition to the knowledge base here. If someone has had this issue before, I couldn't find it.

 

An associate here was trying to add a couple of PIs to an alignment. When he pulled up the geometry editor toolbar, most of the buttons were greyed out and none of them worked. Part of the troubleshooting SOP is restarting AutoCAD, during which he got a message about enabling macros. The first time he had answered No. This time he said Yes, and the geometry editor worked.

 

So be warned. There are some commands in Civil 3D that depend on macros.

Link to comment
Share on other sites

I have no idea what the macro stuff was about, but this is a known bug. I forget for sure what versions it affected. I think C3D 2009, and maybe C3D 2008.

 

As you discovered, restarting C3D clears it up, until it happens again. I never heard what triggered it, but eventually Autodesk fixed it.

Link to comment
Share on other sites

I have no idea what the macro stuff was about, but this is a known bug. I forget for sure what versions it affected. I think C3D 2009, and maybe C3D 2008.

 

As you discovered, restarting C3D clears it up, until it happens again. I never heard what triggered it, but eventually Autodesk fixed it.

 

This happened with C3D 2011. If it's a bug, they didn't fix it. No surprise there.

Link to comment
Share on other sites

  • 9 months later...

This happens to me in 2012 every time. I can open the geometry editor once and use it fine, but if I try to do it again it is all disabled until I restart the program. Any fixes for this yet??

Link to comment
Share on other sites

This happens to me in 2012 every time. I can open the geometry editor once and use it fine, but if I try to do it again it is all disabled until I restart the program. Any fixes for this yet??

 

I started using AutoCAD in 1991. There were bugs in the program then that they still haven't fixed. Don't hold your breath.

Link to comment
Share on other sites

  • 2 years later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...