Jump to content
davidad

Dimension units change after saving

Recommended Posts

davidad

I'm having an issue with dimensions changing from when I save the drawing to when I reopen it.

 

I'm using AutoCAD Mechanical 2009, exclusively in 2D. I save drawings in AutoCAD 2000/LT 2000 Drawing format to maintain backwards compatibility with our legacy documents which are still in regular use.

 

The exact process is:

1. Create dimension in existing drawing.

2. Set units of dimension. Typically this is fractional.

3. Save and close drawing.

4. Reopen drawing, and all of the dimensions units are set to decimal to the fourth decimal point.

 

If I interact with the dimension in any way, it will return to its set unit. For example, if I double click on it to bring up the Power Dimensioning window and just click Okay without altering anything, it will change back to its set unit. Likewise, if I move the dimension itself it will return to its set unit as well.

 

So far my solution has been to simply select the entire drawing at once, then move it X units one way, then X units back. The move back and forth will return all the dimensions to their set units.

 

Obviously this is not ideal, especially when sending drawings to co-workers who are unaware of the issue or even using different versions of AutoCAD.

 

Thanks for any help.

Share this post


Link to post
Share on other sites
DANIEL

I've had thias problem but for the life of me can't remember how I fixed it, I know you could always purge everything and redimension it but I know there is a way to fix it, hopefuly someone else around here will remember lol.

Share this post


Link to post
Share on other sites
DANIEL

set your dimassoc to 1 instead of 2

Share this post


Link to post
Share on other sites
davidad
set your dimassoc to 1 instead of 2

 

It is already set to 1

Share this post


Link to post
Share on other sites
Murph_map

Create your own dim style and use that instead of the standard power dim style. ?

Share this post


Link to post
Share on other sites
DANIEL

are you dimensioning though a view port in paperspace or are you in model space?

Share this post


Link to post
Share on other sites
nestly

Perhaps the Visual Fidelity setting in Options?

Can you post a sample drawing saved to 2000 format so we can check if it's an issue with the drawing, or whether it's a setting in your AutoCAD?

Share this post


Link to post
Share on other sites
davidad
are you dimensioning though a view port in paperspace or are you in model space?

 

Everything is in model space. The way our company uses AutoCAD is pretty crude, we never use paper space.

 

 

 

Perhaps the Visual Fidelity setting in Options?

Can you post a sample drawing saved to 2000 format so we can check if it's an issue with the drawing, or whether it's a setting in your AutoCAD?

 

I just set Visual Fidelity (though SAVEFIDELITY) to 0 instead of 1, and it appears to solve the issue. I've checked it with several drawings that have been giving me trouble and it appears to work with all of them.

 

Thank you all for the help, if I encounter any more problems with it I'll post a sample drawing.

Share this post


Link to post
Share on other sites
DANIEL

oh, and welcome to CADtutor davidad :) , glad nestly got you helped out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×