Jump to content
ColinPearson

PLEASE help with hatch edit!

Recommended Posts

ColinPearson

Hi all -

I don't know what happened, but I was CADDing along and now when I double click a hatch, it invokes what I think is the Quick Properties, not the Hatch Edit command.

 

I can still type the Alias "he" and get to it, but I'm used to double clicking and don't see what change. I looked in the CUI, and under Double Click Actions>Hatch, the Hatch Edit command is listed.

 

What gives?

 

THANKS to the community at large, as always.

Share this post


Link to post
Share on other sites
nestly

Set PICKFIRST to 1 (Tools > Options > Selection > Noun/Verb Selection)

Share this post


Link to post
Share on other sites
ColinPearson

Rats, that's what mine is already.

Share this post


Link to post
Share on other sites
nestly

DBLCLKEDIT setting? (Tools > Options > User Preferences)

Share this post


Link to post
Share on other sites
ColinPearson

Currently checked.

Aaargh.

Share this post


Link to post
Share on other sites
nestly

When you select the hatch, is it listed as a hatch in the Properties Palette?

Is the hatch on a locked layer?

Are you using a Classic workspace, or the Ribbon?

Share this post


Link to post
Share on other sites
ColinPearson

Classic WS, no locked layers.

 

When I select the hatch, it comes up as All(2), so it's getting the boundary as well. I just deleted the boundary and double clicked the hatch and voila, there goes Hatch Edit. Not sure why the original double click seems to be picking both the hatch and the boundary.

Share this post


Link to post
Share on other sites
ColinPearson

Going out to the process unit... don't think I'm rude if I don't respond to y'alls' help in the next couple hours.

 

Thanks for the input so far!

Share this post


Link to post
Share on other sites
ootn75

Mine is doing this now. I've been through all the proper CUI steps, DBLCLKEDIT is ON, and PICKFIRST is set to 1. The CUI shows HATCHEDIT as what's supposed to happen when I double click hatch but it still brings up properties. All my other double click actions are able to be modified but this one is not. Is there something else blocking this?

Share this post


Link to post
Share on other sites
Dana W
Mine is doing this now. I've been through all the proper CUI steps, DBLCLKEDIT is ON, and PICKFIRST is set to 1. The CUI shows HATCHEDIT as what's supposed to happen when I double click hatch but it still brings up properties. All my other double click actions are able to be modified but this one is not. Is there something else blocking this?
Did you see the past post about the boundary? That may be it.

Share this post


Link to post
Share on other sites
ootn75

I restarted my whole machine. Still nothing. Tried everything again above and deleting the boundary worked. Thank you! I need the boundary though. Is this a clue to what the root cause of the issue is? I've never had this trouble before until I had to reinstall everything and re-do all my settings.

Share this post


Link to post
Share on other sites
ootn75

Ok this worked for me. Options>Selection tab. Under "Selection modes" unclick "Associative Hatch." I can still make the hatch associative every time I hatch in the actual hatch command but can't have this clicked. I clicked it thinking it would just default my hatches to associative without me having to tell it to make it associative every time. It will but apparently it makes this issue. Probably some bug or I'm misunderstanding what the button in Options/ Selection tab is for.

Share this post


Link to post
Share on other sites
ootn75

When I hover over the "Associative Hatch" setting under "Selection Modes" it says "Determines which objects are selected when you select an associative hatch. If this option is selected, boundary objects are also selected when you select an associative hatch. (PICKSTYLE system variable = 2)

 

I don't exactly know what this means other than it's messing with the pickstyle. Just thought I'd put it here so someone else won't spend hours like I did ready to chunk the thing out the window!

Share this post


Link to post
Share on other sites
Dana W

Yep, there's some hinky program code behind the associative hatch business. I think the program gets its panties in a wad from time to time, like when you go to trim a bit of hatch inside an existing boundary by putting a smaller boundary inside the existing one, then trimming inside the new boundary, then the hatch you want to keep gets all misshapen or double hatches the existing area, or even jumps to a new area. It makes me crazy. I like the way associative hatch is supposed to work, but it doesn't work very well when you go to change the hatched area itself at times.

 

I make it a practice to keep the Separate Hatches box checked too. That seems to keep things to a simple level so the program code can deal with changes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...