Jump to content
lamensterms

Blank DWG with a large file size...

Recommended Posts

lamensterms

Hey guys,

 

Ive got this blank DWG with a file size of 4MB... ive ERASE > ALL on all layouts, then PURGED a few times, i cant see any layer filters. The STATUS command says it has 241007 objects... but i cant find or get rid of them.

 

Can someone please take a look at this DWG and let me know how i can clear it out and reduce the file size?

 

Any help would be greatly appreciated.

 

http://dl.dropbox.com/u/40227213/Big%20Empty.zip

 

Uploaded to DropBox... the DWG was too big to attach to the post.

 

Thanks again.

Edited by lamensterms

Share this post


Link to post
Share on other sites
Dadgad

I ran -PURGE on it which cleared out 17 registered apps, SCALE LIST EDIT, walked it through LAYERWALK, deleted the unused layers, and audited and purged it again, and it is still slightly over 4MB. That is a seriously large seemingly empty file!

 

Here's what IT is. Did a SELECT ALL and this is what came up in my quick properties palette. :)

big empty.JPG

Share this post


Link to post
Share on other sites
Dana W
I ran -PURGE on it which cleared out 17 registered apps, SCALE LIST EDIT, walked it through LAYERWALK, deleted the unused layers, and audited and purged it again, and it is still slightly over 4MB. That is a seriously large seemingly empty file!

 

Here's what IT is. Did a SELECT ALL and this is what came up in my quick properties palette. :)

 

It's real. It's real. You have discovered Dark Matter. The Pulitzer committee will be calling you any minute now.:lol:

Share this post


Link to post
Share on other sites
Dadgad
It's real. It's real. You have discovered Dark Matter. The Pulitzer committee will be calling you any minute now.:lol:

 

It has long been furtively whispered amongst coworkers after flashing the secret sign, while mingling / loitering around the water cooler, but those days are gone ............ GET THE KIDDIES OFF THE STREETS!!!!! :alien:

Share this post


Link to post
Share on other sites
lamensterms

thanks for the input guys...

 

The file size of these DWGs could be a bit of a problem for us, it's not just 1 DWG...we have heaps which should be below 1MB.

 

Thanks again.

 

----EDIT-----

 

Found SCALELISTEDIT and LAYER WALK.

 

Cheers.

Share this post


Link to post
Share on other sites
khama

Recreate your DWT file. Start a new drawing using acadiso.dwt. Put all the layers and whatever else you need in the drawing and then save it over what ever template (xxx.DWT) you are using. The file has some sort of corruption in it. If acadiso.dwt does not work. Load another default template that you know is clean and then reshape it.

Share this post


Link to post
Share on other sites
SLW210

Do you have all of your Object Enablers installed? OBJECT ENABLERS

 

Try -exporttoautocad (note the - in front). See THIS

 

What program created the drawing?

Share this post


Link to post
Share on other sites
Dadgad
Do you have all of your Object Enablers installed? OBJECT ENABLERS

 

Try -exporttoautocad (note the - in front). See THIS

 

What program created the drawing?

 

Nice one SLW210, never heard of that before, seems like it should help. It looks to be a PROSTEEL file, had a prosteel dim style in it. When I checked earlier today there were no enablers for Prosteel listed.

 

No, that didn't fix it either.

Share this post


Link to post
Share on other sites
SLW210
Nice one SLW210, never heard of that before, seems like it should help. It looks to be a PROSTEEL file, had a prosteel dim style in it. When I checked earlier today there were no enablers for Prosteel listed.

 

I ran across the OPs other posts and saw where ProSteel was the culprit. SOoooooo I was nice enough to find THIS.

Share this post


Link to post
Share on other sites
Dadgad
I ran across the OPs other posts and saw where ProSteel was the culprit. SOoooooo I was nice enough to find THIS.

 

Good work! Looks like just the ticket, but not for this boy, lights out my time. :thumbsup:

Share this post


Link to post
Share on other sites
lamensterms
I ran across the OPs other posts and saw where ProSteel was the culprit. SOoooooo I was nice enough to find THIS.

 

hey guys, thanks so much for taking the time to help.

 

You're right, the drawing was created using the ProSteel addon. Regarding the object enablers... can you please explain what installing that might allow me to do? Im not really up to speed with all the behind-the-scenes stuff.

 

Thanks a lot.

 

----EDIT----

 

also guys, ive tried WBLOCKing a single line out of the DWG - didnt help. I have also tried SuperPurge and TotalPurge with no luck. I think there might be a few other purge apps i could try.

 

cheers.

Share this post


Link to post
Share on other sites
khama

I don't know I use Prosteel everyday and the Default.dwt is only 60kb. There is something majorly wrong with this template. It needs remaking entirely. This is done easily by following my earlier post. Also if you don't have Prosteel you will not be able to see ANY entities made with Prosteel unless you have the enabler active. You can get it from here: http://softwaretopic.informer.com/prosteel-enabler/

Share this post


Link to post
Share on other sites
lamensterms

Hey khama, thanks for the reply.

 

This DWG is not actually the template we use in our office, nor was it created using our template. So I'm not so much concerned about preventing more drawings like this (as the ones we produce are generally Ok), but I would like to try and fix the corrupted ones that have already been made - if possible.

 

On another note... I did install the object enablers, and I'm afraid they did not allow me to clean the DWG. I think I may have corrupted my ProSteel installation in the process though, I have been getting an error about "KsKernell.dll" being unable to load. Do you know if this is a common error?

 

How experienced are you with ProSteel, perhaps we can compare notes sometime.?

 

Ps: what type of work dovyou do?

Share this post


Link to post
Share on other sites
SLW210

I found THIS on the Autodesk forums. Hopefully it will help.

 

What version of ProSteel are you using?

Share this post


Link to post
Share on other sites
lamensterms

hey SLW210, thanks for the link.

 

I had a quick look at some of those solutions and was a bit bamboozled. I did try and remove a few dictionaries (i think) but that didnt seem to have any effect. dgorsman's solution sound like it could be reduce the file size, but he/she mentions that it should only be done to drawings which are not 'active' ProSteel drawings - which ours are.

 

We are using ProStructures V8i (SELECT series 3) - Version 8.11.3.55.

 

Thanks again for all your help.

Share this post


Link to post
Share on other sites
SLW210

You may need to post something on Autodesk or AUGI or Bentley Community.

 

Did you try -exporttoautocad? You might could try DXFOUT/DXFIN and/or WMFOUT/WMFIN.

Share this post


Link to post
Share on other sites
lamensterms

Hi again guys,

 

Just an update on the file size problem im having...

 

I did manage to reduce the size of one of the offending DWGs, by using the following code:

 

(dictremove (namedobjdict) "Ks_BoltRefDictionary")
(dictremove (namedobjdict) "Ks_HoleDisplayRefDictionary")
(dictremove (namedobjdict) "Ks_KoteFlagRefDictionary")
(dictremove (namedobjdict) "Ks_PartFamilyDictionary")
(dictremove (namedobjdict) "Ks_PosFlagRefDictionary")
(dictremove (namedobjdict) "Ks_ShapeRefDictionary")
(dictremove (namedobjdict) "Ks_WeldRefDictionary")
(dictremove (namedobjdict) "Ks_XRecordDictionary")
(dictremove (namedobjdict) "KsRevisionDatabase")
(dictremove (namedobjdict) "PsLizControl")

 

This seems to remove some "dictionaries" - which cause the balloon in file size. I have tested this on an empty junk DWG, and it does work. But I am hesitant to try it on an active drawing, as im not really sure what the effects of the code are. And im not sure how much ProSteel relies on these dictionaries.

 

Another strange point... i tried to remove each dictionary 1 by 1 (to identify which is the cause of the problem), but it seems that I only had success when removing all dictionaries at once. This may have been due to an error made when going through the process. I will test more thoroughly when i have some time.

 

thanks again for everyones help.

Share this post


Link to post
Share on other sites
khama
Hey khama, thanks for the reply.

 

I have been getting an error about "KsKernell.dll" being unable to load. Do you know if this is a common error?

 

How experienced are you with ProSteel, perhaps we can compare notes sometime.?

 

Ps: what type of work dovyou do?

 

I do Mechanical Designing and I am a Mechanical Engineer. I have been using Prosteel for 7 years now and I love it. So much faster than Autocad and can detail on the fly with one click. Our productivity has tripled since we started using it. In it's early stages Kiwisoft was the maker of Prosteel and now it has been bought out by Bentley Systems and has become Prostructures V8i Select series 3. I think it has evolved nicely. I have just changed jobs and I am in the process of working on the detailing systems for the new company so they can do turnkey projects. They are really freaking out at the productivity gains in both Modelling and Detailing. On the first day of introducing the systems to them they gave me a $10,000 pay rise. That was so cool. That takes me way past 6 figures +. As for your error message, can't say that I have had that issue before. It sounds quite nasty thou. If the object enabler did not help you that really is strange. If it is a KS_Kernell issue then there must be something horribly wrong with the template or the version of Prosteel you are using. Have you tried to re-establish the template as I said earlier? This solves 90% of Prosteel issues. This time copy the entire contents of the other companies drawing over to one of your templates and resave it. You will have alot more joy.

Share this post


Link to post
Share on other sites
lamensterms

Wow, congratulations on the new job and pay rise. That must be very rewarding for you to receive such enthusiasm when demonstrating and introducing systems.

 

Regarding the template, i have tried recreating our office's .DWT from a brand new drawing and have found that all our DWGs created with ProSteel seem to be fine. I beleive that something is corrupting the DWG we have received from another office. If i draw a single LINE in the corrupted 'Big Empty' drawing, then copy and paste that line into a clean, normal blank DWG... the line will attach some data (perhaps the dictionaries above) and introduce this data into the clean DWG, thus corrupting it. I have only been using ProSteel for the past ~10 months, so i am not very experienced with how it works behind the scenes. I think the best way to avoid this issue would be to not use DWGs from other offices as our source DWGs, probably not a bad rule in general.

 

Thanks so much for your help Khama, ill send you an email quizzing you about work, ProSteel and such.

 

Thanks again.

Share this post


Link to post
Share on other sites
OTRT
Hey guys,

 

Ive got this blank DWG with a file size of 4MB... ive ERASE > ALL on all layouts, then PURGED a few times, i cant see any layer filters. The STATUS command says it has 241007 objects... but i cant find or get rid of them.

 

Can someone please take a look at this DWG and let me know how i can clear it out and reduce the file size?

 

Any help would be greatly appreciated.

 

http://www.mediafire.com/?2asqrihpeyyc3k4

 

Uploaded to mediafire... the DWG was too big to attach to the post.

 

Thanks again.

 

Can you upload the file again? I'm having a similar problem with a few of my old files and would like to know if the cause is the same. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...