Jump to content

(command "Hatch") Ribbon problem Acad 2011


Recommended Posts

I want to write my own hatch command. (AutoCAD 2011)


In that, I want user to create the hatch manually and then process the hatch object created by the user in my command.


Manually, when you type hatch command at the command prompt:


"When the ribbon is active, the Hatch Creation contextual tab is displayed. When the ribbon is off, the Hatch and Gradient dialog box is displayed." (from Acad help).


However the (command "hatch") statement does not activate the contextual tab even when the ribbon is active.


I have tested all combinations with -hatch, -bhatch, cmddia and PAUSE, but without success.


Is this 'incomplete' work by AutoCAD Development team?


Is there a way to activate the contextual tab using Lisp after (command "xxx") statement?


I have searched the forum but could not find anything related.


Please help.

Link to comment
Share on other sites

Users can manually create their own hatch patterns using the SuperHatch command found in Express Tools. Why reinvent the wheel?

Link to comment
Share on other sites

Unfortunately, my question is not how a User can create a hatch manually.


My question is:


How can I display and activate the contextual hatch ribbon tab after the (command "hatch") statement in my code is executed.

Link to comment
Share on other sites

Would it have something to do with the setting of HPDLGMODE. If it is set to "1" then the Hatch command would act like it did prior to the release of 2011. Set to "0" the contextual hatch ribbon should display.

Link to comment
Share on other sites

From AutoCAD help, HPDLGMODE seems to be about 'Hatch and Gradient dialog box' and NOT about the contextual tab. Have you tried and found out something related to 'hatch' Contextual tab?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...