Jump to content
yosty02

Problem keeping my text height at 1/8

Recommended Posts

yosty02

I usually draw in model space 1:1 and then scale my drawing in paper space to fit my sheet, but when I'm scaling I also scale my text. Is there a way to keep my text at 1/8 even after scaling my drawing from model space?

 

thanks

Share this post


Link to post
Share on other sites
SLW210

Are using annotative text?

Share this post


Link to post
Share on other sites
rkent

Make an annotative text style, then you specify the text height as the height you want it to plot. Finally set the viewport to a scale and have that applied to the text.

 

I assume you meant that you apply a scale to the viewport and you don't actually scale the model objects. If the later then stop doing that.

Share this post


Link to post
Share on other sites
yosty02

I have some annotative text, tables, and a few leaders.

Share this post


Link to post
Share on other sites
SLW210

Can you post the .dwg file?

Share this post


Link to post
Share on other sites
yosty02

First of all I have limited experience with autocad, and I'm currently working as an intern. I have taken a previously hand drawn mechanical drawing and reproduced it in ACAD. I redrew it in model space 1:1, then using a viewport I scaled it down to fit on my compaines layout page. My problem is that the text for the dimesions, tables, etc. and also being scaled down, and I want the text to be 1/8 in paperspace. Is there someway to not scale the text? Thanks

Share this post


Link to post
Share on other sites
SLW210

If the text is annotative set it to the appropriate annotation scale. If I understand the problem.

 

Can you post a portion of the file as a .dwg?

Share this post


Link to post
Share on other sites
ReMark

Your text and dimensions (in model space) should have been ANNOTATIVE. If they are not annotative then you will not get the results you are looking for.

Share this post


Link to post
Share on other sites
yosty02

Okay, so it seems like all I should need to do is change the properties of my dimensions to annotative. Which I tried, but when I go back to the paperspace layout the text is still scaled down.

Share this post


Link to post
Share on other sites
ReMark

Did you assign a scale to the viewport that matches the annotative scale that you assigned to your model space text and dimensions?

Share this post


Link to post
Share on other sites
yosty02

I have my viewport set to 1:4, and annotative 1:1, to keep the text at 1/8 which is the height I used in model space?

Share this post


Link to post
Share on other sites
ReMark

You actually set the height of your text in model space at 1/8" to begin with but your drawing is so large you have to scale it down in your viewport to fit on your layout. Is that correct?

 

If you intend on printing your drawing at a scale of 1/8"=1'-0" then that is the scale that should be assigned to your viewport. I'm not sure where you came up with a viewport scale of 1:4.

 

Consider the following. I start a new drawing and place some text in it. I make the text 6" in height. Now I go to my paper space layout, create a viewport and assign it a scale of 1:4. When printed the text will actually be 1 1/2" in height. Do you understand what just happened? 1 divided by 4 is 0.25 and 6*0.25=1.5.

Share this post


Link to post
Share on other sites
yosty02

You are correct, the drawing is large and needs to be scaled down. The standard for text height here is 1/8 that is the only reason I choose that height. And I choose 1:4 for the viewport becasue that scale fits the whole drawing onto the layout while making it as large as possible.

Share this post


Link to post
Share on other sites
rickh

If you are using annotative text styles, when you first place it in the drawing it applies the current scale to the text. Now, what you did, was first create text (I assume while the scale was at 1:1), and then figured out the scale of the drawing in the viewport. That's ok....highlight all the annotative objects (just window the whole detail) and right click..."annotative object scale"..."add/delete scales".

 

You can add the appropriate scale that you have decided on, and delete any un-needed scales that the text objects already have. (I am assuming here that the right click will show you this option - never seen Mechanical myself).

 

Bottom line is that the objects do not scale themselves every time you change the scale, unless you turn ANNOAUTOSCALE on, but this can make a mess of objects in the drawing if you aren't careful. I prefer to draw the detail as you did - 1:1 true size - but determine the viewport scale before placing the text...then you can place text within the viewport and it will come in at the right scale....if you then have to change the scale of the detail for some reason....highlight - right click - add/delete scales.

 

Hope that helps. Also, don't start messing with the text height in the properties of annotative text objects....let the text styles control it (IMO).

Share this post


Link to post
Share on other sites
ReMark

Personally I wouldn't use a 1:4 scale but it is not my drawing. Have fun.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...