Jump to content

Grips won't stretch/snap


Recommended Posts

I have been using for about two years now, but have never been to a course/class (unless you count AutoCAD for Dummies), so my language may not be *correct*.


Simple problem: When I select a line, normally three grips appear; the ends and the middle. Normally, when I want to stretch (resize) a line I click one end and simply drag it to the desired location. Often it *snaps* to another nearby grip point, the middle selected grip, a line that it crosses, etc. If I zoom in I normally can put the grip any where I want to. It has worked fine up until this morning. Last night when I closed the program it worked perfectly...first thing this morning it doesn't work at all. Restarting the program and the computer had no effect.


The grip will only snap to the other origin (making it zero length) and other random points nearby. I cannot make it a random length...it must snap to those other points, and it *will not* snap to the middle point of the line, which I do all of the time.


Did I accidentally hit a CTRL+ or ALT+ key-stroke which has changed the abilities to snap?


Please, any assistance greatly appreciated.

Link to comment
Share on other sites

What osnap settings do you have active?


I have never really changed any of the default properties for AutoCAD, so *osnap* is new to me. I think it's easier if I just post the image:



Link to comment
Share on other sites

. If I zoom in I normally can put the grip any where I want to.


This doesn't sound like good technique, you should be using osnaps to locate geometry.

What are your F3 and F9 settings?

(I would do F3 on and F9 off).

Link to comment
Share on other sites

Next post...but here is something really weird...when I posted and went back to CAD, it was working as normal!!! Then it stopped working when moving from one line to another. It keeps changing functionality while I am working...


I am sure my technique is waaaaay off...I have not been instructed or mentored in any way, shape, or form.

Link to comment
Share on other sites

Well looking at all that I'm not sure where or what to try to reproduce your problem - I guess I was hoping you could delete most of it and just show a couple of pieces of geometry that exhibit the behavior.



....I can't help but make a couple of comments about the content.

I realize you got this from someone else, but I can't imagine doing that work without blocks (particularly blocks with attributes). Just those symbols for the windings.... ....shudder...

I would also have my border on correct sheet size in paperspace layout....

Link to comment
Share on other sites

Oh...sorry about that. I'll attach a simple dwg with specifics. It's doing it again...making me crazy.


I hate to admit it, but I made those transformers myself. I haven't graduated to blocks yet, but lurking around on the cad forums I figured there was a way to group all of those objects into one. I have a few years of experience in Photoshop but haven't found a cross-skills matrix to apply what I know there in AutoCAD. Your CADspeak in-and-of itself is confusing to me as well. I just don't have a grasp on the lingo yet.


Anyway, I am trying to change the length of the line between the objects labeled MTS1A and MTS1B. I cross select the line and three grips appear. I grab the right grip and try to drop it just to the left at it will not stick. The info text states "specify stretch point or" and then changes to "endpoint", I click and the line stays the original length. The line won't snap to the box around MTS1B either. I haven't had this problem until today and cannot figure out what I may have done to the program.


When it changes how it works from one gesture to the next...well...that's just weird.


CADTutor help1.dwg

Link to comment
Share on other sites

Whoa...here is something I just discovered. I can stretch lines and boxes to the right, but not the left. This goes for expanding or contracting the boxes...doesn't matter. It's a left/right thing. Then, snapping works back to the left, but not to the right. Still cannot snap back to the left to the midpoint of the line, either.



Link to comment
Share on other sites

Here's another discovery: If I try to move a box, I can only use the corner grip on the side I want to move towards, i.e., top grips to move north, bottom grips to move south. So, I can only *increase* the size of a box because they are on the outsides edges of the box.

Link to comment
Share on other sites

It was already set to 0 (zero), but I reset it anyway. No change.


The screen shots I include here may show clues. When I try to simply stretch a line it only gives two options: up and down, and back with that Ortho label. That used to say Specify Stretch Point, not Ortho.




Now again, when I try to stretch back to the mid-point, the snap selectpoint (orange box) is show at the lines source and snaps to there.



This is one of the really weird parts. When I try to change the size of a box (polyline rectangle, whatever) I can only move in the direction of the particular side I have selected. In the graphic here, see how the top right grip is selected as the snap point even though my crosshairs are to the left? It will not let me specify anything to the left as a stretch point. This works similar depending on selecting top, bottom or sides. I can only *increase* the size of the box.



Short of submitting a request to my IT department I am at a loss. That will take weeks. There has to be a logical explanation for this. I must have changed some setting inadvertently but I cannot figure it out.



Link to comment
Share on other sites

Got it...solution found.


I Googled Ortho and came up with the hint I needed. I never saw that Ortho box before...it always said Polar. When I entered the command Ortho and set it to off everything returned to *normal*. There must be a hot-key for that as well and I somehow invoked Ortho mode. I can see the benefits to that mode, but it doesn't work for me right now.

Link to comment
Share on other sites

There must be a hot-key for that as well and I somehow invoked Ortho mode. ..



never would have gotten that from your problem description.


Get a good book that covers blocks (especially with attributes) and become an expert on them. (you will want to go well beyond anything covered in any book on this topic) Will pay back dividends in a big way if this is your usual work.

There are some free classes here, mostly on dynamic blocks http://au.autodesk.com

You want to concentrate on attributes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...