Jump to content
WERDNA

Layers Keep Locking

Recommended Posts

WERDNA

Hi there, I isolated layers to help clear out a drawing, since then I have had nothing but hassle with locked layers, :ouch: No matter how many times I unlock them, they lock up again, :cry: if I create a new layer it comes in locked, :? if I change a line to a differant layer it locks up, :shock: I have tried creating a few simple layers, then copying and pasting the layout into a new drg file, still the problem exists, it is costing me a lot of time having to keep doing this, can anyone help/advise?

Share this post


Link to post
Share on other sites
Barneel

Post a picture of the layer properties manager (LAYER) :)

Share this post


Link to post
Share on other sites
WERDNA
2013-09-19_110110.jpg File attached, thanks for the response. As suspected the layers od theis file are locked, when I hover over the line it shows the padlock symbol.

Share this post


Link to post
Share on other sites
Barneel

And left clicking on the padlock doesn't permanently unlock it? Is it a read-only file?

Share this post


Link to post
Share on other sites
Dadgad

It sounds like you still have layers which are ISOLATED. Don't try to unlock them, but rather run the LAYUNISO command, that should take care of it.

Share this post


Link to post
Share on other sites
WERDNA

It's not a read only and according to layer manager it is unlocked, :?. Left clicking does switch it on or off, but regardless, once I have either closed the drg or changed the layer the line was on, it goes back to showing the locked symbol when hovering over lines, it is very odd. Could it be a security setting of some sort?

Share this post


Link to post
Share on other sites
Dadgad
It's not a read only and according to layer manager it is unlocked, :?. Left clicking does switch it on or off, but regardless, once I have either closed the drg or changed the layer the line was on, it goes back to showing the locked symbol when hovering over lines, it is very odd. Could it be a security setting of some sort?

 

Please try the LAYUNISO command. :)

Share this post


Link to post
Share on other sites
WERDNA

I have carried out layer uniso command, (many times) but still no joy. It may be unlocked briefly but for some reason reverts back to the padlock symbol when hovering over the line. I would attach a file to allow interrogation but cant see a link to carry that out?

Share this post


Link to post
Share on other sites
ReMark

Any chance you can attach a copy of the drawing to your next post? Having the real thing to test would be a big help.

Share this post


Link to post
Share on other sites
Dadgad
I have carried out layer uniso command, (many times) but still no joy. It may be unlocked briefly but for some reason reverts back to the padlock symbol when hovering over the line. I would attach a file to allow interrogation but cant see a link to carry that out?

 

Click on GO ADVANCED, then MANAGE ATTACHMENTS. Try repeating the LAYISO command before you run LAYUNISO. I have know LAYUNISO to fail to release an isolated layer, it really confused me for a couple of minutes when it happened. :|

Share this post


Link to post
Share on other sites
Barneel
I would attach a file to allow interrogation but cant see a link to carry that out?

 

Are you on Advanced reply?

Share this post


Link to post
Share on other sites
RobDraw

AFAIK, LAYUNISO will only work if it is the same drawing session.

 

What has happened is when you used LAYISO you did not follow that up with LAYUNISO. New layers take on the properties of the current or selected layer(not quite sure on that at the moment) and since most of your layers are locked the new one is also locked. I would suggest you select all your layers, CTRL+A while in the layer manager, and unlock them. Relock any that you normally keep locked.

Share this post


Link to post
Share on other sites
Dadgad
I have carried out layer uniso command, (many times) but still no joy. It may be unlocked briefly but for some reason reverts back to the padlock symbol when hovering over the line. I would attach a file to allow interrogation but cant see a link to carry that out?

 

Might you have saved a VIEW which included a LAYER SNAPSHOT inadvertently? Rob's guess sounds like a likely scenario, file saved while layers were still isolated, thus essentially creating a layer filter. :beer:

Share this post


Link to post
Share on other sites
ReMark

I was able to not only unlock all the layers but I was also able to create new (unlocked) layers. I saved the drawing under a new name and opened it. All layers remained unlocked. Not sure why you are experiencing any problems. I'm using 2013 this morning but save to 2010 file format. BTW...I did not use LAYUNISO or any other commands mentioned in this thread.

Share this post


Link to post
Share on other sites
WERDNA

Have you gone to paperspace 1st FLR tab and hovered over the drg sht frame? I am getting the padlock symbol even though it states in L.M. that it is unlocked.

Share this post


Link to post
Share on other sites
Barneel

I had problems with it returning to a locked state at first, but after saving the file under a new name, as ReMark said, I had no problems. I even managed to rip apart your drawing for you.

 

sdf.jpg

Share this post


Link to post
Share on other sites
Barneel

I'm not sure that I understand what you mean.

 

On the off chance this might be your problem: on your drawings when you're editing the sht frame it locks the drawing, and when you're editing the drawing it locks the sht frame. A shortcut to switch between the two is simply double clicking on either the frame or drawing (I think I got caught out by this when I was first looking at your drawings - mine don't do that). Is it possible you're accidentally doing this? :s

Share this post


Link to post
Share on other sites
ReMark
Have you gone to paperspace 1st FLR tab and hovered over the drg sht frame? I am getting the padlock symbol even though it states in L.M. that it is unlocked.

Yes I have and no padlock symbol shows up. Layer Manager is fine too.

Share this post


Link to post
Share on other sites
WERDNA

It was just a query, it is happening in paperspace as well as model space, layer manager is saying the layer is unlocked yet padlock symbol is showing when hovering over the lines. When opening the file it is locking all the layers, yet layer manager is saying they are unlocked, very strange.

 

Thanks for all the replies, I will keep digging, go back and see if it has something to do with the original drg.

 

I'm not sure that I understand what you mean.

 

On the off chance this might be your problem: on your drawings when you're editing the sht frame it locks the drawing, and when you're editing the drawing it locks the sht frame. A shortcut to switch between the two is simply double clicking on either the frame or drawing (I think I got caught out by this when I was first looking at your drawings - mine don't do that). Is it possible you're accidentally doing this? :s

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...