Jump to content
stevenwheatley

Removing all objects not on current page layout AutoCad LT 2013 and LT 2014

Recommended Posts

stevenwheatley

Hello, I work for a practice of landscape architects. On the project I'm working on we have a series of drawings covering the site layout or construction details. Each drawing will issue corresponds to a page layout. When we issue revised drawings to the contractor as PDFs we also need to issue DWGs to the other members of the design team.

 

I bind any xrefs and remove all unrelated page layouts... however, the DWG is still very large and most importantly the model space still contains a lot of extra, unnecessary information. It's just not cost effective to manually strip away objects that won't be visible in the page layout.

 

Is there a way to delete all objects from layers that are frozen or not visible, or all objects that are visible but do not appear within the viewports on the current page layout?

 

I already PURGE and -PURGE RegApps to reduce some clutter and reduce file size.

 

Oh - I've also tried the Export Layout tool. This frequently crashes with a fatal error and when it does work, the resulting model is in page units and looses it's "position" in the real world.

 

We're using both LT 2013 and LT 2014. I think we have access to a version of AutoCad Map 3d 2013.

 

Thanks for your time in reading this!

Share this post


Link to post
Share on other sites
steven-g

You could click into one viewport and try Ctrl+A to select everything, then click into each viewport and deselect everything in the viewport using Shift+ crossing window, you can go into all the viewports without losing the selection set, and deselect all visible items, and then press delete. This will delete everything else including stuff on layers that are 'off', but not frozen layers.

But I would do a test first on a copy of a drawing.

Share this post


Link to post
Share on other sites
stevenwheatley

Many thanks Steven. That seems to work for a layout with one viewport looking onto the model. I can't seem to get it to work with a layout with multiple viewports. No matter.

Share this post


Link to post
Share on other sites
steven-g

Once you have deselected objects in one viewport you should be able to just use a single left mouse click over another viewport to make that viewport active without altering the selection set, then, deselect objects again with shift and mouse.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×