Jump to content
Mr NERV

Weird blurry (low quality) image when plotting a style other than "Wireframe"

Recommended Posts

Mr NERV

Hi, I'm new to AutoCAD, I've been using it for the past half year and have gathered enough knowledge to draw anything I need for my project, but I'm having problems plotting my drawings to .pdf (or printer or any other device).

 

When i plot with shade plot "Wireframe" the result is perfectly fine, the lines are clear, everything is easily readable. But when it use the shade plot "Hidden" or "Shaded" or any other than "Wireframe" i get a fuzzy image, that is hardly readable and difficult to hand out to someone.

 

It is the same no matter what setting i change. The image quality is poor already when i click "Preview", so it seems that it must be something within AutoCAD.

 

Here is an example of plotting my drawing, notice that the only difference in the settings is the "Shade plot" setting:

 

http://i.imgur.com/ztZ8mxF.jpg

 

Thank you for your help.

Share this post


Link to post
Share on other sites
ReMark

Forum member Tanner Frampton offered this advice regarding a similar question. Maybe it will be of some help to you.

 

AutoCAD has never been "great" at plotting 3D linework. A couple things you can try:

 

- Change the Shade Plot from "As Displayed" to "Legacy Hidden"

- use the HIDE command before you plot.

- Toggle the INTERSECTIONDISPLAY variable to see if you get better results.

- Toggle the DISPSILH variable to see if you get better results.

Share this post


Link to post
Share on other sites
tzframpton

Also note that when you plot Wireframe, it's plotting vector linework. Hidden or Shaded it turns to Raster, which is where your "fuzzy" is coming from. Even though you have your DPI set to maximum in AutoCAD, this doesn't control the DPI settings when the pass-through to your PDF plotter happens. This means you still have to set your PDF plot driver to a higher resolution as well. In fact, I take use Zip Compression settings in the PDF plot driver to get maximum output when I plot shaded views. 400 DPI is the standard resolution for plotting so that DPI will be perfect for any output. If you want even higher resolution, regardless of paper print standards, then you can go higher but there's really no need.

Share this post


Link to post
Share on other sites
tzframpton

I've uploaded a couple of examples. In the Zip file you'll see four files, a low/high plot of Hidden and a low/high plot of Shaded. The "low" plots used the integrated DWG to PDF.pc3 Plot Driver which is great for linework drawings but is no good for shaded plots. The "high" plots used the PDFCreator plot driver where you can actually change settings. Everything was plotted 400dpi but high quality plots I changed the compression to Zip Compression. Zoom in on any corner and you'll see the differences in clarity. Plotting is where you really see the differences. Raster Plots from a Hidden or Shaded plot view, when changed to Zip Compression @ 400 DPI will look almost identical to vector graphics if you plot to paper.

 

Hope this helps. :)

Plot.zip

Share this post


Link to post
Share on other sites
Mr NERV
- Change the Shade Plot from "As Displayed" to "Legacy Hidden"
This actually works fine, so for now it will have to do. The other stuff had no effect. Thank you (and Tanner Frampton of course).

 

Also note that when you plot Wireframe, it's plotting vector linework. Hidden or Shaded it turns to Raster, which is where your "fuzzy" is coming from. Even though you have your DPI set to maximum in AutoCAD, this doesn't control the DPI settings when the pass-through to your PDF plotter happens. This means you still have to set your PDF plot driver to a higher resolution as well.
Yes i understand that it uses Raster, but i think it has to be some setting or something inside AutoCAD, because the the preview of the plot inside AutoCAD already looks like the "resolution" is in very low DPI. After the plot the .pdf than has a "blurred" or "antialiased" image of that low resolution image from the preview.

 

In fact, I take use Zip Compression settings in the PDF plot driver to get maximum output when I plot shaded views.
Can you please explain this part a bit more, i dont understand exactly what you mean.

 

Thank you also for you answer.

Share this post


Link to post
Share on other sites
tzframpton
Yes i understand that it uses Raster, but i think it has to be some setting or something inside AutoCAD, because the the preview of the plot inside AutoCAD already looks like the "resolution" is in very low DPI. After the plot the .pdf than has a "blurred" or "antialiased" image of that low resolution image from the preview.
The Preview is exactly that - a "preview". Don't expect it to look exactly like the processed output because it won't. So, for now, disregard everything about the Preview because it really doesn't matter.

 

I've told you above that it's not AutoCAD, it's the PDF processing. This is the stage where it takes the information and creates the PDF, but the PDF settings is where the magic happens. DWG to PDF.pc3, as far as I know, doesn't give you a robust set of configuration settings that other PDF plot drivers give you, such as the native Adobe PDF driver or PDFCreator driver.

 

Can you please explain this part a bit more, i dont understand exactly what you mean.
Read here: http://www.prepressure.com/pdf/basics/compression

 

This lists the different types of compression algorithms available in most PDF output programs. Scroll to the bottom to get a definition of ZIP Compression. What it does is use the commonly known *.ZIP type of compression algorithm to create the PDF, which is "lossless" so the image is not effected and why you get a much higher quality output. Granted, you can export your PDF to uncompressed but you'll wind up with 20MB files. So, my reasoning behind directing you to use ZIP Compression is two things: It's lossless so image quality is not compromised, and it compresses so file size is not compromised, giving you the best of both worlds.

 

Hope this helps! :)

 

PS: Did you not compare my files that I posted? That shows the differences.

Share this post


Link to post
Share on other sites
ReMark

Mr Nerv: Would it be possible to get a copy of your 3D drawing for testing purposes (printing)? Thank you.

Share this post


Link to post
Share on other sites
rkent

I think the answer to this is to use VIEWBASE and the associated commands. You can control the lines through layer control, plot styles, etc. The plotted image is better than the method you are using.

 

If you are going to stay with visual styles then drop the styles from the Visual Styles Manager onto a tool palette, then you can edit them and the changes will be there for future work. Looking at your example I would either turn Silhouette Edges to not show or change the width to 1, at least as a place to start.

Share this post


Link to post
Share on other sites
ReMark

LegacyHiddenPDFplot.jpg

Forgive me if my representation of your 3D drawing is a bit off. I had nothing to go by other than the posted image.

 

Screen shot of my plot preview using a monochrome.ctb, Legacy Hidden shaded plot option, with output to PDF via the default DWG To PDF.pc3 that comes standard with AutoCAD.

 

Would you not agree the preview is quite sharp?

 

Changing to a Hidden shade plot style (quality: maximum) the image does degrade slightly but nowhere near what your image displays.

Share this post


Link to post
Share on other sites
ReMark

HiddenShadePlotMax.jpg

Shaded plot: Hidden

Quality: Maximum

 

DWG TO PDF.pc3

Share this post


Link to post
Share on other sites
tzframpton

ReMark, the O.P. is using the native Adobe PDF plot driver which is why he's getting severely bad results. DWG to PDF.pc3 does produce better quality right out of the box but nothing as good as ZIP Compression @ 400dpi and above, which can be accessed by the native Adobe PDF plot driver.

 

What you have might be more than good enough for the O.P. :)

Share this post


Link to post
Share on other sites
ReMark

I think the first image I posted looks pretty darn good considering it is the default DWG-to-PDF option and there are no dpi settings that one can tweak.

 

Maybe he should consider switching until such time as he can more thoroughly investigate the option you mentioned.

Share this post


Link to post
Share on other sites
Mr NERV
I've uploaded a couple of examples...
In this plots from your .zip I see compression difference (like jpeg artifacts) but the DPI of the drawing is the same. Compression is not the problem here.
The Preview is exactly that - a "preview"...
OK, I'll ignore the preview.
Thanks, i understand about compression, I didn't understand where you set those setings. I now understand you use PDFCreator to plot to .pfd. I installed it and found the ZIP compression settings. I tried using it to plot to .pdf but I got the same result.

 

 

 

Screen shot of my plot preview using a monochrome.ctb, Legacy Hidden shaded plot option, with output to PDF via the default DWG To PDF.pc3 that comes standard with AutoCAD.

 

Would you not agree the preview is quite sharp?

Yes it is sharp enough. I tried the "Legacy hidden" after your first post and it works well , i get the same result as you just did. (I already thanked you for it above :D )
Shaded plot: Hidden

Quality: Maximum

 

DWG TO PDF.pc3

Yes, i get the same result, and you see how the resolution looks worse than with "legacy hidden" or "wireframe". I understand, that "wireframe" is vector and everything else is raster, but there should be a way to up the DPI to a level, where the results would be presentable.

 

Here are my files. A .dwg and three plots, one "wireframe" with "default DWG To PDF.pc3" one "hidden" with "default DWG To PDF.pc3" and one "hidden" with PDFCreator.

 

You can see in the .pdfs, that its not only the compression, but the whole image looks off, lines look broken on missing in some places, and the biggest problem, the annotations look barely readable.

 

 

 

Prototype02-03-plot.dwg

Prototype02-03-plot-wireframe.pdf

Prototype02-03-plot-hidden.pdf

Prototype02-03-plot-PDFCreator.pdf

Share this post


Link to post
Share on other sites
ReMark

I was merely trying to reproduce the problem you were seeing and to confirm what Tanner had suggested.

Share this post


Link to post
Share on other sites
tzframpton
Thanks, i understand about compression, I didn't understand where you set those setings. I now understand you use PDFCreator to plot to .pfd. I installed it and found the ZIP compression settings. I tried using it to plot to .pdf but I got the same result.
You didn't need to install it since you already have the native Adobe PDF print driver. That comes with Adobe Acrobat. But, either way.

 

I understand, that "wireframe" is vector and everything else is raster, but there should be a way to up the DPI to a level, where the results would be presentable.
I still don't think you're quite understanding how it works. The DPI can be super extreme... say 2,400dpi and you can still have unsatisfactory results because of the compression. You just have a higher resolution version of bad results. Think about it... the "page size" is exactly the same physical size. The DPI is the granularity precision in a physical square area distance. So DPI does not necessarily have a direct link to compression. The way something compresses a rasterized image is what gives you the "dirty artifacts" around the linework you want silky smooth. So, to conclude:

 

  • DPI is the amount of pixels in a given square area
  • Compression, depending on the type, is the quality for raster image outputs. Lossless vs Lossy compression types determines this.

Unlink DPI as "quality" in your mind and it will help you better understand why you're getting these types of outputs. Remember that vector uses algorithms to generate the linework so no compression is needed. :)

 

PS: Let me clarify: DPI can affect quality but not in the sense you're discussing. Sure, if you have a low DPI things can be pixelated when printed, but only on raster images. DPI should always be related to physical printing. This is why a screenshot image created in Windows is crystal clear but when printed is pixelated because of the native DPI.

Share this post


Link to post
Share on other sites
Mr NERV

Thank you for your effort. Let me just explain that i fully understand what DPI is and how it works. My misconception was based solely on on the assumption, that everything in my "hidden" .pdf was drawn wrong, because i did not zoom in enough and Adobe Acrobat has a weird way to show some lines when zoomed out. My assumption that everything is wrong was triggered by the "unreadable" rendering of the annotations, which i still think is a problem, that i have to deal with.

 

 

animated.gif

 

See this example. When zooming to 800% in my .pdf i see now, that the lines are drawn OK (except for the compression artifact, which are gone when i use PDFCreate) so it's really not a DPI problem as I falsely assumed before.

 

But the number 332 (text) from the annotation is really rendered weird. It looks like its bolded or extruded to a level it's hardly readable.

 

So it looks like i have to find out why the annotations look like they look after converting.

 

Again thank you for your help! I'm really surprised at the quality and swiftness of this communities response.

Share this post


Link to post
Share on other sites
Designer2060

Is it possible to create a visual style in AutoCAD that has the same exact settings as the shade plot setting called "Legacy Hidden". This shade plot style creates excellent quality vector PDF output, but leaves a lot to be desired in the way of aesthetics. Also the multitude zig-zagging lines is confusing to the eye. A hidden style is much more simplistic to look at, but the PDF output for visual styles based on the hidden style, generates raster PDF output when vector output could easily be generated from the simplistic line geometry that is represented by a hidden visual style.

 

Does anyone have any thoughts on this?

Share this post


Link to post
Share on other sites
Gabriel.gabriel
Posted (edited)
On 6/5/2014 at 9:41 AM, tzframpton said:

Also note that when you plot Wireframe, it's plotting vector linework. Hidden or Shaded it turns to Raster, which is where your "fuzzy" is coming from. Even though you have your DPI set to maximum in AutoCAD, this doesn't control the DPI settings when the pass-through to your PDF plotter happens. This means you still have to set your PDF plot driver to a higher resolution as well. In fact, I take use Zip Compression settings in the PDF plot driver to get maximum output when I plot shaded views. 400 DPI is the standard resolution for plotting so that DPI will be perfect for any output. If you want even higher resolution, regardless of paper print standards, then you can go higher but there's really no need.

 

Hi my friends. I am trying Autocad2019, and I faced that same issue. Blurred and horrible images, rasterized, from hiden viewport plotting. I find out that you can plot through adding a PostScript Level 1 or similar, then generating an EPS file, or dwg to pdf, whatever,  and then in AI I finish some page configs and logos and etc. Many people may do this way. But in the latest versions of Autocad, seems they, among a thousand of awful changes, have discovered also a way to destroy the plot productivity (And I´m building a book to myself to revert those unproductive and desperately annoying changes). But I did find how to fix it, this issue of hidden blurred plotting. I use paper space (dont know if via model also works), and by clicking the viweport border with the right button, choose > Shade Plot > Hiden. You will get vectorized hidde perfect and light images and files, just like it was during the Golden ages of AutoCAD, when they did not put teenagers who never worked in life, to develop new interfaces to sell the "best newer version with 10.0000 ways for you to revert for a clever, light, clean and fast way to work, and not waste 95% of your time solving software issues".

 

And NO, hidden does not mean RASTER, never meant. God bless Autodesk.

 

keywords: SOLVED, AutoCAD, 2015, 2016, 2017, 2018, 2019, hidden, blurred, vector, vectorized, postscript, level 1, shademode, file, heavy, PDF, plot, configuration, revert, stupid changes, awful, traumatic, hell, we are already in hell, life is an app, delicate, "mama said I am special".

Edited by Gabriel.gabriel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...