Jump to content
eloid

2014 paper space /viewports in metric cant scale correctly !

Recommended Posts

ROBP
/yup, that will work too, but Eloid will still have to scale it and replace the dimensions, and everything. -DWGUNITS takes all that and fixes it Automatically. Of course there may be some minor tweaks that have to be fixed like dimension style details, if there are any suffix or precision changes needed.

 

dwgunits does work on earlier versions have no choice but to use the long way.

 

I will use at the office we are utd on cad

thanks for the info on the new command

R

Share this post


Link to post
Share on other sites
Dana W
dwgunits does work on earlier versions have no choice but to use the long way.

 

I will use at the office we are utd on cad

thanks for the info on the new command

R

-dwgunits (has to have the hyphen) has been around for some time except in the LT version. Not sure from when, but I used it in 2008 full. AutoDesk even saw fit to add it to the LT version, I think in 2013. I think that some of the earlier versions of -DWGUNITS don't rescale the drawing objects though, the operator has to do it. I could be wrong about that.

 

I just hope that Eloid is not just overwhelmed. Seemed a little exasperated. I can understand that. The week-end is here, and a coooooold mug of Sierra Nevada Beer Camp Hoppy Lager awaits. Everything looks easier on Saturday morning. Cheers.

Share this post


Link to post
Share on other sites
ROBP
-dwgunits (has to have the hyphen) has been around for some time except in the LT version. Not sure from when, but I used it in 2008 full. AutoDesk even saw fit to add it to the LT version, I think in 2013. I think that some of the earlier versions of -DWGUNITS don't rescale the drawing objects though, the operator has to do it. I could be wrong about that.

 

I just hope that Eloid is not just overwhelmed. Seemed a little exasperated. I can understand that.

 

Hyphen of course it does it in a jiffy wow cool did not know about that one

Learn some new everyday also

 

Here too well at least Eloid did learn a new trick

Share this post


Link to post
Share on other sites
Dana W
Hyphen of course it does it in a jiffy wow cool did not know about that one

Learn some new everyday also

 

Here too well at least Eloid did learn a new trick

:lol: The devil is in the details now ain't he?

 

Yeah, hopefully after a nights sleep, the OP can see the instructions in not such a foggy atmosphere of pressure.

Share this post


Link to post
Share on other sites
eloid

Hello Dana

 

 

Yes the drawing units must be meters. option (6) from drawing units using -dwgunits command.

 

 

When -dwgunits is complete I notice my dimensions have changed?. ie... what was 5m( old drawing) is now .1524m? so do I just need to rescale my drawing now?... so the model measure correctly????????

Share this post


Link to post
Share on other sites
Dana W
Hello Dana

 

 

Yes the drawing units must be meters. option (6) from drawing units using -dwgunits command.

 

 

When -dwgunits is complete I notice my dimensions have changed?. ie... what was 5m( old drawing) is now .1524m? so do I just need to rescale my drawing now?... so the model measure correctly????????

Probably all you have to do is open the dimension style editor and change your primary units to meters. Make sure you look at UNITS and be sure that is also set up for meters.

 

-DWGUNiTS should have scaled ALL of your drawing objects for you IF you answered Yes to the following;

 

** WARNING: you have changed the unit for this drawing database. **

** All new objects will be drawn according to the new unit, but **

** existing objects will not change size unless you specifically **

** ask to have automatic scaling occur. **

 

Scale objects in current drawing to reflect change in units? [Yes/No] : y

 

Include objects in Paper Space? [Yes/No] : y

Share this post


Link to post
Share on other sites
eloid

I had to scale it my self, after following your step ... step by step..... I believe its correct now for scaling.

 

 

Problem 2.... In model space my dashed lines set bylayer look ok.... in model space but in paper space there solid. In paper space tried changing the properties under bylayer / other/ hide details.

 

 

I set (use paper space units for scaling off) (blank) try regen my paper space viewport... no luck.

 

 

then i tried changing my global setting of (1 default to 25.4 -30) then doing a regen command in paper space again and the lines are still solid vs model why?

Share this post


Link to post
Share on other sites
Dana W

Did you check the dimensions primary units? Is there a scale factor applied to your dimensions?

 

I dont understand why it did not scale to meters correctly when you ran -dwgunits. It is infallible.

 

You have to be careful using the shotgun approach to fixing things. I don't even know what some of the stuff you did to try and fix the dashed lines means.

 

Try setting paperspace line type scale PSLTSCALE to 1, and global line type scale LTSCALE to 1 They are system variables. just type the bold names into the command line one at a time and change the values.

 

If that does not do it, then select the lines in modelspace, open properties and change their object property Line Type Scale to a larger number than it already is, until they look correct in paperspace.

 

Those items above control the "scale" of the lines. Your dashed lines in paperspace are still dashed, but the dashes are so small, and so close together that you can't see them.

Share this post


Link to post
Share on other sites
eldon

If you set the system variable MEASUREMENT to 1, then all your troubles will be over.

 

If you realize that AutoCAD plots in millimetres and your drawing units are metres, then all your troubles will be over.

 

When you come to choosing the viewport scale, then (using the above new knowledge), the viewport scale is 1000/100.

 

The default plotting scales are not set up for metre units, so the thing to remember is that the plot scale is drawing units in millimetres divided by the scale required. So in your case is 1000 (millimetres in a metre) divided by 100.

Share this post


Link to post
Share on other sites
RobDraw

This metric stuff is so confusing.

Share this post


Link to post
Share on other sites
Dana W
I had to scale it my self, after following your step ... step by step..... I believe its correct now for scaling.

 

 

Problem 2.... In model space my dashed lines set bylayer look ok.... in model space but in paper space there solid. In paper space tried changing the properties under bylayer / other/ hide details.

 

 

I set (use paper space units for scaling off) (blank) try regen my paper space viewport... no luck.

 

 

then i tried changing my global setting of (1 default to 25.4 -30) then doing a regen command in paper space again and the lines are still solid vs model why?

I figured out What I told you incorrectly to do when running -DWGUNITS. I forgot to change the default to in answer to the prompt below

** WARNING: you have changed the unit for this drawing database. **

** All new objects will be drawn according to the new unit, but **

** existing objects will not change size unless you specifically **

** ask to have automatic scaling occur. **

 

Scale objects in current drawing to reflect change in units? [Yes/No] : y I should have indicated that the correct answer here is NO. We do not want the existing objects scaled. That is why they came out Way Too Small when you did it. My bad. I was thinking backwards for some reason right then. This line >> ** existing objects will not change size unless you specifically ** is counter-intuitive and made me second guess myself.

Share this post


Link to post
Share on other sites
ReMark

Maybe AutoDesk should consider making acadiso.dwt the default template file for any copy of AutoCAD sold outside of the United States. Then we can stop having this conversation ad infinitum.

Share this post


Link to post
Share on other sites
sparkyuk
Maybe AutoDesk should consider making acadiso.dwt the default template file for any copy of AutoCAD sold outside of the United States. Then we can stop having this conversation ad infinitum.

 

 

And also give the ability to select English as default instead of having only having "American English" to select what ever that is lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...