Jump to content

Command Line Not Staying Docked - *FIX*


Recommended Posts

I'm posting this for any future people encountering the same issue.

Hopefully it will save them some frustration!


I'm old and I like the Command Line under the tabs. Personal Pref...

I tried letting it float and adjusting transparency settings for several months

and I'm just an old dog.


I just read every thread I could find about how to get the Command line to stay put.


I tried every variation if LOCKUI with no luck.

Saving Workspaces (and new Workspaces) didn't work for me.

CUI didn't work either.

(Restarting ACAD always reset the location)


Easiest Fix - WSSETTINGS -> Check Automatically Save Workspace Settings


ALT Method/Same Command -

Workspaces Pulldown (Upper Left of center)

Where Drafting and Notation, 3D Modeling, 3D Basics are located

Pick Workspace Settings

Check Automatically Save Workspace Settings


I did find this mentioned in one thread but it was a bit obscure.

Don't mean to offend anyone, :cry:

just trying to do something to help others the way many on here help me! :)

  • Like 1
Link to comment
Share on other sites

I'm glad you posted this!!


My company setup multiple workspaces for the different departments, and I was unable to get my stuff to stay put.


This solved my issue!

Link to comment
Share on other sites

  • 6 years later...

Thank you!

I was looking all over to make the command line docked.

It used to stay put, don't know why all of a sudden my civil3d 2020 decided not to put command line docked.

but yes other threads were not very clear of what to do.


Although, other autocad that I have installed have the WSSETTINGS as do not save automatically, don't know why my Civil3d is acting differently...

but anyway it worked! 

Thank you!!

Link to comment
Share on other sites

In the CUI you can Customize Workspaces, expand Palettes and select Command Line then modify the properties below.

Workspace Settings do get messed up sometimes like when a palette disappears. Having them automatically saved prevent you from being able to fix the issue by simply switching workspaces back and forth.

  • Like 2
Link to comment
Share on other sites

@tombu Thanks!

I thought WSSETTINGS was working, but it did not work after all...

Thanks for the solution!!

CUI - Workspace - Palette - Command Line - Modify properties looks like the right way to fix the issue!! 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...