Jump to content
fdefrance

convert cloud of points or mesh into surface

Recommended Posts

fdefrance

Hello,

 

I am using Matlab to create a surface I import into Autocad Mechanical 2015.

Matlab uses a library to convert a matrix into a .dxf 3D surface. Depending on the option, the surface is either a cloud of points, or made of triangles or square patches (linking the points). (files attached)

I can open these files with AutoCAD Mechanical and even export them in other formats (ie. stp), but I would like to convert the cloud of points or the triangles mesh into a surface (mostly to reduce the size of the file).

For now I have 4 millions points (which gives me a 19MB .stp file when I export the triangle mesh .dxf file into .stp). I am planning to increase the resolution... So it is not possible to keep all the points and triangle meshs and I hope that there is a way to replace the meshs and points into a surface in order to make it easier to handle by AutoCAD, and lighter to export. (I need to export it in .stp (or similar format) so it can be used by an electromagnetic simulation software (HFSS, CST...)).

 

How can I do with Autodesk product design suite ultimate 2015?

(AutoCAD Mechanical, Inventor pro...)

 

Best regards,

 

Fabien

triangles_and_points.zip

Share this post


Link to post
Share on other sites
ReMark

I managed to create a single surface (one object) using your triangle_mesh.dxf file. Is that what you are looking for? BTW....the saved file size is 9.32MB.

Edited by ReMark

Share this post


Link to post
Share on other sites
fdefrance

It is better than what I managed to do! How did you do to convert the mesh into a surface?

However, this element is only a small cell of 2mm x 2.2mm. I will need to create a bigger surface by duplicating the cell several times (to make a complete grating, of 50mm x 50mm, I would have to duplicate it more than 500 times... Maybe I will start smaller though!). Anyway, it would be good if it were possible to reduce the file size even more.

 

Thank you!

Share this post


Link to post
Share on other sites
ReMark

This is how I did the conversion.

 

I first made sure the system variable FACETERSMOOTHELEV had a value of "0". Next I used the CONVTOMESH command to convert the polygon mesh to a regular mesh. Finally I used the CONVTOSURFACE command to convert the mesh to a surface.

 

I can foresee problems duplicating the surface 500 times. The file size will big immense. Hope you have a brute of a computer.

Share this post


Link to post
Share on other sites
fdefrance

I just tried that. (well, first I had to download the English package for AutoCAD because I realised that the name of the commands change depending on the language of the version...).

The CONVTOSURFACE command lasted for almost an hour. The result is a surface, but quite an heavy one! (about 200MB when I export it in dwg or sat or igs). As you can see attached (pict), when creating the surface, a lot of lines were created to interpolate the points. I should be why the file is so big.

I tried PURGE, setting PROXYGRAPHICS to 0 or converting the surface to NURBS, it didn't change the size.

Why is the size so different to what you obtained? In what format did you export it?

surface_autocad.jpg

Share this post


Link to post
Share on other sites
ReMark

Who said anything about exporting the drawing? I got as far as creating a surface, as per your request, then saved the drawing. That was all I did.

Share this post


Link to post
Share on other sites
fdefrance

In fact, I saved it (in dwg) and also exported it (in sat and igs). But even the saved file in .dwg is 195MB big. So, it seems like my surface is a lot heavier than yours, even though I used the same commands. I am trying to understand what happened. I attached a picture of my surface so you can compare to what you obtained. Do you also have so many lines interpolating the points? In what format did you save the file?

 

Thank you very much for helping me.

Share this post


Link to post
Share on other sites
ReMark

Repeat: My saved drawing file (2010 file format) was less than 10MB. I don't know what you are doing that accounts for the almost 20 fold increase you are getting.

Share this post


Link to post
Share on other sites
fdefrance

Thanks, but you don't have to repeat. As I wrote in my previous post, I was trying to understand why I wasn't obtaining the same file size as you.

I finally found out. There is a variable : SMOOTHMESHCONVERT which has to be set to 3 (or maybe 2). So, AutoCAD doesn't try to smooth the surface. By default it is set to 0, which results in a really long execution time and gives a smooth but really heavy surface.

Now, the command is exectuted in 1s and I get a 9.8MB .dwg surface file, like you. Thanks for your help

Share this post


Link to post
Share on other sites
Tyke

You don't need to download an English version of AutoCAD or even a laguage pack if you are using a non English version. Just preceed the English command with an underscore character e.g. "_CONVTOMESH"

Share this post


Link to post
Share on other sites
fdefrance

Nice tip! It would have saved me some time. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×