Jump to content
Sbeth85

Dimensions showing BOTH metric and imperial?

Recommended Posts

Sbeth85

Hi-

 

I'd like to dimension a drawing in both feet and centimeters. Is there some sort of DimStyle workaround to get this to happen automatically?

 

Yes, I know I could manually overwrite each dimension and do "inches", but is there a way to do it automatically?

Thanks!

Share this post


Link to post
Share on other sites
rkent

Open Dimstyle, use the Alternate Units tab, notice the muliplier for alt units, set that for the conversion to cm, etc.

Share this post


Link to post
Share on other sites
Sbeth85

Rkent-

Thank you, but I got a little confused about how to it properly.

 

Currently I work in CM.

I'd like it to display in feet and inches.

Example: 167 cm / 5'6"

 

(as opposed to 167 cm/5.5)

Is this possible? Can I have the name of the units show besides it? How do I deal with this multiplier thing?

Share this post


Link to post
Share on other sites
Sbeth85

Followup:

I've played around and gotten to the point where my measurement will look like this:

 

240 [7 7/8"] which is the "Architectural" Alt format

or

240 [7.82] which is the "Decimal" Alt Format

 

But none of the formats are giving me what I'd really like, which is to see:

240 [7'10"]

or better yet

240 cm [7'10"]

 

Anyone?

Share this post


Link to post
Share on other sites
ReMark

Using plain AutoCAD.

 

AltDims.jpg

 

With the "cm" added as a suffix.

 

AltDimCM.JPG

Edited by ReMark

Share this post


Link to post
Share on other sites
Dadgad

When I need to use and display alternate units, if there is sufficient room in my drawing, I like how they look with the placement of the two above and below the dimension line.

In some instances a drawing might be too dense to do it this way, as it does take up a bit more room. This is just a heads-up for another way to display them. Of course, there is another Architectural units display style, called Architectural Stacked, which might be preferable, available in the unit format drop down list. :)

alternate units placement option.jpg

architectural stacked alternate units.jpg

Edited by Dadgad

Share this post


Link to post
Share on other sites
Sbeth85

ReMark and Dadgad-

Thanks for your responses.

 

I've been able to do both of what you've shown (imperial besides the cm and imperial beneath the dim line). The weird thing is that the apostrophe after feet isn't showing up! And since it's in the middle of the measurement it's not like I can add a suffix... how odd! :?

 

autocad imperial dimension problem.jpg

Share this post


Link to post
Share on other sites
eldon

Both your alternate units are showing 7 7/8". There are no feet. What is your conversion multiplier?

Share this post


Link to post
Share on other sites
ReMark

How is it that you managed to get 240cm to equal 7.87 INCHES? In one of your previous posts you had the conversion correct. Now it is wrong. You changed something. Probably the multiplier.

Share this post


Link to post
Share on other sites
Dadgad
How is it that you managed to get 240cm to equal 7.87 INCHES? In one of your previous posts you had the conversion correct. Now it is wrong. You changed something. Probably the multiplier.

 

Sbeth, please do us a favor and start the -DWGUNITS command, what does it report as your current units or ?

You said your units were cms, I am curious if they really are, or possibly mms?

Don't change anything, just report back to us whatever the first response is.

I suspect that it will be for mms, instead of for cms, quite independently of whatever suffix might have been added.

Eldon & Remark are correct, as usual, your alternate multiplier is off.

 

Of course the only way to know definitively, what it should be, is to determine in what units your drawing has really been created. :)

Edited by Dadgad

Share this post


Link to post
Share on other sites
SLW210

What is the number you have in the "Multiplier for Alt Units" box? It should be .3937.

Share this post


Link to post
Share on other sites
Sbeth85

My -DWGUNITS is 4.

 

I think there must have been something wonky going on, because my multiplier WAS 0.3937, and yet the dims were coming out weird.

In any case, I made a dimstyle from scratch according to your instructions and it looks ok now.

Thank you guys!

 

autocad imperial dimension problem- solved.jpg

 

autocad imperial dimension problem- solved-settings.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...