Jump to content

Recommended Posts

jUNI0R

Hey everyone,

 

I am new to drafting and been having trouble with Osnaps and Ortho clashing when i draw lines, plines, measure and etc. Pretty much anytime i type in a command, and sometimes randomly. What i mean is that whenever i press F3 which is key bound to snaps or F8 which is key bound to Ortho they scramble up. Example: Im drawing a line to the edge of another line so to keep it straight i press ortho but it turns osnaps off, so i press osnaps to turn it back on, but it than turns my ortho off. So i press osnaps again and it actually turn it back, so than i go back to pressing ortho and it turns my osnaps off again and its a big merry-go-round that takes up to 5 minutes to get correct. Sometimes i just end up closing AutoCAD completely to fix this, but after awhile it starts back up again.

 

If anyone knows how to fix this, it would be much appreciated!

Thanks.

Share this post


Link to post
Share on other sites
BIGAL

Look into using F10 polar tracking it does the snap intersection with a ortho say for a line on an angle.

Share this post


Link to post
Share on other sites
jUNI0R

Sweet as, thanks mate. That one is actually pretty good. Just now have to create a new habit. Wish Snaps and Ortho would just work...

Share this post


Link to post
Share on other sites
ReMark

While you may have found a work-around it doesn't solve the problem. I would recommend first trying to "Reset Settings to Default" as found under the AutoDesk program heading in the Start menu.

Share this post


Link to post
Share on other sites
rkent
Hey everyone,

 

I am new to drafting and been having trouble with Osnaps and Ortho clashing when i draw lines, plines, measure and etc. Pretty much anytime i type in a command, and sometimes randomly. What i mean is that whenever i press F3 which is key bound to snaps or F8 which is key bound to Ortho they scramble up. Example: Im drawing a line to the edge of another line so to keep it straight i press ortho but it turns osnaps off, so i press osnaps to turn it back on, but it than turns my ortho off. So i press osnaps again and it actually turn it back, so than i go back to pressing ortho and it turns my osnaps off again and its a big merry-go-round that takes up to 5 minutes to get correct. Sometimes i just end up closing AutoCAD completely to fix this, but after awhile it starts back up again.

 

If anyone knows how to fix this, it would be much appreciated!

Thanks.

 

This was supposedly fixed in one of the 2017 updates, are you running the latest update/patch?

Share this post


Link to post
Share on other sites
Dana W

I'm running 2018, and there is still a difficulty with snaps and ortho. It's not that they mutually exclude each other. Ortho gives priority to snaps that are on the X or Y axis. Sometimes a snap will be acquired even if it is off screen and the cursor is moving away from it, depending on where the cursor was when the command becomes "live" by moving the cursor. Sometimes this conflict makes it seem as though there are no snaps working because ortho is busy trying to find one on X or Y. I wonder if this is muddying the water a bit for the OP. I do use polar tracking and auto snap tracking too, to clear up the issue, but it is not perfect.

 

I try to avoid using ortho at all unless I need to draw something exactly on X and Y that I can't make with a polygon. Polar tracking does a pretty fair job of "locking" onto X and Y itself. One just has to be aware of how it operates and slow down so one can see the lock occur.

Share this post


Link to post
Share on other sites
RobDraw

I love Polar tracking when you combine that with OSnap tracking, it's the cat's meow. I stopped using Ortho many years ago.

Share this post


Link to post
Share on other sites
jUNI0R

Ill try that soon, i'm not too confident in messing with work files at this very moment. (Just lacking the knowledge to do it correctly without affecting other work files.)

Share this post


Link to post
Share on other sites
RobDraw

Just do it. If it doesn't work, UNDO!

Share this post


Link to post
Share on other sites
Dana W
Just do it. If it doesn't work, UNDO!
...Or when it asks you if you want to save after clicking the red "X", click No. And, Autosave DOES NOT overwrite the work file. By the way, the tracking and snap settings reside in your own workspace, not the drawing file. You can't damage the files by changing drafting settings, unless you save one full of errors. To prevent that, make a copy (save as) of a file to play with on your "C" drive. Name it something so unique that it can't possibly be saved over another drawing, like Gilligan's Island.dwg or something.

 

You can even protect your own workspace from silly mistakes. After making settings changes, save your workspace as one with a name indicating practice area or something. Then, change to the practice workspace whenever you need to play with enlightenment. Don't set your practice workspace as the default workspace. That way you can go back to boring old out of the box settings simply by default when you start the program up.

Share this post


Link to post
Share on other sites
RobDraw

Great advice, Dana!

Share this post


Link to post
Share on other sites
Dana W

All learned the hard way.:shock:

Share this post


Link to post
Share on other sites
tombu

While Osnaps and Ortho can easily be toggled Off/On by clicking buttons on the Status Bar AutoCAD also has default Temporary Override Keys for both when prompted for a point as well.

You can see their buttons on the Status Bar toggle Off/On while holding down the shift key for Ortho or holding down both Shift and A or Shift and ' for Osnaps.

 

More about Temporary Override Keys: https://www.cad-notes.com/10-autocad-temporary-override-keys/

CADNOTES has lots of AutoCAD tutorials and information. I've been subscribed for years and would recommend it to anyone.

Share this post


Link to post
Share on other sites
jUNI0R

Sorry about late reply, thanks for all your replies. I don't know how i did it but i got it to stop. Thanks again for putting your voice in and helping me understand a little bit more :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×