Jump to content
Draftsman_Dave

ACVMTOOLS.ARX is an invalid .arx file

Recommended Posts

Draftsman_Dave

Ola, I was trying to make a 3d object, and while I was making it, I noticed that the 3DORBIT is gone, and when I entered this command, it said that "ACVMTOOLS.ARX is an invalid .arx file" I'm using AutoCAD 2014 btw. Ty!

Share this post


Link to post
Share on other sites
SLW210

What graphics card do you have? Computer specifications and OS?

 

You may try a repair or reinstall of AutoCAD or if another computer is available with AutoCAD 2014, you might replace the ACVMTOOLS.ARX with a known good version.

Share this post


Link to post
Share on other sites
ReMark

Perhaps the file became corrupted. Note that a Repair is NOT the same as a full uninstall / reinstall. That should always be considered as an option of last resort.

 

I ran a search of my system and found two such files. One has a date of 2014 while the other is dated 2017.

Share this post


Link to post
Share on other sites
Draftsman_Dave

Intel® HD Graphics, Windows 7 Home Premium 64-bit and Intel Core i3.... I think I should just replace ACVMTOOLS.ARX, since there is no another computer that is available here and I'm far from my house (where the installer is :/ )...

Share this post


Link to post
Share on other sites
Draftsman_Dave

So, I should create another object? and try again if 3DORBIT is working?

Share this post


Link to post
Share on other sites
ReMark

Worth checking. I'd start a new drawing for the purposes of testing.

 

Just to verify...your computer is using an onboard graphics chip and not a dedicated graphics card. Correct?

 

What other programs are running in the background?

Share this post


Link to post
Share on other sites
Draftsman_Dave

Okay, would now try to do it. Yup, no graphics card at all. (lol) Just Rocketdock. :D

Share this post


Link to post
Share on other sites
ReMark

Sometimes the demands of a 3D drawing can overwhelm the capabilities of an onboard graphics chip. Maybe an upgrade is in your future?

Share this post


Link to post
Share on other sites
Draftsman_Dave

d:\program files (x86)\autocad\autocad 2014\acvmtools.crx is an invalid ARX file.

Unknown command "3DO". Press F1 for help.

Command: 3DO

d:\program files (x86)\autocad\autocad 2014\acvmtools.crx is an invalid ARX file.

Unknown command "3DO". Press F1 for help.

Command: *Cancel*

Command: 3DFORBIT

d:\program files (x86)\autocad\autocad 2014\acvmtools.crx is an invalid ARX file.

d:\program files (x86)\autocad\autocad 2014\acvmtools.crx is an invalid ARX file.

Unknown command "3DFORBIT". Press F1 for help.

Command: 3DO

d:\program files (x86)\autocad\autocad 2014\acvmtools.crx is an invalid ARX file.

Unknown command "3DO". Press F1 for help.

 

 

Here's a copy of the log. But I used this same version for few months already, using my system, and with 3DOBIT :/

Yup, maybe I'll get an upgrade, but can't you provide me a copy of acvmtools.crx file? I think it's just corrupted or something :/

Share this post


Link to post
Share on other sites
ReMark

Run the REPAIR option. In some cases you do not need to have the installation disk to do so. If you are prompted for it then have the disk on hand and ready to go. A Repair takes no more than 5 minutes to run.

Share this post


Link to post
Share on other sites
Draftsman_Dave

Okay will do, bro! I'll update you right away if anything happens!

Share this post


Link to post
Share on other sites
SLW210

Make sure you have the latest updates for AutoCAD and the latest drivers for the graphics card.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×