Jump to content
lamensterms

Frame Around MTEXT During Edit

Recommended Posts

lamensterms

Hey guys,

 

In the MTEXT editor... what is the option to control the display of the frame around the text?  I am not trying to draw a frame around text, or create a background mask.. I am only interested in the frame around the MTEXT while in the MTEXT editor.

 

image.thumb.png.a3b45da08498e3da3d239ae0c1f0ef0f.png

 

Thanks for any help.

Share this post


Link to post
Share on other sites
SLW210

Stretch with the mouse or Right-Click and choose and set MTEXT Width.235725259_MTXTWidth.png.fc0294b815ae2fa6e20e9be4691e81fb.png

Share this post


Link to post
Share on other sites
CyberAngel

Do you want to turn off the frame? Change the margins? Make it a different color?

Share this post


Link to post
Share on other sites
lamensterms

Thanks for the replies guys.

 

@CyberAngel I would like to be able to toggle the display of the frame.  I have it enabled in ACAD2014, and would like to enable it in ACAD2015.

 

@SLW210 you are correct that assigning a width to the MTEXT will enable the frame, but in ACAD2014 it is possible to display the frame when MTEXT has zero 'defined width' (that what the screenshot shows).

 

Any other options?

Share this post


Link to post
Share on other sites
CyberAngel

Still looking, but I came across a couple of system variables I'd never heard of, this might help. MTEXTED started with version 2015, so it coincides with your issue.

 

MTEXTED controls the type of multitext editor. Value 'oldeditor' gives you the pre-2015 version, while value 'internal' gives you the new one. And the usual gotcha, the value '.' leaves you with no editor at all.

 

MTEXTFIXED controls multitext appearance in the editor. With value 2, if the text is too small to read or rotated, AutoCAD may (based on its own criteria) change the size and/or rotation to make it legible. With value 0 or 1 the text's appearance is not changed.

Edited by CyberAngel

Share this post


Link to post
Share on other sites
lamensterms

Thanks for the reply and suggestions CyberAngel.

 

Unfortunately neither of those system variables are able to restore this border around the MTEXT during edit.  Using 'oldeditor' presents the MTEXT in a little pop-up style window, and the text is strangly illegible for some reason (kind of grey and smeared - looks like monitor resolution issue).

 

Thanks again for your efforts

Share this post


Link to post
Share on other sites
CyberAngel

Wait, the problem is you don't have the frame? Could the frame color be the same as the background?

Edited by CyberAngel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×