Jump to content

Civil 3d 2019 Command Window Will Not Stay Docked!


Recommended Posts

Ever since installing the 2019 version of Civil 3D, my command window will not stay docked. I am asking for help at this point because I do not know what else to do and have scoured the web in search of answers and have tried just about everything I can think of. Before all the usual suggestions come pouring in, here's what I have tried so far:


(1) I changed STARTUP to 0 and docked the command window. This did nothing.

(2) Next I locked everything. LOCKUI setting was changed to 15 which is supposed to lock toolbar, panels, floating toolbars and windows in place. No effect on my command window which is undocked every time I open AutoCAD

(3) I made sure to automatically save my workspace settings (WSSETTINGS). No change.

(4) Then I changed WSAUTOSAVE to 1. I docked the command window. The opened CUI, found my workspace --> opened Palettes --> Opened Command Line --> and set the properties of the command window Orientation to "Do not change", of the Allow Docking to "Do not change". Not only did this not work, but the CUI settings reset.


What else can i do?




Link to comment
Share on other sites

I don't use Civil 3D and I have never encountered this issue in Autocad, so it's a little difficult to diagnose the problem, but I did some searching and found some Autodesk articles. Maybe something in one of these links will help.


AutoCAD does not retain changes to workspace or settings upon relaunch
Default profile loads in AutoCAD instead of a custom one

Link to comment
Share on other sites

I never have the workspace set to auto save, to dangerous to screw up, I force a save using the please confirm.


Like Cad64 check your startup icon settings, right click, properties, startup should have something like /p "<<C3D_Imperial>>"


When you drag the command line to bottom left does it "Snap" you can drag the number of rows up as a test, you can place it at the bottom but its not docked.

Link to comment
Share on other sites

So my profile  "<<C3D_Imperial>>"  was set up correctly.


Cad64, I looked at the sequence of fixes from your link and was able to do a few of them, but I refrained from messing with HKEY_CURRENT_USER  and the  HKEY_LOCAL_MACHINE -- too much things could wrong with that operation!


In the end here's what worked though: I got rid of my custom workspace and switched back to the default Civil 3D workspace. This seems to have done the trick -- whew!


Thanks Cad64 and BIGAL -- I appreciate your help immensely!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...