Jump to content
Doove

Can't loft: selected entities not valid

Recommended Posts

shift1313

it probably has to do with the geometry. Have you tried using SLICE? how about creating the other sides as surfaces and then trying to convert it to a solid?

Share this post


Link to post
Share on other sites
Doove

Thanks to everyone for their advice, I can honestly say it was ALL very helpful.

 

Managed a new record yesterday of over 25 CTDs.

 

So, steps to create solid of terrain from 3D polyline contours:

1. Convert 3D polys to 2D polys.

2. Draw a 3D Polyline perimeter

3. Copy this perimeter, explode it, send all lines to z = 0 (or whatever), and join them up as a closed 2D polyline.

4. Offset 3D polyline perimeter by a good distance (I used 5000mm)

5. Extend contours to new offset perimeter line.

6. Loft a surface using contours.

7. Extrude a solid from 2D poyline at z=0 through and beyond the surface.

8. Slice solid using surface (you need to select the surface option during slice command.

9. Trim / delete contours and polys as desired.

10. Bingo!!!!

 

NOTES:

step 5 : extending the contours, this avoids face:body errors during slice.

step 7 : my highest elev was 24500 so I extruded from z=0 to z=30000, also to avoid slice errors.

 

IMPORTANT:

see this link for reducing 3D file size http://discussion.autodesk.com/forums/message.jspa?messageID=6165506

 

ALSO I used drawing setup manager to scale from mm to m (ie. scale by 0.001) in order to slice. When I tried to slice in mm scale the software would freeze / CTD. When I tried to scale with scale command the software would freeze / CTD.

After I had sliced I could again use drawing setup manager to go back to mm units.

 

I assume 2010 would be far better at this, also that it may be easier to ask surveyor to supply a solid terrain model perhaps Landscape or Civil 3D could do this easily.

 

Again, thanks to everyone particularly shift1313.

 

Final Image (all I have to do now is add buildings, roads, pipework, plant and materials for render!):

(anyone know how to get rid of those grey lines with the visual style?)

3D - LANDSCAPE - 4_solid pre-buildings.jpg

Share this post


Link to post
Share on other sites
shift1313

Congrats Doove! My guess is the grey lines are a surface that is still there. DELOBJ command sets the object delete function. My guess is when you sliced your extruded solid with the surface that the surface is still there on top of the solid it. If perhaps they are no different layers(and you want to keep that surface) just turn it off, or change it to another layer and turn it off.

 

Sorry I didnt specify the commands on SLICE. Glad you figured it out.

Share this post


Link to post
Share on other sites
Doove

Nah, deleted the surface - it was over 9MB worth of object! The grey are surely soemthing to do with visual style setting, they don't show up if I render. I'm not really bothered, it's probably some complicated graphics thing and is not superimportant as I can render images. I'm so happy it finally worked that a little grey in me ground ain't a worry!

Share this post


Link to post
Share on other sites
shift1313

haha, well thats good. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...