Jump to content
pvd

How to let Autocad use more RAM?

Recommended Posts

pvd

Hi all,

 

My computer has 8 GB of RAM. However my autocad is not faster than a computer with 2 GB of RAM. I have Windows 7. Is there a way I can allocate more RAM to Autocad to make it run faster?

 

Thank you

Share this post


Link to post
Share on other sites
khama

Are you running 32-bit or 64-bit Windows 7? If 32-bit version you will be limited to the ram it can use. If you have 64-bit, then I am stumped. It should use all of your ram.

  • Like 1

Share this post


Link to post
Share on other sites
ReMark

AutoCAD will only use what it needs; you can't force it to use more or less RAM.

 

Do you have hardware acceleration enabled or disabled?

 

Are you working with 2D, 3D or a combination of drawings? What is a typical file size?

 

Additionally you can optimize various aspects of your computers performance though which is an entirely different subject.

 

Have you benchmarked your computer?

Share this post


Link to post
Share on other sites
pvd

I'm using 64-bit. When I look in my Task Manager it says Acad is only using 657.128 K. Especially when i'm having a layout with lots of viewports, zooming for example doesn't go fluid at all! (or is this a graphical card-issue? I have ATI FirePro V4800 (FireGL))

 

Apart from Autocad I also use Inventor for the 3D part.

 

My hardware acceleration was turned off. I turned it on now. File size is about 5 Mb. I have no idea about benchmarks so I suppose I have to answer no to that question Remark (:oops:).

Share this post


Link to post
Share on other sites
ReMark

There is software available to benchmark a computer. Once you have the results you can compare them to similar configurations. You could also benchmark your two computers and see what the difference is between them. This may help you troubleshoot the problem. Do you have the full specs for each computer?

 

You failed to answer some of my other questions. Without complete answers to questions we put to you we can only make guesses. At this rate it would take an inordinate amount of time to pinpoint the problem.

 

A Dell T3500? I'll have to check but I think one of our engineers has the same model (I'm sure the configuration is somewhat different). I'll have to ask him how he rates his computer's performance.

 

Have you tried disabling the InfoCenter?

 

Do you have a bloated scalelist?

 

Do you use layer filters?

 

Are you making use of xrefs?

Share this post


Link to post
Share on other sites
pvd

thanks Remark, I'll respond later. As I'm not an expert on all this I will have to look for some things. i'll first try to do the benchmark thing....

 

In autocad i only work 2D, I work with several files at the time and we use quite some x-refs.

 

I have disabled the Infocenter. (I once did it with a program I found on this site)

I keep my scalelist as clean as possible, think I'm usually not having more than 6 in my list. And I only have a few layerfilters too. I do have a lot of layers though as I'm not in control of that....

 

But then still....I would think this is all piece of cake for 8 Gb of RAM?? I was hoping for some setting where i can tell Autocad to use at least 6 of them...I have to say, I'm a dreamer from time to time....

Share this post


Link to post
Share on other sites
ReMark

You're looking for a "miracle' button and I'm afraid I am the bearer of bad news. There isn't one. But don't give up hope. There are a couple of lists floating about this site that address slow performance of AutoCAD and things one can do to speed things up. A search should turn up one or both lists. Also check out the Similar Threads listed below.

  • Like 1

Share this post


Link to post
Share on other sites
ReMark

Suggestions for speeding up AutoCAD and Windows 7. Disclaimer: I am not the author of either of these documents nor have I tested each suggestion. Your mileage may vary.

 

Speed AutoCAD up.doc

 

Speed up Windows 7.doc

Share this post


Link to post
Share on other sites
BIGAL

I just had a play with a proposed 64bit box for us and loaded a 42Mb dwg whilst its hard to see speed some things were obvious we had a lot of images and around 20+ layouts, swapping layouts on 32bit was have a coffee in between, 64bit 1-2 seconds and panning zooming became real time no lag. Obvious improvemnts. I did not check memeory use but when I looked it was maybe 2-3 gb for a normal dwg. Overall 64 bit was way better.

 

Check your garphics card this can be a killer of performance.

Share this post


Link to post
Share on other sites
oddbob

Do you have autoCAD 64bit as well as Windows 64bit?

Share this post


Link to post
Share on other sites
ReMark

The OP is using Win7 64-bit. He does not state what AutoCAD LT is.

Share this post


Link to post
Share on other sites
LMTORRES

 

Hello, I also have questions about it. Please how can I increase the use of RAM in autocad 2019? For example, with a topographic plan, is it possible that the autocad, use more RAM as cache, to improve performance when processing lines that have between 50,000 and 100,000 points in between?

Share this post


Link to post
Share on other sites
Handiman

There is a setting that allows you to control the amount of your ram use.

But you will need to read up on it and make the correct setting.

Look up - Page File

There are many things that effect the way the cpu and motherboard and memory work, there isn't a switch to flip to make it perfect.

Good Luck

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...