Jump to content

migration toolbars from ACAD 21007 to ACAD 2014


Recommended Posts

ReMark

nestly has made you an offer. I suggest you take him up on it.

 

BTW...you export FROM 2007 and INTO 2014 and NOT the other way around.

Link to post
Share on other sites
  • Replies 38
  • Created
  • Last Reply

Top Posters In This Topic

  • alninek

    17

  • ReMark

    11

  • nestly

    11

Top Posters In This Topic

Posted Images

alninek
nestly has made you an offer. I suggest you take him up on it.

 

BTW...you export FROM 2007 and INTO 2014 and NOT the other way around.

 

ohh...damn... yes thank you! :-P

 

 

I'm not familiar with XMX filetype... it appears to be a compiled file.

If this is truly a matter of accessibility, and not preference, I suggest you contact Autodesk directly. Otherwise, I'll be happy to show you how to manually export your buttons from 2007 and import them into a custom 2011 cui, if you're interested in that solution of course

 

sorry...before i havent seen your answer

thank you for your offer... if you have patient to teach me...

i will be your ''young padawan'' :-)

Link to post
Share on other sites

I need to leave the office for a couple of hours, do you know how to export (save_as) the bmp's from 2007 into a location where you can find them later? If so, go ahead and start exporting them.

Link to post
Share on other sites
alninek
I need to leave the office for a couple of hours, do you know how to export (save_as) the bmp's from 2007 into a location where you can find them later? If so, go ahead and start exporting them.

 

 

i ve already start to do this... :-)

i ll wait you be back.. :-)

Link to post
Share on other sites

Well, my day didn't turn out as expected....

 

Here's a video showing how to create you own "partial" cui file, how to transfer the existing toolbars into your cui, how to replace the default icons with the toolbar icons you export from a previous version, and finally how to turn off the default toolbars and use only your toolbars.

 

The demo also shows the problem with the background color when using the old icons on the new toolbars. You may be able to find a graphics program that will automatically change the background color, but I've always just done it manually. I suggest you try a few, and see if it's really worth all the work of replacing all the icons, or just a select few.

 

 

What potentially makes this worth while is that once you have the toolbars set up inside your custom cui, it's very easy to re-use it in other computers, or in other versions. I'm using the same custom toolbars I created in 2011 for 2012, 2013, and 2014.

Link to post
Share on other sites
alninek

really thanks for your video...

video is fantastic!!!

 

i'll see it and than i'll try to apply your infos...

 

thanks!!!!!:D

Link to post
Share on other sites

Windows7

 

Use the Snipping Tools from the Windows Start menu, save your "snip" as a .jpg.

-or-

Press PrtScr button on your keyboard, then paste into MS Paint. Crop/Trim as needed then save.

 

In the forum reply window, click the picture icon and insert your "snip"

 

insert.jpg

Link to post
Share on other sites
alninek
Windows7

 

Use the Snipping Tools from the Windows Start menu, save your "snip" as a .jpg.

-or-

Press PrtScr button on your keyboard, then paste into MS Paint. Crop/Trim as needed then save.

 

In the forum reply window, click the picture icon and insert your "snip"

 

[ATTACH=CONFIG]42842[/ATTACH]

 

 

tnx... i knew how to do a screenshot.. :-P

 

forum said to me please insert an URL image...

 

i think i should use a service like imageshack shouldnt'i???????

Link to post
Share on other sites
sorry.. i havent that option in my menu...

maybe because i m young registered user in forum.....

 

I'm pretty certain you have the "Insert Image" button.

Browser security settings (specifically blocking JavaScript) will prevent the user from being able to open the "Select Files" window. Have you increased your security settings to block javascript?

Link to post
Share on other sites
I'm pretty certain you have the "Insert Image" button.

Browser security settings (specifically blocking JavaScript) will prevent the user from being able to open the "Select Files" window. Have you increased your security settings to block javascript?

 

 

thanks for patient...so...

i ve insert image without other flag

 

my java script option are enabled (i m using chrome)

 

however it doesnt matter... i ll post it in imageshack....

 

 

here it is

 

w0gn.jpg

Link to post
Share on other sites

It looks like you've duplicated at least one toolbar and have replaced several icons... Good!

 

It's good to see you don't have the background color issue. I went from 2005 to 2011, so Autodesk must have changed them in 2006 or 2007.

Link to post
Share on other sites

I think so...

however i was wondering:

 

how i can delete a customization file from CUI?

 

i tried to do some cuiix files... and actually there is a bit of confusion in my workspace... i have for example two DRAW toolbars

i think one is from 2007toolbars.cuix as in your fantastic video.. other... i dont kno (i switched all MAIN customization toolbars off as you suggested...)

 

o:)

 

edit:

 

i noted

 

if i modify a toolbar... after i applied my modification my workspace change and ALL toolbars are showed... is this correct??

Why it hasnt showed my configuration of toolbars i set before changing icon images??

 

toolbar 1 ON

toolbar 2 ON

toolbar 3 OFF

toolbar 4 OFF

 

etc?

Edited by alninek
Link to post
Share on other sites

1) You can unload unneeded partial cuix files simply by right clicking on them.

 

CuiToolbars2.gif

 

 

 

 

 

2) You can see which toolbars are loaded in your workspace by selecting your workspace, then viewing the contents in the top right pane.

 

CuiToolbars1.gif

 

 

 

 

 

3) Turning Toolbars On/Off can be done without entering the CUI by right-clicking on the grey background near a toolbar

 

CuiToolbars3.gif

Link to post
Share on other sites

1) - 2) thank you... thisi was i wish to know! :-)

 

3) i knew this... and i made as you show me

but...

 

after i had set correct visualization of my custom toolbars (2007toolbars from a copy of main .cuix) i changed many icons of another toolbar...layers2... when i made apply all toolbars has been showed in my workspace

Link to post
Share on other sites

I've noticed that sometimes when editing toolbars in the CUI, some of the default toolbars turn themselves back on. I don't know why, but it does happen. I just turn them back off again and Save the Workspace.

 

Also, I should warn you that when you turn on a toolbar for one workspace, the toolbar is added to all workspaces. In other words, when you get done setting up your CLASSIC workspace/toolbars, If you switch to any of the Ribbon workspaces, there will be many toolbars that you either have to turn off, or reposition. I thought there was a setting to prevent toolbars from automatically being added to every workspace, but I can't find it now.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...