Jump to content
vasiqshair

Trouble drawing a simple rectangle

Recommended Posts

vasiqshair

Hi folks. What I am trying to do is something very basic: drawing a rectangle. But apparently autoCAD is acting up and wouldn't let me draw it. After clicking the rectangle button located at the top, I tried to draw a rectangle in the sketch area and this is what I got. Any input on the matter, other than restarting AutoCAD, would be appreciated.

 

Thanks

weirdRECT.jpg

Share this post


Link to post
Share on other sites
ReMark

What happens if you try to draw a rectangle using the Line command?

 

What happens if you try to draw a rectangle using th Polyline command?

 

Just curious.

Share this post


Link to post
Share on other sites
vasiqshair

Hey there, thanks for the quick response. If I use the line or polyline command to draw the rectangle, it works just fine. But I am just really curious why the rectangle command is acting weird. Besides I need to use the "fillet" feature of the rectangle. Have you ever come across something like this.

Share this post


Link to post
Share on other sites
ReMark

No I haven't.

 

Try again with the Rectangle command. When done press the F2 key to bring up the Text window. Find and copy command and your inputs; paste that info into your next post.

Share this post


Link to post
Share on other sites
nestly

I believe that's actually AutoCAD2014 (w/Hardware Acceleration is disabled)

 

I'm not sure what I'm looking at... did those wide florescent green lines appear when you tried to create a rectangle?

Share this post


Link to post
Share on other sites
vasiqshair

I wasn't sure I fully understood your last post, so I restarted Autocad. It works fine now.

Share this post


Link to post
Share on other sites
vasiqshair

nestly, yes.

Share this post


Link to post
Share on other sites
ReMark

I wanted to see what you were doing but now I guess it doesn't matter.

 

You do know you can see a history of your commands and inputs by calling up the Text window using the F2 key don't you?

Share this post


Link to post
Share on other sites
vasiqshair

I know now... :) well, what I am actually trying to do is draw this "exer" (see attach). I first drew a base rectangle of dimensions 120 * 42. it was too big to fit on the screen so I had to scale it down by .5. Next I extruded the rectangle using the 2D wireframe. The top and bottom rectangles after extrusion are scaled by the factor .5, but what about the distance between them. How do I scale that?

exer.jpg

Share this post


Link to post
Share on other sites
vasiqshair

Just so you can get an idea of what I am doing, here's a snapshot.

draft.jpg

Share this post


Link to post
Share on other sites
nestly

Don't scale anything up or down... you can fit the entire universe in Autocad. Double click the middle button, or use Zoom>Extents.

 

also... PRESSPULL :)

 

exer.gif

Share this post


Link to post
Share on other sites
PotGuy

Modelspace is infinitely big. Always draw at 1:1 in Modelspace. To view the thing you have drawn, double clicking middle mouse, or typing ze does the trick.

 

In Paperspace, I'd draw a rectangle that has the same width as the piece of paper you will be printing from. (In Britain, A4 = 210, 297mm/ A3 = 297, 420mm etc)

 

If you want assistance with setting up a view to the model give us a shout. :)

Share this post


Link to post
Share on other sites
ReMark
I know now... :) well, what I am actually trying to do is draw this "exer" (see attach). I first drew a base rectangle of dimensions 120 * 42. it was too big to fit on the screen so I had to scale it down by .5. Next I extruded the rectangle using the 2D wireframe. The top and bottom rectangles after extrusion are scaled by the factor .5, but what about the distance between them. How do I scale that?

Step back a minute. See the dimensions for the base (42x120)? Well that's the size you make it. You don't draw it as 42x120 then scale it down by 50% just so you can see it. Nor do you draw it 21x60 (half size). Draw everything in model space at FULL size. It doesn't matter if the object is the size of a paper clip or the size of a soccer stadium draw it FULL size. Use your Zoom command to view the object (ex. - Zoom > Extents or Zoom > All). Better yet, if the object is too large double click your mouse wheel and the object will fill up your entire screen.

 

Scale does not come into play until such time as you switch to a paper space layout and utilize at least one floating viewport. It is the viewport that gets a scale assigned to it.

Edited by ReMark

Share this post


Link to post
Share on other sites
ReMark

ThreeViewports.jpg

One 3D solid model in model space.

Three viewports (color: magenta) in a paper space layout.

Three different scales used. Left side: 1:1 scale. Right side top: 1:2 scale. Right side bottom: 1:4 scale.

Three different visual styles depicted. Left side: Realistic. Right side top: Conceptual. Right side bottom: Hidden.

But remember, back in model space there is only the ONE 3D solid model.

Paper size used: A3.

Edited by ReMark

Share this post


Link to post
Share on other sites
ReMark

vasiqshair: Did you finish your 3D model? Yes? Then how about posting an image. No? What seems to be the problem?

Share this post


Link to post
Share on other sites
feargt

on a side note, nestly what did you use to generate the above gif file and control the file size.

Share this post


Link to post
Share on other sites
ReMark

I guess vasiqshair gave up. Maybe he decided to study accounting.

Share this post


Link to post
Share on other sites
nestly
on a side note, nestly what did you use to generate the above gif file and control the file size.

 

Camtasia Studio > Limit Frames per Second

Share this post


Link to post
Share on other sites
feargt
Camtasia Studio > Limit Frames per Second

 

thanks for that

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...