Jump to content
Vagulus

What does "Radius of parameter" do?

Recommended Posts

Vagulus

I am attaching a rotate parameter and action to a dynamic block.

 

I get the "Specify base point" bit okay but I can't figure out what "Specify radius of parameter" does.:?

 

Do I have to include or exclude other parameters like Flip or Stretch?

I get some weird results when I rotate an object with other parameters.

 

Is it possible to place the Grip in a specific place?

It always seems to like to sit on top of another parameter name.

 

Thanks

Share this post


Link to post
Share on other sites
ReMark

Attach a copy of the drawing you are working on to your next post. A drawing is worth 1000 words.

 

BTW...a radial constraint parameter defines and controls the radius.

 

Look at this tutorial (you will have to scroll down to the Dynamic Block section).

 

http://www.we-r-here.com/cad/tutorials/level_2/2-2.htm

Edited by ReMark

Share this post


Link to post
Share on other sites
nestly

 

I get the "Specify base point" bit okay but I can't figure out what "Specify radius of parameter" does.:?

 

I have not found the "radius" to have any bearing on how the rotation action, or the dynamic block works.

 

Do I have to include or exclude other parameters like Flip or Stretch?

I get some weird results when I rotate an object with other parameters.

 

It depends on what you are trying to do, but there is something a little broken with 2011 and newer when including the FLIP Action in other action sets. 2010 worked properly. You can revert to the 2010 style dynamic block actions by changing BACTIONBARMODE=0 (it seems this is the setting preferred by some top Dynamic Block experts)

 

Is it possible to place the Grip in a specific place?

It always seems to like to sit on top of another parameter name.

In the block editor, just click the grip, then click it again to make it "hot" and move it the same way you'd grip edit any other object.

Share this post


Link to post
Share on other sites
Vagulus

Sadly, DWG files will not attach. I can browse for the file and click upload but nothing happens. The best I can do is:

Chaise Lounge Block Editor.jpg

This is the block (it's pretty simple but I am just experimenting). It has two flips and a stretch all of which work okay then I test them:

Chaise Lounge Test Block 1.jpg

But when I use the rotation, things go haywire:

Chaise Lounge Test Block 2.jpg

Stretch and flip give the strangest results.

 

I have reset that variable Nestly mentioned but no change.

Share this post


Link to post
Share on other sites
nestly

Create the Stretches first, then create the Flips and include EVERYTHING in the Flip Actions, lastly create the Rotation and include EVERYTHING in the Rotation Action.

 

Dynblock.gif

Share this post


Link to post
Share on other sites
Dana W
Sadly, DWG files will not attach. I can browse for the file and click upload but nothing happens.
You're using IE aren't you. I have the same problem with it. Switch to Google Chrome for seamless uploads. Also, make sure the drawing is within the size limitations on the forum.

Share this post


Link to post
Share on other sites
Vagulus
Create the Stretches first, then create the Flips and include EVERYTHING in the Flip Actions, lastly create the Rotation and include EVERYTHING in the Rotation Action.

 

Well, I did that but I still have problems.

Chaise Lounge Test Block 4.jpg

 

The base point of the original block does not move.

After rotation Stretch goes haywire.

 

My Block file is on a website.

 

I hope you can see from that where I am getting it wrong.

I hate bringing something like this up but I cannot find anything about it in texts or tutorials.

Thanks for your patience.

Share this post


Link to post
Share on other sites
Vagulus

Hi Dana

I did, I thought I did, send a query to the website powers that be asking about restrictions on file sizes and types.

I have no reply yet.

Can you clarify?

Thanks

Share this post


Link to post
Share on other sites
Dana W
Hi Dana

I did, I thought I did, send a query to the website powers that be asking about restrictions on file sizes and types.

I have no reply yet.

Can you clarify?

Thanks

Well, heck. I forgot where it is. The sizes are listed in the attachment manager somewhere, I do believe. I will go look. You are using the Go Advanced button, right?

 

Nope, not in the Attachment manager even though the FAQ's say it is. Somebody will tell us soon.

Share this post


Link to post
Share on other sites
welldriller

Can't remember the correct number but 500 or 5000 (yes a big difference there) but i have run into the problem when trying to upload to large a file. The good news -- it will tell you file to large and give you the largest file size that you can upload.

Share this post


Link to post
Share on other sites
nestly
Well, I did that but I still have problems.

 

Are you sure you included everything in the Rotation action? The only thing I did to your block was redo the Rotation selection.

 

DBlock.gif

Share this post


Link to post
Share on other sites
Dadgad
Well, heck. I forgot where it is. The sizes are listed in the attachment manager somewhere, I do believe. I will go look. You are using the Go Advanced button, right?

 

Nope, not in the Attachment manager even though the FAQ's say it is. Somebody will tell us soon.

 

Here are the file type attachment limits for upload to CADTutor.

CADTutor attachment limits.jpg

Share this post


Link to post
Share on other sites
Vagulus

And here is where I found it - right under my nose.

Manage Attachments.jpg

 

Why don't I stop and think why people make screen widgets with buttons with question marks on them?

I must be getting dafter in my old age:x!

 

Thanks Dana and Dadgad.

 

I am going to try uploading with Chrome. I'll let you know if that works.

Share this post


Link to post
Share on other sites
Vagulus
I am going to try uploading with Chrome. I'll let you know if that works.

 

Well, I just tried Chrome and I certainly got a different result.

It would seem the drawing is there.

 

Thanks to whoever suggested that.

Just one of MSIE's foibles, it would seem;).

Chaise Lounge.dwg

Share this post


Link to post
Share on other sites
Dadgad

I use Firefox and have never had any difficulty uploading to the site whatsoever. :)

Share this post


Link to post
Share on other sites
Vagulus
Are you sure you included everything in the Rotation action? The only thing I did to your block was redo the Rotation selection.

 

Well, I removed all the parameters and actions and re-inserted all of them. Everything worked fine until the Rotation. Then I still get strange results.

I uninstalled and re-installed Rotation this time typing in in all when asked to select objects. Same, same.

 

Distorted Stretch.jpg

 

Got madder and reinstalled AutoCAD 2014. Tried again. Same, same. :ouch:

 

The recycled drawing is attached if anyone's interested.

 

Note that the Flips haven't rotated.

Chaise_Lounge-Recycled.dwg

Share this post


Link to post
Share on other sites
nestly

Ok, lets go through the variables.

Are you using AutoCAD2014?

Did you use a crossing window to select EVERYTHING when you defined the Rotate action?

How many objects did the Crossing window find?

Did you save the block when you were done?

 

Edited by nestly

Share this post


Link to post
Share on other sites
Dana W
And here is where I found it - right under my nose.

[ATTACH=CONFIG]44036[/ATTACH]

 

Why don't I stop and think why people make screen widgets with buttons with question marks on them?

I must be getting dafter in my old age:x!

 

Thanks Dana and Dadgad.

 

I am going to try uploading with Chrome. I'll let you know if that works.

If I see irony in this, does that make me a Hipster? In the Help file? Whodathunkit. :shock:

Share this post


Link to post
Share on other sites
ReMark

Reinstalling AutoCAD because you could not figure out how the rotation parameter works sounds a bit extreme.

 

Did you test this parameter on a much simpler object to see if indeed it malfunctions or if it is OIE (Operator Induced Error)?

Share this post


Link to post
Share on other sites
Vagulus
Ok, lets go through the variables.

Are you using AutoCAD2014?

Did you use a crossing window to select EVERYTHING when you defined the Rotate action?

How many objects did the Crossing window find?

Did you save the block when you were done?

 

Yes, I am using AutoCAD 2014.

I have used a crossing window and the word all (at separate times).

In the insertion of the flip Top to Bottom (the first one in this attempt) I used all and got:

12 found 2 not in current space

The arrow doesn't move when I test it. I tried to select objects again using crossing window selection and got:

11 found

 

Then I tried to insert flip side to side (YouTube =>

)

 

 

 

That works okay but the top-to-bottom arrow still doesn't move, and the distortion is still there.

 

_Arrows don't shift.jpg

 

Attached rotate with select objects => all got:

18 found 2 not in current space.

 

I saved the block (click on save icon) at each attachment. The, after testing I get out of block editor and save changes at that prompt.

 

One other thing. When you reset action selection you right click (I presume) on the action and get a little menu with five selections. I don't get that. I have to go back through Recent Input => BACTIONTOOL

Edited by Vagulus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...