Jump to content

UCS troubles, please help!!! :)


Recommended Posts

ColinPearson

Hey folks, I've had problems with many drawings where (0,0,0) seems to be different depending on which plane you're working on. That is, if I pick the Top view or Left view or Front view, then start a polyline from (0,0,0), the starting point is not always the same point?!?

 

This is causing me plenty of trouble when I go to xref drawings of individual pieces of equipment into a larger model. I've attached a dwg that includes three magenta polylines that were all drawn from a starting point of (0,0,0) but on different planes to illustrate.

 

Does anyone know what I did to cause this or how I can fix it?

 

THANKS SO MUCH FOR YOUR HELP! IF I"M NEAR YOU AND YOU CAN HELP, I"LL OWE YA A BEER :)

Rx.dwg

Link to post
Share on other sites
  • Replies 47
  • Created
  • Last Reply

Top Posters In This Topic

  • ColinPearson

    23

  • ReMark

    15

  • steven-g

    4

  • tzframpton

    2

tzframpton

When using the Navigation Cube to change to different Orthogonal Views, the UCS doesn't change unless you have the UCSFOLLOW system variable set to 1. I, personally, do not like this setting turned on, so anytime you switch Views you then have to subsequently use the UCS command to realign the orientation of the drawing space. Like this:

 

Command: [color="red"][b]UCS[/b][/color]
Current ucs name:  *WORLD*
Specify origin of UCS or [Face/NAmed/OBject/Previous/View/World/X/Y/Z/ZAxis] <World>: [color="red"][b]V[/b][/color]
Command:

 

This will only realign the UCS for the View and not necessarily the best placement for the Object you're working on. Refer to the Help File to see what other UCS commands can further help you work in a 3D environment better.

 

Here is an older tutorial showing how I use the UCS command to work in a 3D environment I posted awhile back on this forum:

Unable to display content. Adobe Flash is required.

 

The principle of the tutorial isn't exactly for your needs, but still has merit to your situation. Hope this helps. :)

Link to post
Share on other sites
ColinPearson

Thanks for the reply. Unfortunately, I am unable to hear the audio on the tutorial.

 

However, that doesn't quite get to my question (I don't think)... I don't have trouble changing back and forth between various orientations of the UCS. For example, the shape in the video would be no problem for me to draw. My issue isn't that the UCS is changing, it's that the origin appears to be changing.

Link to post
Share on other sites
tzframpton

How are you realigning the UCS? This has an effect on the 0,0,0 origin. If all you're doing is reorienting to a View, then it'll stay in the same spot. If you use any other method, you could be changing the 0,0,0 placement without knowing.

 

Can you be more specific and possible give an example on how you're changing the UCS?

Link to post
Share on other sites
ColinPearson

For the three polylines I drew starting at 0,0,0 I only changed the View via the toolbar (which I assume to be equivalent to using the Navigation Cube). However, at various times I'll use 3 Point or algin the UCS to a face to change the orientation. Does this permanently affect the location of the UCS?

 

Even if these can permanently change the origin, I don't understand why it's moving based on the View. Since I already have this problem, do you know how I can reset the origin? Thanks for your help!

Link to post
Share on other sites
ColinPearson

I think the align to face or object or 3 point changes to the UCS probably do change the origin, and I would have no trouble moving it back to be in the proper relationship to other portions of the drawing, but the trouble is that merely changing the View moves the origin.

Link to post
Share on other sites
ColinPearson

Ok, that works. I know this must be something I'm doing unintentionally.... so how did you fix that thing? I've got a half dozen drawings that I need to fix the same way. And more importantly, what did I do wrong?

Link to post
Share on other sites

I have no idea what, if anything, you did differently. I copied and pasted your 3D objects plus most of your reference lines into a new drawing that I first intentionally set up with my so-called reference lines (layer: REF - locked).

Link to post
Share on other sites
ColinPearson

I'm about to head out to the refinery here for a bit so if I don't reply right back, don't think I'm ignoring. I definitely appreciate any help y'all might have, I'm kind of stuck right now.

Link to post
Share on other sites
ColinPearson

OK, so you just copied everything into a fresh dwg and the issue went away? I should have done that too I guess...

 

Not sure what I did but if I can make the problem go away then I can keep working. thanks!!!

Link to post
Share on other sites

I'll take another look at your original drawing and if I can discover what went wrong I will post back. If you don't hear back from me within the next 45 minutes then it means I failed to discern the problem.

 

Time now in Connecticut is 3:42PM.

 

Not sure if this has anything to do with it but the setting for UCSAXISANG in my drawing is 90 yet in your drawing it is 270.

 

UCSAXISANG Stores the default angle when rotating the UCS around one of its axes using the X, Y, or Z option of the UCS command.

Your drawing has a layer name 0 XREF Rx (color: white). What is the purpose of this layer?

Edited by ReMark
Link to post
Share on other sites
ColinPearson

ReMark, that layer was a line copied from the drawing that I need to xref all my equipment drawings into. I put each reference on a separate layer so I can turn the whole thing on/off quickly, the "0" keeps it all of them at the top of my Layer Manager.

 

Anyway, I was on that layer in my main model and drew a line from a reference point on the equipment (where it should have been) to 0,0,0 in the model. Then I copied this line into the equipment drawing so I could move all those objects to the correct position with respect to my main model's 0,0,0. Then I took selected everything and using the point that represented 0,0,0 in the main model I moved everything in the equipment drawing to 0,0,0. That way, I figured that when I xref'd into the model at 0,0,0 everything would line up correctly which it did not.

Link to post
Share on other sites

I've been going at your drawing since my last post and have yet to discern what is the matter. Better/sharper minds than mine will have to take a crack at it.

 

When I move equipment (condensers, distillation columns, etc.) between drawings I establish a basepoint right on the piece of equipment itself rather than specify a coordinate. I've never had a problem like the one your drawing is exhibiting. Maybe if it were earlier in the day and I was only on my fifth of ten cups of coffee my mind would be sharper but I've been on the computer since 5:20 a.m. and I am getting a little punchy. I'm calling it quits for the day. Maybe over the weekend I'll take another crack at it. I hope someone like nestly or rkent solves the problem in the meantime which will save me the joy of opening it again. LoL No offense meant. Good luck.

Link to post
Share on other sites
ColinPearson

ha! None taken, you've helped me out several times and I appreciate all attempts whether stuff gets solved or not. I began with only one piece of equipment and did have 0,0,0 as a centerline point at a reasonable location. Later I obtained a survey drawing so I wanted to move everything so 0,0,0 corresponded to the centerline of the same equipment, but at existing grade elevation.

 

Thanks again :)

Link to post
Share on other sites

I did give you one way to solve the problem which may or may not be suitable in regards to the other drawings you say you are also having a problem with.

 

Are you using any other programs besides AutoCAD?

Link to post
Share on other sites

I have acouple of small projects to finish up this afternoon but when I am done I'll give your original drawing one more look. I am kind of surprised noone else has responded.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...