Jump to content
resullins

2015 Publish Not Prompting for File Name

Recommended Posts

resullins

Ok, so I just upgraded to 2015 from 2012, and I'm having a problem with publishing.

 

I have always had a template file that holds all my page setups, I then import into publish.

 

So previously, my 42x30 PDF page setup would print to Adobe PDF (like it was a plotter). And when I published, it would prompt me for where I wanted to save the file. When I upgraded to 2015, using PDF as a plotter got weird, and I had to switch to the DWG to PDF function. now, when I publish (even though it IS set to "prompt for file name"), it saves the PDF to the last location I saved to, and uses the name of whatever file I happen to have open.

 

This is KILLING me. Any suggestions?

Share this post


Link to post
Share on other sites
resullins

I should also note that there seems to be a problem with 2015 recognizing Adobe at all...

Share this post


Link to post
Share on other sites
nestly

Selecting Publish to PDF?

 

2015 PUBLISH.jpg

Share this post


Link to post
Share on other sites
resullins

But will that override the settings in my page setup?

Share this post


Link to post
Share on other sites
Mike_Taylor
But will that override the settings in my page setup?

 

It doesn't, it essentially changes the plotter and matches a page size (or makes a custom page size if nothing matches).

 

To change location go to publish options and you can select a new location there.

Share this post


Link to post
Share on other sites
nestly
But will that override the settings in my page setup?

 

Nope... it will still use the settings for each layout

 

Publish to PDF.gif

Share this post


Link to post
Share on other sites
resullins

Well, but that's the thing, I shouldn't have to go to location and change it there. And then it will still give it a random name. It's supposed to be prompting me for the file name (and so by default, the location).

Share this post


Link to post
Share on other sites
steven-g

In the publish dialogue, click on publish options, which opens another dialogue, about the third row down - naming - set that to prompt for name.

Share this post


Link to post
Share on other sites
resullins

It's already set to prompt for name. That's the problem.

Share this post


Link to post
Share on other sites
nestly
Well, but that's the thing, I shouldn't have to go to location and change it there. And then it will still give it a random name. It's supposed to be prompting me for the file name (and so by default, the location).

 

Mine uses the Layout name(s) that are selected to plot.

 

I pick PDF from the "Plot to" options, remove any layouts I don't want to publish from the list, then click Publish and it prompts me for a file name.

Share this post


Link to post
Share on other sites
BlackBox

FWIW -

 

I've been using AUTOPUBLISH since Land Desktop 2009 (using IDSP 2014 now, and just installed IDSP 2015), and have never experienced any of these issues... With 3? one-time settings configured, a PDF is produced for each drawing at SAVE*, and I'm done. :thumbsup:

 

Admittedly, I also use an app to prevent unwanted PDFs from being produced when I save drawings that are used for XREF only, or other non-sheet drawings, so that doing so doesn't waste production time, resources, server storage, etc.... But still.

 

Cheers

Share this post


Link to post
Share on other sites
resullins

Well, I've been using the publish command FOREVER and never had a problem until 2015. And it's all because I can't get my page setups to rotate properly. My paper will be in portrait mode while my work is in landscape.... and no amount of fiddling has fixed this crap. That's why I had to go to the DWG to PDF in the first place... which is what's causing the issue. Grrr....

Share this post


Link to post
Share on other sites
Mike_Taylor
It's already set to prompt for name. That's the problem.

 

Are you publishing to multi-sheet or single sheet file?

 

I believe single sheet will publish file name - layout name by default regardless of whether it prompts you or not. Everything works fine for me as a multi-sheet file though.

Share this post


Link to post
Share on other sites
resullins

Multi-sheet file. Are you starting to see my confusion now?

Share this post


Link to post
Share on other sites
BlackBox
Well, I've been using the publish command FOREVER and never had a problem until 2015.

 

I've just downloaded Infrastructure Design Suite Premium 2015 from subscription center, and installed AutoCAD 2015, Civil 3D 2015, etc... Let me get some work out of the way, and finish making Dell my b!tch (for unilaterally f@cking up my new $25K server infrastructure upgrade; ... Grrr), and then I can get back to this. o:)

 

Cheers

Share this post


Link to post
Share on other sites
steven-g

Can you post a drawing, in theory an empty drawing with a few sheets in it, providing it shows the same behaviour for you, just to make sure it's not an issue with some drawing based settings.

Share this post


Link to post
Share on other sites
steven-g

I use a different version than you are having problems with, hopefully someone with 2015 can try it out, and get the same problem you do (or not), just for the record it works fine here - but that was not the issue right ;)

Share this post


Link to post
Share on other sites
resullins

Right... it worked fine in 2012, then I upgraded to 2015 and started having problems.

Share this post


Link to post
Share on other sites
RobDraw

Since you've pretty much eliminated everything else, how about checking the advanced(custom) properties for your Adobe driver. Get there from the plot dialog box by selecting the plotter and then going to properties. Click on the "Device and Document Settings" tab, then select custom properties and click on the custom properties button. I don't have Adobe so you will have to find your way from there but look for the save settings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...