Jump to content
edoll

Multileader Styles - Right Attachment Attribute not Carrying Over when Applied in DWG

Recommended Posts

edoll

I am setting up some architectural Multileader Styles to pull into various drawings as needed from the Designcenter.

 

I have created 7 different scales of Multileaders and set their Text "Left and Right Attachments" to "Middle of top line". When I pull the styles into a drawing, the "Left Attachment" is true and is at the middle of the top line. However when I make a right attachment the multileader randomly decides to "Underline top line". I have thought of everything I can to try and fix it in the original file referenced from the designcenter...both attachments say "Middle of top line". I have overwrote the Styles in the file and saved things and closed down things and restarted things. lol I'm at a loss and so any help would be appreciated.

 

Along the same lines - for these multileader styles I am creating, how can I get rid of default text? I would like to be able to just click the multileader tool, place it in my drawing, and begin typing - but somehow I cannot get rid of the "Contents" - or - "Default Text" because AutoCAD asks me if I want to overwrite the default text when I place it - in which I would always like to overwrite it so i'd rather have no default text and just be able to type asap. lol

 

Thanks,

Share this post


Link to post
Share on other sites
nestly

If the drawing already contains a Mleader style with the same name, the existing style won't be overwritten.

 

I'm not sure about the attachment issue, but it may be related to above... could you upload a sample drawing.

 

The default text can be removed by clicking the ellipsis button [...] to the right of the "Default Text" on the MLeader Style manager Contents tab.

Share this post


Link to post
Share on other sites
BlackBox
If the drawing already contains a Mleader style with the same name, the existing style won't be overwritten.

 

1+ .... This was my first thought as well, given the OP's 'pulling in' the MLeader Styles.

Share this post


Link to post
Share on other sites
edoll

Okay, so I now have the Mleader styles working properly after renaming them and purging the old ones. This also solved the attachment issue. Thanks!

 

On another note, I should have explained the "default text thing a little more clearly. I have clicked the [...] and it takes me to my text line where, yes, I can delete the text but when I click out of the text to save it, the text just reappears...

 

Is it possible to have Mleader Styles with no text so you can just type a new text from scratch everytime?

Share this post


Link to post
Share on other sites
BlackBox

Okay, so I now have the Mleader styles working properly after renaming them and purging the old ones....

 

Glad you got it sorted. :beer:

 

If you rename things often (i.e., usually for 3rd party drawing, etc.), you might find my Right Click Rename app to be of use.

 

 

 

Is it possible to have Mleader Styles with no text so you can just type a new text from scratch everytime?

 

With the needed styles already in the drawing, I simply use the MLEADER Command which prompts for text when adding the MLeader to the drawing (no default text specified).

 

Cheers

Share this post


Link to post
Share on other sites
edoll

Thanks BlackBox. I would share a screen shot if i knew how, because I am still unable to remove the "content" (default text) of my Multileader style. I click the three dots and remove the text and click away - hoping it will remember that I don't want any "default text" and it just comes right back.

 

I use the MLEADER command just as you say, pick leader and landing locations, and then - instead of being able to type what I want - it asks if I want to overwrite the default text. I know this is probably redundant and annoying by now - but there has got to be a way to remove the default text so the MLEADER command performs as it does with ACAD's "Standard" Multileader style.

 

if you have an email address - i'd be happy to show you a screen shot i took.

 

Thanks,

Share this post


Link to post
Share on other sites
BlackBox

I would share a screen shot if i knew how....

 

That may be a minimum post count issue - if memory serves somewhere after 20 posts, you get some new forum features.

 

 

 

... I am still unable to remove the "content" (default text) of my Multileader style. I click the three dots and remove the text and click away - hoping it will remember that I don't want any "default text" and it just comes right back.

 

I use the MLEADER command just as you say, pick leader and landing locations, and then - instead of being able to type what I want - it asks if I want to overwrite the default text. I know this is probably redundant and annoying by now - but there has got to be a way to remove the default text so the MLEADER command performs as it does with ACAD's "Standard" Multileader style.

 

In the Multileader Style Manager dialog, select the target style and select Modify button. On the Content tab of the Modify Multileader Style dialog, select the Ellipse [...] button, which will launch the text edit window, select all text (i.e., Ctrl+A), hit the Delete button on your keyboard, then left mouse click in space (outside of the text edit window). You should now be returned to the Modify Multileader Style dialog, and the 'Default text' textbox should read 'Default Text' (which means no default text).

 

HTH

Share this post


Link to post
Share on other sites
edoll

Solid Gold BlackBox...solid gold! I'm good to go! I am obviously a beginner and will admit that I did not even think about trying the manager dialog box - thought I could get things done with the properties dialog box only.

 

Speaking of 20 minimum posts...

 

Thanks for hanging in there with me!

Share this post


Link to post
Share on other sites
BlackBox

Solid Gold BlackBox...solid gold! I'm good to go! I am obviously a beginner and will admit that I did not even think about trying the manager dialog box - thought I could get things done with the properties dialog box only.

 

No worries, edoll; we all start somewhere... You'll be helping others in no time. :thumbsup:

 

 

Speaking of 20 minimum posts...

 

Thanks for hanging in there with me!

 

Congrats on your 20th post! :beer:

Share this post


Link to post
Share on other sites
SLW210
That may be a minimum post count issue - if memory serves somewhere after 20 posts, you get some new forum features.

 

The only issue for new members (

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×