Jump to content

Search the Community

Showing results for tags 'tables'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Other Autodesk Products
    • Autodesk 3ds Max
    • Autodesk Revit
    • Autodesk Inventor
    • Autodesk Software General
  • Other CAD Products
    • BricsCAD
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 9 results

  1. (defun c:test(/ tab ent Obj pt tObj row col) (vl-load-com) (if (and (setq tab (car (entsel "\nSelect Table: "))) (eq "ACAD_TABLE" (cdr (assoc 0 (entget tab))))) (while (and (setq ent (car (entsel "\nSelect Object: "))) (vlax-property-available-p (setq Obj (vlax-ename->vla-object ent)) 'Area)) (while (progn (setq pt (getpoint "\nClick into Cell to place field: ")) (cond ((vl-consp pt) (if (eq :vlax-true (vla-hittest (setq tObj (vlax-ename->vla-object tab)) (vlax-3D-point pt) (vlax-3D-point (trans '(0 0 1) 0 1)) 'row 'col)) nil (princ "\n** No Cell Selected **"))) (t (princ "\n** No Point Selected **"))))) (vla-setText tObj row col (strcat "% (vl-princ-to-string (vla-get-Objectid Obj)) ">%).Area \\f \"%lu2%pr2%ps[, Sq m]\">%"))) (princ "\n** No Table Selected **")) (princ))
  2. Hi, I'm trying to import four cells from Excel that will be a small table. The four cells each contain a numerical value. I've read a bit about this and decided that the PASTESPEC command was most appropriate. I then select "paste link" and "AutoCAD entities". This works fine. The cells are imported and the values automatically update whenever the Excel file is changed. However, because of the formatting style of the Excel sheet, the four cells are not always the same size, have different borders, etc. With my first test import I modified each cell in AutoCAD (cell width, cell height, alignment, borders, margins, etc) so that it looked good. So far so good. When I import a second value once again the various cell properties are wrong. I want it to be formatted like my first test import but no amount of reading about this has yet revealed a way to do this. MATCHPROP doesn't seem to do anything! There are potentially a hundred or so of these four cell groups to import so modifying every cell, as I did with the first one, is definitely not on the cards. My question is in two parts: (1) Is there a way to quickly format new imports so that it looks exactly like my first test? (2) Is it possible to create a 2-row 2-column table in AutoCAD, define all the parameters that I want and lock them, and then copy and paste (or another method if necessary) my information from Excel? Many thanks, Chris
  3. Hi All, Not sure if this is the correct forum to post this in. But I'm having trouble with formatting a table a certain way. I am creating a table with a user input. User will input a footage as in 500 and it formats to 500'. Or a diameter in a separate column which will format 2 into 2". I did this by adding a suffix using additional formatting after choosing the data type "whole number." My problem en lies than even after i make the cells "format locked" it wipes away this formatting after i hit delete. Say I wanted to change a footage from 500 to 400. I hit delete then enter 400 and the formatting I did for the cell vanishes and it populates as 400 instead of 400'. Is there anyway to keep that formatting after I delete? Maybe a system variable? Thanks. I can upload an example file if more info is needed... thanks, rushmore edit: also i am using AutoCAD Map 3D 2014
  4. I was wondering if anyone can help with problem I have. I am using Autocad 2011 although I only use it to tidy my drawings prior to sending to my client, my proficiency is quite basic. I have been tasked with surveying a number of feeder pillars or cabinets with 5 points of data, pt 1 is the centre of the doors, the other 4 points are the corners of the cabinet always in the same order. These can be imported into Autocad as a series of points and then I have to join the dots, and draw the cabinet. I know a little about blocks and that I can create a block of my drawing and place it over the five points, and then I'm stuck as if I change the block once it changes it in all the other positions. After i have placed the block, I need to list the coordinates of the 5 points, this i do individually using the id command and copy and paste into a table. Is there anyway to speed this up? I have attached a sketch of what I'm after doing, there could be as many 20+ cabinets in a drawing. So any help is appreciated. Many thanks in advance. fp1 trial.dwg feeder pillar template.pdf
  5. Has anyone had this problem with selecting text? I use AutoCAD 2005, and I've made project logs which contain mtext for logging work I do each day, and tables for logging Revisions and prints and whatnot related to the project. I've noticed, especially since adding the tables to the log template, that sometimes I cannot select the mtext, but if I go to paperspace and doubleclick in a viewport, I can select it, and once I do that, and move the text and then move it back, I can go back to modelspace and select it just fine. Right now I have one particular project log dwg file that does this every time I open it, and if I save the drawing in modelspace, the next time I open it, I have the problem in modelspace, but if I save it in paperspace, it's the other way around and I can select it in modelspace. Does this have something to do with a bug in the tables? The problems seemed to have started once I implemented the tables. I've also noticed that when I layiso defpoints, I can't select anything on defpoints; I'm not sure if that's related or not. Thanks in advance, Matt
  6. Hi, Currently I am converting old type tables (text type) to real table using lisp. In this I have facing one issue, once converted to table, every time I must align the table like text height, test alignment, row height, margin and each column size (different size). I can see many experts over here. So kindly give me one solution. Thanks in advance.
  7. I'm pretty fluent with excel the thing is though, but I'm not as fluent as transferring into autocad. I've been working with Autocad on a regular basis now for about 6 months and am getting pretty fast with it but there are a couple of things with the tables that I haven't even been able to work with but would like to. FYI I have Autocad 2012. 1. First off is there anyway I can link my excel sheet to autocad and any changes I make it will automatically update the excel sheet in autocad? 2. We use blocks a lot as we do Fire Sprinkler and Fire alarm. When I use these blocks, instead of having to individually count each block on the drawing at the end when I'm tallying up the amount of heads, etc, is there a lisp program that will tally up each type of block on the drawing? For instance, if I have 200 sprinkler heads in the building, is there a way for me to link some type of counter to my table so it automatically updates the # of spinkler heads each time? 3. Is the tables to work with in Autocad far more troubling than just copying and pasting my excel file into Autocad? 4. I've changed my key Aliases, but I can't find how to change the F1 key? It is quite a bothersome as sometimes I hit it when I click esc, etc... I've figured how to change half the F keys but for some reason not F1 and a couple of the others. 5. Kind of like the same question with the counter but when we run our circuits, is there anyway to have a link of some what to account for the length of the circuit? 6. I've also tried creating my own line types but for whatever reason, I can not get the text that I'm putting in the line type to line up directly in the middle like I'm wanting. I would rather the drawing look nice than it to look sloppy. 7. Also whenever I edit my aliases for some reason if I open an old drawing it takes resets all my aliases is there anyway to correct that? I can't think of anymore off the top of my head at the moment, and I know these are kind of petty as they don't take to long to do but time is $ and anything that speeds up my work would help out tremondously. Thanks again!
  8. Hi all, I'm new to the site. I'm setting out attribute block on a plan and would like to extract the world coordinates of the insertion of the block in to a cad table in the same drawing. Please help, thanks AW
  9. leemckenzie

    Data Extraction Tables

    Hi I have a couple of questions regarding Data Extraction Tables. Firstly is there a way to link the data from a table in Autocad to a pre setup blank template in Excel that can calculate totals and inserts those totals onto another sheet. The other thing is when I do a Data Extraction Table I can only insert a totals footer for the count column and no other columns. (even when changing the column format settings to whole number or any other formats.) Is this normal or am I supposed to be able to have the totals appear for every column in my data table. I have searched the net for tutorials but can't quite seem to be able to get my head around it. Cheers
×