Jump to content
MikeP

Make it stop! autosaving in the middle of a command

Recommended Posts

MikeP

how can I prevent autosave from happening in the middle of a command. it is very frustrating and can potentially cause a crash (rarely though).

 

PLEASE DO NOT TELL ME TURN OFF AUTOSAVE. I like it on, want it on and my computer has no issue handling it and it rarely crashes during.

last time I posted this that was the only answer I got. So im trying again

Edited by MikeP

Share this post


Link to post
Share on other sites
Jack_O'neill

I don't think there is a way to do that. As I understand it, autosave operates on a timer and executes on that schedule regardless. It annoys me too, but it's saved my butt often enough to be worth the annoyance. I have mine set at 30 minute intervals, so twice an hour is the most it can interrupt me.

Share this post


Link to post
Share on other sites
MikeP
I don't think there is a way to do that. As I understand it' date=' autosave operates on a timer and executes on that schedule regardless. It annoys me too, but it's saved my butt often enough to be worth the annoyance. I have mine set at 30 minute intervals, so twice an hour is the most it can interrupt me.[/quote']

 

I mean there has to be a variable that forces it to wait after the command is complete.

 

but the weird thing i have mine set to 30 min also but for some reason it will autosave far more often than that. if I have multiple dwgs open maybe its autosaving for the other drawings and I think its doing the current one.....

Share this post


Link to post
Share on other sites
JD Mather

Turn off autosave.

Saving is your job.

Share this post


Link to post
Share on other sites
MikeP
Turn off autosave.

Saving is your job.

 

If I can punch you through the computer I would.

Why would I turn off a feature that can prevent loss of work?

Share this post


Link to post
Share on other sites
JD Mather
Why would I turn off a feature that can prevent loss of work?

 

uhhmmm, let's see

...it is very frustrating and can cause a crash.

 

http://www.cadtutor.net/forum/showthread.php?58907-How-to-prevent-autosave-from-saving-during-a-commmand&p=399263#post399263

 

If you save every so often then you only lose a few minutes of work (and recover might save that) rather than possibly corrupting a file. And avoid the frustration of autosave interruption as well.

 

Modern CAD programs don't even have an autosave (only a pop-up timer to warn when you haven't saved in a user-set period) because of the danger of corruption (among other reasons).

 

A search of various CAD forums might turn up a significant number of discussions that come to the same conclusion.

 

 

If I can punch you through the computer I would.

You can find me College Avenue Labs, Penn College, Williamsport, PA or at AU in Las Vegas.

Share this post


Link to post
Share on other sites
SLW210
If I can punch you through the computer I would.

Why would I turn off a feature that can prevent loss of work?

 

No need for talk like that. :nono:

 

TURN OFF AUTOSAVE if it is giving you problems. Learn to SAVE your drawing. :ouch:

Share this post


Link to post
Share on other sites
Jack_O'neill

The "for" and "against" autosave division is more deeply entrenched than that between Republicans and Democrats, and if you are on one side of that argument (doesn't matter which side) you might as well argue with a stump instead of the guy on the other side of the argument. You'll have more success. It's very simple....if you like it, use it. If you don't, don't worry about it. I use it, I also hit save every so often. No, I'm not going to change that so don't waste your breath. Nor will I waste mine trying to convince someone on the other side. Each can site facts and research to support their respective positions.

 

Ok...agree to disagree and argue about something more interesting.

Share this post


Link to post
Share on other sites
Squirltech
I use it' date=' I also hit save every so often. No, I'm not going to change that so don't waste your breath.[/quote']

 

+1................

Share this post


Link to post
Share on other sites
SLW210
The "for" and "against" autosave division is more deeply entrenched than that between Republicans and Democrats' date=' and if you are on one side of that argument (doesn't matter which side) you might as well argue with a stump instead of the guy on the other side of the argument. You'll have more success. It's very simple....if you like it, use it. If you don't, don't worry about it. I use it, I also hit save every so often. No, I'm not going to change that so don't waste your breath. Nor will I waste mine trying to convince someone on the other side. Each can site facts and research to support their respective positions.

 

Ok...agree to disagree and argue about something more interesting.[/quote']

 

What has that got to do with the original question?

 

Autosave is crashing when it activates during a command. The OP needs to live with it or turn it off, no debate or arguing necessary. There is NO OTHER SOLUTION in OOTB AutoCAD.

 

How many that absolutely must have Autosave to save their necks have actually tried running for a period of time without it? I have had it turned off since R14 and have never missed it. Whenever I have upgraded and forget to turn it off first thing, BAM, CRASH first time it activates during a command. If you crash, I believe since around AutoCAD 2008, you get a recover file. If you believe .BAK is needed, give your .BAK file a good look over. The .BAK is a copy of your previous SAVE, not the one you just did.

 

Leave Autosave on and keep .bak, but do not go around whining about Autosave crashing your drawings and then threatening violence when the ONLY SOLUTION is provided.

Share this post


Link to post
Share on other sites
DANIEL

turn it off and save save save!

 

if you go to your uptions you can turn it off under the open/save tab

Share this post


Link to post
Share on other sites
Jack_O'neill
What has that got to do with the original question?

 

 

It has as much to do with it as telling him to turn it off did. The original question was "how can I prevent autosave from happening in the middle of a command" without turning it off. He was looking for a variable to set that would delay it if a command was active. So far, I am the only one who has addressed the question. Instead, it turned into a "turn it off" rally with the obligatory "modern cad programs don't do that".

 

Granted, threats are unacceptable, but none of you even attempted to answer his question.

Share this post


Link to post
Share on other sites
JD Mather

I am curious.

For those who leave autosave on - what do you have set as your time?

Share this post


Link to post
Share on other sites
SuperCAD

Every five minutes. No crashes, no problems. If it starts to drag, I just wait a few seconds for it to stop and then continue on my path.

 

I also do Ctrl+S often. I can do a lot in five minutes, so Autosave and manual saves have "saved" my butt quite a few times.

Share this post


Link to post
Share on other sites
Jack_O'neill

As I said earlier, mine hits in 30 minute intervals. I also hit save quite frequently. The worst thing I've ever had happen is for it to interrupt the command, or if I forget to turn it off when running scripts it will make the script stop. I've never had a corrupted drawing, never had a system crash, or any of the other things that have been described caused by autosave. I rarely use scripts, and when I do it's to do something repetitive to large numbers of drawings. That is infrequent so not a real issue.

Share this post


Link to post
Share on other sites
JD Mather
... I've never had a corrupted drawing' date=' never had a system crash, or any of the other things that have been described caused by autosave....[/quote']

 

Actually not sure a cause/effect was stated that autosave causes system crash or file corruption - but a combination of events of which autosave was one event. If a cause/effect was stated somewhere in here - I think the problem is more complex than that. The topic has been discussed at some length on other forums and I notice SWx and Inventor simply have a reminder that pops up rather than taking control of your machine for a bit. I assume the programers know a bit more about this (problems with an autosave function) than I. In any case poll the past winners of the AUGI Top Dog (they know far more about AutoCAD than I will ever know or care to know) and see how many of them leave autosave on, especially with a short time limit of say less than 30 minutes.

 

In my particular use of the software - I have turned it off every release and don't recall ever being burnt by this.

Share this post


Link to post
Share on other sites
SLW210

His original question you answered in the first response. It was also answered in the first response the last time he asked. MAKE IT STOP

Share this post


Link to post
Share on other sites
MikeP

ok first off. i asked a question about how to prevent it from saving during a command. if your suggesting me to turn it off, then obviously you do not know how to read or just like wasting my time. I clearly said in my first post that i do not want to turn it off. (I revised it make it even more obvious) I like to have it on. It has saved my ass a number of times. I have a butt load of ram and a very good processor and video card and it rarely crashes. I only mentioned crashes because it does happen but not often enough to concern me. Im just annoyed that im in the middle of doing something and it locks up and starts to save. the fact that I save to a server further slows down the save process. if your computer isnt powerful enough to handle an autosave then by all means turn it off. but mine can handle it just fine. its just an annoyance to me.

 

obviously the answer is........ IT IS NOT POSSIBLE.

 

THREAD CLOSED

Share this post


Link to post
Share on other sites
rkent

Manually saving will reset the timer, so set the auto save time to 10 and hit qsave every 9 minutes or more often. I qsave often and especially before rendering, plotting, switching to another drawing. I never see the auto save but I still have it set just in case I forget that one time in three months to save often enough and the program crashes.

Share this post


Link to post
Share on other sites
SuperCAD
...just in case I forget that one time in three months to save often enough and the program crashes.

 

And that's the one time that AutoCAD will decide to screw you and not create a backup to recover.

 

I'm running a lisp routine that will check the autosave setting, and if at any time it detects that the interval is anything but 5 minutes, it will reset it to 5 minutes.

 

I don't care if it's autosave or a pop up or whatever. If it saves you from losing work, it's worth it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×