Jump to content
ssartor

Linetype scale in paper vs. model space

Recommended Posts

ssartor

Ok, so I have this drawing that I just finished. There were a few dotted lines that were showing up correctly in model space. Then, when I switched over to paper space all of those lines were solid. I messed around with the option LTSCALE and set it to 0.01. This made the lines show up correctly in paper space, but now they are all messed up in model space. Is there an option to make it so they show up exactly the same in both model and paper space?

 

Thanks

Share this post


Link to post
Share on other sites
resullins

Attach the file please... I'll take a look.

Share this post


Link to post
Share on other sites
resullins

When you're in your linetypes dialogue box, check your GLOBAL SCALE box... they should be set to 1. Then go back to your drawing and set all your individual lines to linetype scale 1. You've messed up your global settings somehow.

Share this post


Link to post
Share on other sites
eldon

Also when in Linetype Manager, uncheck the box for "Use paper space units for scaling"

Share this post


Link to post
Share on other sites
CyberAngel

Try setting MSLTSCALE and PSLTSCALE to 1.

Share this post


Link to post
Share on other sites
ssartor

Try setting MSLTSCALE and PSLTSCALE to 1.

 

Both are set to 1.

 

When you're in your linetypes dialogue box, check your GLOBAL SCALE box...

 

How do I get to the linetypes dialogue box?

 

Share this post


Link to post
Share on other sites
ScribbleJ

How do I get to the linetypes dialogue box?

 

Command: LINETYPE [or LT]

 

Then click the button Show Details (If 'Details' are already being displayed the Hide Details will be displayed).

 

Also:

 

Command: LTSCALE

Share this post


Link to post
Share on other sites
rkent

You set the phantom line to an object linetype scale of 14, change that to 1. Now the width of your diagram is in the 25' range so your cannoscale needs to be set to 3/8"=1' or something close to that if working in metric.

 

Set ltscale between .5 to 1, psltscale to 1.

 

In Paperspace, make the layout active and set the cannoscale to 3/8" or a close metric equivalent if working in metric.

 

Consider adding layers for things like the phantom line rather than setting it per object.

Share this post


Link to post
Share on other sites
ssartor
In Paperspace, make the layout active and set the cannoscale to 3/8" or a close metric equivalent if working in metric.

 

What exactly would I type in to make that change? It keeps saying input invalid whenever I try to change it to 3/8.

Share this post


Link to post
Share on other sites
ScribbleJ
What exactly would I type in to make that change? It keeps saying input invalid whenever I try to change it to 3/8.

 

That is determined by your viewport scale while in paper space. (Also your model space scale.)

 

It would be good for you to look up annotative text and annotative scales in the help file.

Share this post


Link to post
Share on other sites
rkent

Use the drop down cannoscale found at the lower right of the screen.

Edited by rkent
removed bad advice

Share this post


Link to post
Share on other sites
ssartor

Ok so I'm still having a bit of trouble getting this to work.

 

MSLTSCALE and PSLTSCALE are both set to 1.

My global LTSCALE is set to 0.4.

All my dotted lines have their own linetype scales set to 1.

The lines look fine on paper space, in model they are dashed but the lines are to close together so it almost looks solid.

 

CANNOSCALE doesn't seem to do anything, it just zooms my drawing out a little bit in paper space. Can someone explain what CANNOSCALE does exactly. Also, what exactly in my drawing is considered annotative. I didn't realize I had put any annotative stuff in to begin with.

 

Thanks for the help.

 

EDIT: Global LTSCALE is actually 0.4.

Share this post


Link to post
Share on other sites
ReMark

Annotative objects, like dimensions and text, can be identified simply by hovering your cursor next to them. If you see a small triangle icon (or icons), bluish/white in color, next to the object then it is annotative.

 

From your Help file.

 

CANNONSCALE

 

Sets the name of the current annotation scale for the current space.

Share this post


Link to post
Share on other sites
ssartor
Annotative objects, like dimensions and text, can be identified simply by hovering your cursor next to them. If you see a small triangle icon (or icons), bluish/white in color, next to the object then it is annotative.

I don't think anything in my drawing is annotative according to this. So if CANNONSCALE can't fix this what should I try next?

Share this post


Link to post
Share on other sites
ReMark

I have not had the opportunity to read the entire contents of this thread which means simply I am not up to speed on what the nature of the problem is that you are trying to solve nor what suggestions have been made to fix the problem. I would have to do some reading first before making any suggestions myself.

Share this post


Link to post
Share on other sites
ReMark

Some drawing you have there. I have an over-whelming urge to comment but I'll put that aside for the moment.

 

Have you printed the drawing yet? It appears you have set it up in paper space as an 11x17 drawing. The height of some of your text, in model space is set to 1.0 yet your viewport scale is 0.0355 which means your text is going to be really small. It is also going to affect the way your phantom, hidden and Acad_Iso lines will print as well.

 

What other lines are supposed to be dashed? With everything being the same color and on the same layer it is difficult to separate out various entities.

 

OK...i think I've narrowed down all instances of linetypes other than continuous. I noticed that on a couple of them when I checked their linetype scale using Properties it said "VARIES" which means you could have six lines, all the same linetype, yet have each of them displayed at a different linetype scale. That will drive just about anyone crazy trying to sort out. For the sake of my sanity I set the linetype scale of all non-continuous lines to 10 for the moment so I can find them easier. I also created a separate layer for each line type and put them on their own layer with color set to 'By Layer' as well.

Edited by ReMark

Share this post


Link to post
Share on other sites
rickh

I'll try to help sum up what others have mentioned if it helps at all......

--type "Linetype", pick show details, Global scale factor = 1, check 'use paperspace units for scaling'

--in Modelspace, select the linetypes and change their properties linetype scale to 1; change the cannoscale to 1:30 (based on your paperspace viewport).

--in Paperspace, change the viewport scale to 1:30. regen all.

 

You can change the 1:30 to whatever you need to plot at, but for the linetypes to look the same in both model and paperspace, you need the same scale selected in both and the psltscale set to 1 (psltscale is the 'use paperspace units for scaling' checkbox... 1 if checked). To be honest, Psltscale set to 1 and the cannoscale set to the same in model and paperspace is all you really need - the global scale and object property scales will then apply to both spaces...but starting with everything at 1 makes it easy to adjust.

 

Hope that helps.

 

Also, if you are unsure of any of the commands people are posting, type it and then press F1....a lot of info in there.

Share this post


Link to post
Share on other sites
ssartor

MOTOR_CIRCUIT_AND_DB_SUPPLY.dwg

Some drawing you have there. I have an over-whelming urge to comment but I'll put that aside for the moment.

 

 

 

Haha, feel free to comment, I'm still learning AutoCAD and I'm just a Mining Engineering intern copying some old electrical drawings for the electrical engineer here because he doesn't know how to use CAD. I'm not too familiar with the professional standards of a drawing and I lack the electrical version of CAD so I'm drawing all these intricate symbols the hard way.

 

 

Have you printed the drawing yet? It appears you have set it up in paper space as an 11x17 drawing. The height of some of your text, in model space is set to 1.0 yet your viewport scale is 0.0355 which means your text is going to be really small. It is also going to affect the way your phantom, hidden and Acad_Iso lines will print as well.

 

I've done some changes since I posted the file. I put all the dashed lines in their own layer, PHANTOM for the 1 phantom line, and HIDDEN for the 6 hidden lines. Also the lines look fine in paper space, they are how I want them to look, so the problem now is just making them look the same in model space. The updated file is attached.

Share this post


Link to post
Share on other sites
ReMark

I seldom worry what my lines look like in model space because invariably I have them on their own layers, in their own colors, and I print from a layout utilizing viewports. It's the "finished" product that concerns me the most.

 

Re: your drawing in general.

 

Try to make use of layers as much as possible. A good layering system, as part of any template, will save you a lot of time and headaches. I would also make better use of the color 'By Layer' option. It really helps when you know that all hidden lines are on their own layer and have a particular color assigned to them. It is visually easier to discern parts of your drawing. BTW...having different entities on different layers means you can turn layers On/Off or Freeze/Thaw them to make working in a "busy" drawing easier.

 

I would also suggest that if you are going to be doing a lot of electrical drawings that you create a symbol library and use the symbols religiously. It is so much easier to insert a symbol, move, rotate, copy, delete it this way then having to deal with a bunch of separate lines/circles.

 

I always lock my viewport display so that if I enter model space from within my layout I do not inadvertently change the viewport scale.

 

Finally, you have a drawing in model space that measures roughly 279 units wide and 424 units high. That is pretty big when you are going to shrink it down to fit on an 11x17. You may have to increase your text height, if you aren't going to use annotative text, and you'll have to pay attention to the size of your symbols too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×