Jump to content
bobsy852

Linetype scales, model vs paper space

Recommended Posts

bobsy852

I've had a problem with linetype scales for some time now and I can't seem to work it out, so I'm finally getting around to asking on here....

 

When I draw say a dashed line in the model space it sometimes looks broken exactly how I would expect it to look. Yet when I then set the drawing up in a viewport within the paper space it looks like a continuous line. It also plots as a continuous line.

 

The only way I have found of working around this is to change the linetype scale of the line in question (usually to around 0.012) this then usually gets the line to display dashed as expected on the paper space. It is very trial and error though with different lines requiring different scales?

 

I wondered if there is a setting so that they display in the model space exactly as they would display in the paper space or vice versa?

 

Thanks for the help.

Rob

Share this post


Link to post
Share on other sites
RobDraw

Set PSLTSCALE to 0.

Share this post


Link to post
Share on other sites
bobsy852

That helps a lot!! Thanks!! At least now my lines look the same in model space as they do in paper space.

 

I presume I'll always have to scale them up or down to get the right sized dashes etc?

Share this post


Link to post
Share on other sites
RobDraw

Not really. In general, the linetype scale of the lines should be set to 1. The LTSCALE for model space should be set to the scale factor of the drawing in paperspace. If you are working with multiple scales within the same file, you should look into annotative scaling.

 

If you need different lengths on dashed lines, a different linetype should be used. AutoCAD comes with multiple versions of dashed linetypes with different lengths of the dashes, i.e. HIDDEN, HIDDEN2, HIDDEN4.

Share this post


Link to post
Share on other sites
bobsy852

Thanks again Rob.

 

I use annotative scaling for my drawing text etc. And I understand the use of the different linetypes. But the LTSCALE factor I'm struggling with.

So if my drawing is due to be plotted at 1:100, then I should set the LTSCALE to 100?

 

Having just tried this above technique and quickly drawing a line in the "dashed" lintype, it came up as continuous. But changing the LTSCALE to 3 created a nice dashed line (in both paper and model spaces)

Share this post


Link to post
Share on other sites
rkent
Thanks again Rob.

 

I use annotative scaling for my drawing text etc. And I understand the use of the different linetypes. But the LTSCALE factor I'm struggling with.

So if my drawing is due to be plotted at 1:100, then I should set the LTSCALE to 100?

 

Having just tried this above technique and quickly drawing a line in the "dashed" lintype, it came up as continuous. But changing the LTSCALE to 3 created a nice dashed line (in both paper and model spaces)

 

This is what I use and it works as expected.

 

FOR 2008 AND UP

MSLTSCALE = 1

LTSCALE = 0.5 (some insist on using 1, others find .5 works best, experiment)

PSLTSCALE = 1

CANNOSCALE = (DESIRED PLOT SCALE, set with anno scale drop down

lower right)

Share this post


Link to post
Share on other sites
bobsy852
This is what I use and it works as expected.

 

FOR 2008 AND UP

MSLTSCALE = 1

LTSCALE = 0.5 (some insist on using 1, others find .5 works best, experiment)

PSLTSCALE = 1

CANNOSCALE = (DESIRED PLOT SCALE, set with anno scale drop down

lower right)

 

 

Thanks rkent!!! It seems it was the MSLTSCALE that needed correcting also! Works brilliant now!! Thanks to both of you for your help! :D

Share this post


Link to post
Share on other sites
RobDraw

rkent is correct. I use an LTSCALE of 1. AutoCAD changed the default to .5 some years back and it messed with all our linetype scaling. I think they have since changed back to 1. I think the change to .5 was their way of saying that their linetypes were originally designed wrong. Since day one, I've always used the ***2 versions which is half of the base versions. When they changed to .5 everything was just that, half the size it used to be.

 

I'm not saying don't mess with assigning different LTSCALEs but coming from a very collaborative environment and standards are important, it's not good practice. If none of AutoCADs linetypes work for you with an LTSCALE of 1 or .5, then make new ones. If you work in a place where everything is internal, do what you want but just know that there may be other more acceptable ways to accomplish the same thing.

Share this post


Link to post
Share on other sites
bobsy852

It seems I'm having trouble with this again. My main issue is with a layer that I need to appear as the BATTING Linetype to show insulation on my drawing.

 

 

The insulation needs to be drawn between a 50mm space, and to fill that space. The scenario changes a bit depending on the MSLTSCALE setting.

 

 

MSLTSCALE set to 0

With the linetype scale set to 1 it shows up within model space as the batting being thinner than 50mm wide. Within paper space it shows up as a straight continuous line with no width at all.

 

 

Set the linetype scale to fill the 50mm gap within the paper space viewport.

To fill the space I Have to set it at 0.045

I then go back into model space and Match Properties to all insulation lines from this line that now shows correct in paper space.

The lines now show as continuous lines in model space.

 

Seems to work for a while.

 

 

However, they then seem to randomly change scales again. The actual linetype scale doesn't change but the way they display in paper space does. For example, to test it I just regenerated the drawing. The lines now show as continuous in paper space, nowhere near filling the 50mm gap!

 

 

So next I try:

 

 

MSLTSCALE set to 1

 

Set the MSLTSCALE to 1 and regenerate the drawing.

The batting lines now show up as filling way more than the 50mm space in model space.

They still show as continuous in paper space.

 

 

If I regenerate the drawing again, nothing happens.

However as I tried to regenerate the issues ive been having, I flicked between model and paper space a few times. The lines now show as filling the 50mm gap perfectly again in paper space. But are a lot larger in model space.

 

 

Click into the viewport and regenerate the drawing and they show as continuous again!!

 

 

Flick back to model then back to paper space again. Showing as filling the space again!

 

 

 

 

It's driving me nuts!!!!

Can anyone help???

 

 

Sorry for the long winded-ness of this post.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×