Jump to content

Problem opening drawings! File Invalid?!?!


Recommended Posts

We are currently using Autocad 2014 and a couple stations using Autocad 2015. For some odd reason lately our drawings are being corrupted somehow. It is quite confusing.


Say we create a drawing at 8AM and save and print it. Later that day we want to open it to make a revision and when we double click to open the drawing, it doesnt want to open. Almost like the file doesnt exist. I run recovery and it says no errors detected but still doesnt open it. Tried using insert(says invalid), xref(says invalid), etc.. nothing.


THE ONLY THING THAT WORKS, is I have to logon to our Conference room computer that still has trusty ole AutoCAD 2002 installed and I am able to open it from there. However, the fun doesnt stop there. If I open and save the drawing from that station I am still unable to open from 2014/2015. I have to CTRL+A and copy everything into a "NEW" drawing then save that drawing over the existing one. Only then am I able to open this drawing.


Am I missing something? Is there anyone else out there experiencing this? Please chime in. Thanks

Link to comment
Share on other sites

Something is definitely wrong, if you can open it in 2002 without any errors. Later file formats are not compatible, or at least fully compatible, in 2002.


Are you saving your drawings as 2002 format? If so, that could be the problem.


Can you post a sample file exhibiting the behavior?

Link to comment
Share on other sites

It happens quite often, actually. It looks like older version is better ignoring corrupt file, but newer version is more sensitive. I found this since version 2011.

WBLOCK or copying the objects like you did seems to be the only fix.

Link to comment
Share on other sites

Newer versions are more sensitive because they can recognize the problem. It's most likely coming from a feature not available in 2002. WBlocking the drawing in 2002 is a work around, not a solution to the problem. Not being to open a file is not common at all. What if the OP did not have 2002? Recently I've only needed to WBlock an entire drawing maybe once a year.


Without a file exhibiting the behavior, we can only guess at what the error is. Please post a file.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...