Jump to content

Search the Community

Showing results for tags 'tool palette'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Other Autodesk Products
    • Autodesk 3ds Max
    • Autodesk Revit
    • Autodesk Inventor
    • Autodesk Software General
  • Other CAD Products
    • BricsCAD
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Categories

  • Programs and Scripts
  • 2D AutoCAD Blocks
  • 3D AutoCAD Blocks
  • Images
    • Backgrounds

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 19 results

  1. Good morning, I've created quite a number of tool palettes, including nine palette groups, and everything has been working great. Now, of a sudden, I can't drag and drop any type of entity into an new, empty palette. I can still load whatever I want into an existing one, but nothing into a new one. I've created the palette both through the palette itself and through the adcenter, but nothing works. Anyone have thoughts? Thanks, Tom
  2. Hello all, I made a tool palette for everyone at my work. This tool palette is shared so everyone can use it. Now, there are some people who want to make an own tool palette... The problem with this is, that when they make one, everybody sees this tool palette appear. How can they make a tool palette non-shared and still keep the shared TP? Thanks! -Martin
  3. dear experts, apologize if this question was already addressed, but I fail to find a solution. Is is possible to enable/disable programmatically (AutoLisp/.NET) a Tool of a given Palette . I mean, how can I set a given tool of a palette such that it is grayed out and inactive but still displayed? I would appreciate any hint or link to some recipe on how to implement this feature programmatically. Here is my configuration: - Windows 7 64 bits - AutoCAD 2015 SP2 - .NET framework 4.5/Visual Studio 2012 thanks for your valuable help.
  4. Good morning, I've created quite a number of tool palettes, including nine palette groups, and everything has been working great. Now, of a sudden, I can't drag and drop any type of entity into an new, empty palette. I can still load whatever I want into an existing one, but nothing into a new one. I've created the palette both through the palette itself and through the adcenter, but nothing works. Anyone have thoughts? Thanks, Tom
  5. sandiegophil

    tool palette prefix problem

    Hello and happy Friday! I have made the toolpalette group i want to send across the network. I have one issue with it though. Lets say my palette is named 'Happy Friday'. When it is put in place it is now named 'TOOL PALETTES - HAPPY FRIDAY'. Does anyone know how to make it display the way it's actually named? Thank you all, phil
  6. jernst2

    Tool Palettes help

    i am setting up are company for 2015 and have a issue on computer A tool palettes look and act correctly i left the ootb path and added a new custom path for the location of are tool palettes. i exported company profile, copied .atc files and install all on computer B computer B will show the palette Group but no palettes. and the file location is also shown correctly under options. any help would be great dont want to import 12 palettes on 30 machines..
  7. Hey everyone, I'm new here, at least as a poster. I've found tons of great info here on the forum, but not one that that quite deals with my issue. I'm the newly-elected CAD Customization Committee Head and I'm trying to get my Tool Palettes to work over our network. The palettes I've created over the past month work on my station but don't show up on the other users' stations. In a last ditch effort, I exported the problem palettes to my desktop (as .xtp files), then attempted to import them back to my tool palettes. I thought this would force AutoCAD to write .atc files that would actually work. It didn't. AutoCAD created the .atc files, they're in the proper folder on the network but they don't show up in anyone's Tool Palettes, except mine! I can exit and restart and the palettes are there. The other users on the network can not see them at all. So--out of our 5 custom palettes--the 3 created in September work, but the 2 created in October do not. Is there anything I can do to save my tool palettes? or do I need to start over? Also having that strange problem where when I create a new palette, ACAD won't let drop any tools on it. Maybe this has something to do with my problem. (Forum will not let me attach the atcs, else I would.)
  8. Dear CAD specialists, is there a way to read information from drawing (e.g. content of a specific text object, content/value of specific attribute or any other object that I can place in a layout) and then put that information in a command string? LISP is not in the range of solutions as: 1) I haven't had time to dig into it 2) I have quite a few LT users who also need to be able to use my solution Simple example of the problem I have an object with a value "5". I would like to draw a polyline with a width equal to that object's value ("5") using a Tool with a command string: ^C^C_PLINE;\width;[read object's value];[read object's value]; The real problem I have created PageSetups for different paper sizes for our plotter as well as for creating PDF and plt files. PageSetups include custom paper sizes. To simplify plotting I have created tools for each paper size with a command string e.g.: for plotter: ^C^Cpreview;-plot;N;;_A3_HP500;HP500_A3_A3.2_A3.1_A3.0.pc3;N;N; for pdf file: ^C^Cpreview;-plot;N;;_A3_DWG to PDF;CP_DWG To PDF.pc3;~;N;y; Explanation ^C^C: cancels all the previous commands preview: leads to print preview so the person can check if drawing is OK -plot: invokes plotting N: is the answer to question whether detailed plot configuration is necessary [empty]: uses default (actice) layout name for layout to be plotted _A3_HP500: is the name of PageSetup HP500_A3_A3.2_A3.1_A3.0.pc3: is the name of output device N: is the answer to question whether to write the plot to a file N; is the answer to question whether to save changes to PageSetup The last question which is answered manually is whether to proceed with plot What I would like to do is create a tool which reads the PageSetup name and output device name from something that I can define along with (or within) a layout. Each layout would contain 6 source objects/fields (plotter/pdf/plt x PageSetup/name of output device). This way I could use one tool for plotting, one for creating pdf file and one for creating plt file disregarding the current paper size The command string would look smt like: ^C^Cpreview;-plot;N;;[value from drawing A1];[value from drawing B1];N;N;
  9. Dear All, I am looking for a way to add justification to a newly created text palette. I have a mtext set to the correct layer, color and size and justification. I dragged it to the tool palette and everything works well except for the text justification. I have checked the properties on the palette but no solution here. Is there a way to add a system variable to Your help would be very valuable. Thanks.
  10. I keep doing the same commands over and over and I think i can use a macro to take some of the work out of my repetitive task. I pick "spline" and then type "near" (osnap), pick the first object then pick a spot in space then type "near" (osnap) and pick last object (end of routine). so would the macro look something like: ^C^C_spline;near;\\near;\; Thanks, Steve
  11. Do i need to create 2 styles, 1 with oblique of 30 and 1 with oblique of -30? Also can i put these on a tool palette? Thanks
  12. I'm just learning how to utilize recordable macros. I have a simple one that I found how to assign to a tool palette by simply changing the properties command string to "^C^CBottom" and "^C^CTop". These are the titles of the macros I created. The article I found explaining this said you can also assign a shortcut key using the aliaseditor but it does not recognize it as a valid command. Is there a way to either use the aliaseditor or the CUI to assign a shortcut for these recoded macros? Thanks, -Nobull
  13. I am going to be moving from 2002 to 2014 within the next 2 weeks and have been having trouble with my custom menu and lisp routines in 2002. I had my menu setup with custom toolbars with flyouts to select blocks to insert. Most of the blocks ran a LISP routine that did several things, the main thing was reading the crosshairs to determine if you were in a certain isoplane then it would select the proper block for that plane. I think I understand that maybe using a tool palette to select the blocks from might be a better way of inserting them now? I am not familiar with tool palettes, does anyone have advice on this subject? Thanks, Steve
  14. Hi all, I'd like to share a program I wrote to give me quick access to AutoCAD commands and their defininitions. It's a great learning tool and excellent for when you KNOW a command exists but just can't quite find it. It's got a quick search box and also allows you to run commands by double-clicking them. Best of all - it's free! :smileyhappy: You are welcome to download it from here: https://sites.google.com/site/wjasonhudson/my-projects
  15. Hello community! First post ever. I've been spending so much time trying to figure this one out that I kind of gave up. Now I need your help. I have 4 computers sharing tool palettes on a network. Whenever a user updates the palette with a new block, he has to export the .xtp file on the network and every other users has to reimport the palette in order to see the changes. We're in the middle of a big clean up since we just got our new Autocad 2011 license and the palettes change pretty much every day, whenever we find time to reorganize it. Is there a way to skip the export/import part when modifying a tool palette? I mean we are all using the file on the network right, so why doesn't it update on modification? At first I thought the palettes would update on startup, at least, but it seems that every single user has to export first and then import the .xtp file every morning or so. It feels like once the palette on the network has been imported, the modifications we apply on the said palette are local, as if autocad would copy the one on the network instead of running it live, which makes it harder to keep it synchronized on every machine. I'll stop my post here because I don't want to further confuse anyone. I hope the problem's clear. I hope there's a way to work around that export/import sequence and get this whole palette thing to work in sync. Thanks for reading this, any help is appreciated
  16. I am new to using Tool Palettes. I have created a folder on my C: drive which contains all my tool palettes. Right now, I get the symbol of a circle with a line drawn through it and cannot use my tool palettes. In the Options tab, I noticed that there are the "Tool Palettes File Locations" and also "Authoring Palette File Locations". What is the difference between the two? Do I need to do something to both so I can use my tool palettes without difficulty? I would really appreciate your help.
  17. r-key-tect

    create new wall assembly type

    I want to create wall types based on certain assembly types with the true rather than nominal block and brick dimensions, and add them to the wall tool palette. How do I do this? Also, the hatch for a CMU wall is a 45-degree double line. Drafting standard I am accustomed to is single line perpendicular to the wall direction. Can this be changed in the wall type?
  18. [Maybe this item is covered somewhere in the forum already, but to me it was impossible to find] Hello, Tool Palettes are useful to force certain drawing operations into specific colours, layers, line weights etc. Drawing in layer A, it can be used to draw a dimension in layer B without manual switching layers and AutoCAD will maintain using layer A. For some reason this does not comply with multiple operations like ^C^C_textsize;5;_mtext; Starting in Layer A it switches to Layer B but it will not return to Layer A again, unlike single operations. Does someone know why, a solution or a workaround? Thanks in advance!
  19. Hello community! First post ever. I've been spending so much time trying to figure this one out that I kind of gave up. Now I need your help. I have 4 computers sharing tool palettes on a network. Whenever a user updates the palette with a new block, he has to export the .xtp file on the network and every other users has to reimport the palette in order to see the changes. We're in the middle of a big clean up since we just got our new Autocad 2011 license and the palettes change pretty much every day, whenever we find time to reorganize it. Is there a way to skip the export/import part when modifying a tool palette? I mean we are all using the file on the network right, so why doesn't it update on modification? At first I thought the palettes would update on startup, at least, but it seems that every single user has to export first and then import the .xtp file every morning or so. It feels like once the palette on the network has been imported, the modifications we apply on the said palette are local, as if autocad would copy the one on the network instead of running it live, which makes it harder to keep it synchronized on every machine. I'll stop my post here because I don't want to further confuse anyone. I hope the problem's clear. I hope there's a way to work around that export/import sequence and get this whole palette thing to work in sync. Thanks for reading this, any help is appreciated
×
×
  • Create New...