Jump to content

Search the Community

Showing results for tags 'linetype'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Autodesk Revit
    • Revit General
    • Revit Architecture
    • Revit MEP
    • Revit Structure
  • Autodesk 3ds Max
    • 3D Modelling
    • UVW Mapping, Textures & Materials
    • Cameras, Lighting & Rendering
    • Rigging & Animation
    • 3ds Max General
    • Infrastructure, Architecture & Landscape Visualisation
  • Other Autodesk Products
    • Autodesk Software General
    • Autodesk Inventor
  • Digital Design
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Web Design
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Biography


Location


Interests


Occupation


Discipline


Discipline details


Main CAD Product


Current Product Version


First AutoCAD Version


Other Applications


Operating System


Computer


Monitor


Motherboard


CPU


RAM


Graphics


Primary Storage


Secondary Storage

Found 41 results

  1. Hey everyone, Our office is publishing large PDFs for submittals from DSD files and we are hitting a snag where one custom linetype I wrote 5 years ago that referenced a shp file is working 50/50. Half of our DSDs are publishing 100%, then the latter half are not loading the linetype. Also, if I have the CAD file open that this linetype is used in, the linetype is not loading anymore after the publish from the latter half of DSD. If I just publish a couple pages from the file itself, it is publishing 100%. So is there possibly some setting in one of the other files of the DSD that is throwing off the reference path to the shp? Any suggestions? Thanks for any help. Below are the codes of the lin and shp. lin: rail.lin *RUNNING_RAIL,Running Rail A,0,-.013889,[RAIL,Z:\CAD\Reference Files\rail,s=10],-.013889 shp: rail.shp *1,80,RAIL 4,125,4,80,3,79,3,7,3,105,3,128,002,9,(-1,-64),(0,0),001,9,(2,0),(0,0),002,9,(-2,6),(0,0),001,9,(2,0),(0,0),002,9,(-2,122) (0,0),001,9,(2,0),(0,0),002,9,(-2,-6),(0,0),001,9,(2,0),(0,0),002,9,(-1,-58),(0,0),001,4,128,4,105,4,7,4,79,3,80,3,125,0
  2. Where would (if there is a way) I change the default setting for linetype generation? Whenever I draw a polyline the setting is set to disabled. I would like for it to be enabled instead. Any help is always appreciated. Regards, Miller
  3. Hello all, real newbie here.. My first question is: AutoCad 2016 (student ver.) is there a possible way of selecting one line (property RED) and then have a command that could select all the lines in model space that have the color RED?? Could it be done with using any of: linetype/lineweight/line color ***IF WHILE IN MODEL SPACE EVERYTHING IS ONLY "LAYER 0"***....meaning I didnt use the layer properties what if the RED lines are a block? Can I SELECT one block and then USING a SELECTION TOOL it could select all the blocks?? NOW 18:53- I WILL BE HERE UNTIL TOMORROW NO LATER THEN 09:00 PLEASE HELP ME
  4. So i was drawing plans and decided to use the batting linetype for the insulation. i decided to stop for the day, saved the whole thing, then opened it the other day. When i opened it the batting was still there (all in the correct linetype scale) but after working in the file for a while the batting was gone and replaced by a regular line. I tried the MSLTSCALE, LTSCALE and all those other commands but it doenst change the line into batting... I'm working on a 2014 Autocad student version. Anyone who knows what to do?
  5. Hi All, i'm trying to make a new linetype with text, but i want the text to have a field that displays the length of the line. Does anyone know how to do this? Or if it's possible? Any help would be much appreciated!
  6. We have a couple custom linetypes that need to be loaded every time (only some workstations) open CAD. I have made sure the supported path in options is pointing to the correct location but it still doesn't retain the information once the program is closed and reopened. It is only a problem on some workstations. I have googled and tried everything I can think of. Does anyone have any thoughts?
  7. I attached the plan I am having trouble with. It is named first_plan.dwg. I created some lines with the arc tool and joined them to represent the electrical wiring in the layer called electrical wiring. I changed the linetype to a dotted and dashed style but it won't display in the model space and layout 1. Nor will it display when I hit print preview. Can someone point out to me what I am doing wrong? I am new to AutoCAD and this is my first plan. I am using AutoCAD 2015 for Mac. first_plan.dwg
  8. I attached the plan I am having trouble with. It is named first_plan.dwg. I created some lines with the arc tool and joined them to represent the electrical wiring in the layer called electrical wiring. I changed the linetype to a dotted and dashed style but it won't display in the model space and layout 1. Nor will it display when I hit print preview. Can someone point out to me what I am doing wrong? I am new to AutoCAD and this is my first plan. I am using AutoCAD 2015 for Mac. first_plan.dwg
  9. I created a linetype using a shp, however it is only showing up on my computer and not on anyone elses. Right now the .lin, .shp and .shx are all in a folder on a server where they can be accessed by anyone. Is this something that I will need to make sure is actually on everyone's hard drive and not just the server? Everyone else gets a "Bad Definition" error.
  10. My current college CAD Instructor is very loose about following a standard regarding Line weights, colors and hierarchy standards for Architecture. And that frustrates me because I want to produce drawings in class that match common industry standards. Can any of you provide a visual guide (chart) for your commonly used standards?
  11. Hi Guys, I'm creating a layer setting pull down menu, in order to migrate my cad to revit I would like to define the linewight. So far I managed to create a command with a dashed line: (defun c:layA-SEC-LIH-005() (command "layer" "m" "A-SEC-LIH-005""C" "magenta" "" "l""DASHED2" "" "") and another one with the lineweight (defun c:layA-SEC-LIH-005() (command "layer" "m" "A-SEC-LIH-005""C" "magenta" "" "_LW" 0.10"" "") but I haven't been able to create one that combines the 2 of them.. any help? Cheers Roberto
  12. I've had a problem with linetype scales for some time now and I can't seem to work it out, so I'm finally getting around to asking on here.... When I draw say a dashed line in the model space it sometimes looks broken exactly how I would expect it to look. Yet when I then set the drawing up in a viewport within the paper space it looks like a continuous line. It also plots as a continuous line. The only way I have found of working around this is to change the linetype scale of the line in question (usually to around 0.012) this then usually gets the line to display dashed as expected on the paper space. It is very trial and error though with different lines requiring different scales? I wondered if there is a setting so that they display in the model space exactly as they would display in the paper space or vice versa? Thanks for the help. Rob
  13. So... "suddenly" my trusty 'fence' linetype ( -x-x-x-x- ) no longer displays the 'x' at the correct size ( -.-.-.-.- ). It's TINY. It's not a regular linetype scale issue as I have older untouched drawings that no longer display correctly. Also, the 'gap' where the "x" should be is showing scaled correctly, but not the tiny 'x' within. I tried re-importing the linetype from a number of local files and get the same result. Other linetypes still display correctly. It won't even appear right in the manager. Help please? . (all lines in pic same type at different scales) . P.S. Other computers on the same network are displaying the same issue. Files are on a central server.
  14. Hi, I have been using a jojo shrub linetype which looks a bit like this ----V--V-V---V----V-- but comes out as a single jagged line. All of a sudden the line looks more like this (losing the V shape): ---- -- - --- ---- -- When I try to load the linetype it gives me the "Bad Definition of Fenceline1' error message, meaning all linetypes that use the .shp file are stuffed. This has only occurred while working on the file, which has been fine until now. Can someone please tell me how this happens? Something more useful than 'it could be your .shx or .shp file...' Thanks heaps. Aaron
  15. My batting linetype was showing up perfectly until I opened my drawing file today. Now it shows up as a dotted line. I tried MSLTSCALE, PSLTSCALE, LTSCALE, etc. I tried changing the scales manually. When I go to "load" it again it says "Bad definition of FENCELINE1 at line 119 of file / Users/***********/Library/Application Support/Autodesk/roaming/AutoCad 2013/R19.0/enu/support/acad.lin" I can't even access as far as "Library" via Finder. How do I reload ACAD.LIN altogether or make it work?
  16. Hi All, Generally for drawing cable, I use a p-line (generally curve or spline fit) and change my global width to the diameter of that cable. This is usually exactly what I need to show. HOWEVER, when a complicated drawing arises with several different types of cable in one particular area, I have to differentiate the cables by altering their appearance for ease of tracing that wire in a black and white printout. Before, I would offset the polyline to either side, close in the ends and fill with a hatch. This works ok, but is time consuming and the hatch doesn't rotate relative to the line. I tried to be clever with the express tools linetype creator, but autocad won out. See Pic for my attempt. It looks ok zoomed out (except for the dots in the center of the line, which need to go). However, when zoomed in, the curve is actually an assembly of straight segments that overlap on the inside and don't meet up on the outside of the curve. Can someone point me in the right direction for instructions, tips, pointers for creating "bending" linetypes? I've already accepted that I'm probably going to have to somewhat learn lisp... hit me with it. Thanks! Kyle
  17. Hey guys its my first thread out here so i hope i will find help..Well i 've currently create several layers and after i change in one of 'em the linetype from continuous to a "Dashed" , every new layer i made had a "dashed" linetype and when i tried to change it back to default , it didnt.. Help!
  18. Hi, I want to create a custom linetype for a drawing but am unsure of the best method to use. I only need this linetype for 1 drawing and so I would like it embedded in that drawing if possible. Other people may need access to this file so sending a custom file is out of the question. Should I create a new .lin file or edit the default acad.lin? I started to create one using Express Tools and when it prompted me to create / save a new .lin file it defaulted to the 'C:\Program Files\Autodesk\AutoCAD 2012 - English' folder. I was unsure if to save it here or 'C:\Program Files\Autodesk\AutoCAD 2012 - English\UserDataCache\Support', where ACAD's .lin is stored. Any idea's / help?
  19. From what i am reading, it takes some work to access a layers linetype name (LineTypeTableRecord.name). Is there another way around this? Is there a way to access the linetype name from within the layer in question?
  20. I've created my first line type (woohoo!) but the rotated V that I used as an "arrow" won't center and I'm having a difficult time understanding why so that I can fix it. I am aware that linetypes like the one I created exist but I wanted the arrows a specific size and distance apart which I couldn't do with the existing linetypes available to me (also I really wanted to try creating a custom one). In the attached picture: -the green line is the finished custom linetype -the red lines are polylines -the blue text is rotated 90 degrees, set to a text style titled Linetype (simplex font, not annotative, height set to 0 and width set to 1.0), and Justify set to Bottom Center linetypes-Model.pdf The finished linetype code is: *STREAM_LINE_W_ARROW_BIG,Stream_Line_W_Arrow_Big A,.392629,["V",Linetype,y=-.07619,s=.2,u=90],.207371,-.144393,.011213,-.138787,.011213,-.138787,.011213,-.144393,.392629,["V",Linetype,y=-.07619,s=.2,u=90],.207371 Also, this the first time I've attached a picture, I'm not sure that I did it correctly, please excuse my lack of know-how on this. I will look into it further for future use. Any help is greatly appreciated and thank you in advance!
  21. haynesc87

    Script > Linetype Replace

    Hello all The Situation is as follows : I wish to have a script that can be run on 1000+ drawings to do the following : Load a New Defined Linetype .... "NewLineType000" Select all layers that = NOT Continuous & = Colour 8 > Replace Linetype with "NewLineType000" Can anyone help me out please, many thanks in advance Chris
  22. I have utilized the "old school" Flow Line Lintetype (with the ARROW that is never really centered) for many years I have been trying to acquire the preferred FlowLine Arrow Linetype (complex with the arrow shape) So far, I have not succeeded. What is the easiest way to obtain/create this preferred linetype ? (arrow directions change with the driection of the polyline)....
  23. I want to make a lintype where line starts with a point and ends with the point and in between is continuous line. Space from points to line should be 1 or 0.5 units depending on the scale I want to plot my drawing in. Just in case there is somekind of confusion about how it should look like there is an image in the attachments. If anyone knows how to do it, pease help!
  24. Why is it that sometimes works and sometimes does not work? What contributes to this happen? I intend to apply the routine to change the scale factor of linetypes. (defun c:ls (/ ns a n i b1 c d b2) (setvar "cmdecho" 0) (setq ns (getreal "\nNew Scale: ")) (setq a (ssget)) (setq n (sslength a)) (setq i 0) (repeat n (setq b1 (entget (ssname a i))) (setq i (1+ i)) (setq c (assoc 48 b1)) (setq d (cons (car c) ns)) (setq b2 (subst d c b1)) (entmod b2) ) (princ) ) (prompt "\nType: LS")
  25. Sorry if this is a repost, although I doubt it. Can't hurt. As part of our Confuse-a-CAD-Monkey policy, we change our standards on every project. We had a custom linetype for silt fence years ago, which looked something like this: Unfortunately, every one of those pointy bits had to be drawn by hand, or at least copied, along an erratic border. I came up with a dynamic block (my first), but it was kinda clunky. Then we switched to a different linetype. Now we've switched back. I came up with a custom shape and put it in a complex linetype. If anyone wants it, here's the shape definition (in my.shp): *001,5,SILT 018,011,01F,018,0 Compile it as my.shx and put this in a .lin file. *SILTFENCE, silt fence -^--^--^--^- A,.25,[sILT,my.shx,s=.1],.25
×